V2 rtsp feedback - other cameras drop on the network

Scratch that. 3 of 5 are not working this morning.

So I didn’t disable it, but I increased the time limit of the watchdog feature. I can’t recall the time, I think I set it for sixty seconds.

What happens now is that I can see the cameras drop, but then they come back up after a few seconds. If I disabled the feature, they would never come back up. I also think I changed the reset camera feature, but I can’t recall what I set it as. I will try and remember to check it when I get home.

So now, I see the cameras come on and off and back on, but they at least now, always stay on and not lose the signal and never come back up.

Not ideal, but better then nothing. Every week or two one of them doesn’t come back up and I have to reboot it physically.

Reads like an application for a Smart Plug!

Hello,

sorry for the late reply.

This are CPU & Mem info:
Is there any other relevant info i could provide you with?
This is the default CPU activity. Nobody is connected / watching.
grafik

cat /proc/cpuinfo 
processor: 0
model name: ARMv7 Processor rev 4 (v7l)
BogoMIPS: 76.80
Features: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer: 0x41
CPU architecture: 7
CPU variant: 0x0
CPU part: 0xd03
CPU revision: 4

processor: 1
model name: ARMv7 Processor rev 4 (v7l)
BogoMIPS: 76.80
Features: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer: 0x41
CPU architecture: 7
CPU variant: 0x0
CPU part: 0xd03
CPU revision: 4

processor: 2
model name: ARMv7 Processor rev 4 (v7l)
BogoMIPS: 76.80
Features: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer: 0x41
CPU architecture: 7
CPU variant: 0x0
CPU part: 0xd03
CPU revision: 4

processor: 3
model name: ARMv7 Processor rev 4 (v7l)
BogoMIPS: 76.80
Features: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32 
CPU implementer: 0x41
CPU architecture: 7
CPU variant: 0x0
CPU part: 0xd03
CPU revision: 4

Hardware: BCM2835
Revision: a02082
Serial: 00000000d2ae9188



cat /proc/meminfo 
MemTotal:         766748 kB
MemFree:          235548 kB
MemAvailable:     401348 kB
Buffers:          128416 kB
Cached:            42412 kB
SwapCached:            0 kB
Active:           474548 kB
Inactive:          25664 kB
Active(anon):     329412 kB
Inactive(anon):      108 kB
Active(file):     145136 kB
Inactive(file):    25556 kB
Unevictable:           0 kB
Mlocked:               0 kB
SwapTotal:             0 kB
SwapFree:              0 kB
Dirty:                 8 kB
Writeback:             0 kB
AnonPages:        329256 kB
Mapped:            17540 kB
Shmem:               140 kB
Slab:              17844 kB
SReclaimable:       9020 kB
SUnreclaim:         8824 kB
KernelStack:         968 kB
PageTables:         1660 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:      383372 kB
Committed_AS:     633240 kB
VmallocTotal:    1294336 kB
VmallocUsed:           0 kB
VmallocChunk:          0 kB
CmaTotal:           8192 kB
CmaFree:            6796 kB
1 Like

Thanks!

any idea why the cpu load is so high ? :slight_smile:

Sorry, nope.

to give a reference 2 usb cams usually have a 10% cpu load

Hello. I recently made the move to use RTSP and will say my pancam has no had any issues, other than through the Synology Surveillance Station I am unable to pan it. The issue comes in with the V2 software on the Cam v2 and the wifi dropping out, and never coming back on from the fact I cannot access it from the Wyze app or the Synology Surveillance Station (DS Cam ) app. One of the cameras I can ping (2-5ms) response but still never shows in either app, sometimes the Wyze app. I will try to reset both of the devices to default and try and see if that helps. The pancam was reset by accident, but I think at the end of the day it might have actually helped in the long term. Any other ideas?

Is there a way to change the RTSP port?

I have had a Wyze Pan Cam running 4.29.4.41 for around 6 months now and this has been fairly stable when connected to Blue Iris. On the back of performance/quality I’ve experienced with the Pan Cam running RTSP and in Blue Iris 4/5, I decided to buy a couple of V2 cameras.

These V2 are flashed with what I believe to be the latest RTSP firmware (available for them) – 4.28.4.41. Unfortunately, these are no where near as stable as the Pan Cam. (I assume the 2nd set of digits in the version number equates to model?? If not, I wonder what differs between 4.28.4.41 and 4.29.4.41)

They each require that I stream the RTSP feed via VLC (rtsp://user:pass@ipaddress/live) prior to showing in Blue Iris. And then, after some time (~2 hours maybe?) both just drop, leaving Blue Iris showing ‘no signal’.

They mirror my Pan Cam when it comes to settings, but stability wise, they’re nothing like.

I tried flashing the Pan Cam firmware to the V2 earlier with no joy.

I fear my only option to have these run with the stability I require, is to flash them with Dafang, which I really didn’t want to have to do :frowning:

So i just bought the wyzecam v2 when it was $20 on amazon. I love the quality of the camera but the beta firmware for rtsp support sucks. I use Blue iris and it constantly loses connection to the camera at random times. The annoying thing was you have to start the rtsp stream via VLC before blue iris would connect. I did some troubleshooting and research and found that you always have to get the vlc stream to connect first before blue iris will connect. I found a pretty easy work around for this issue using powershell and task scheduler on my machine running blue iris:

  1. Create a powershell:

& ‘C:\Program Files\VideoLAN\VLC\vlc.exe’ rtsp://user:password@IPADDRESS/live -I rc

start-sleep -s 10

Stop-Process -Name “vlc” -Force

The command basically runs VLC and connects to the rtsp stream (please note that you have to update the rtsp url with your camera’s rtsp url. Since i did not want VLC to run and consume cpu/network cycles on my machine, i kill the process with the last command.

  1. Create the scheduled task to run once and repeat every 5 or 10 minutes.

When creating the scheduled task, please keep in mind the settings which i will type out:

2a. General Tab

Run whether use is logged on or not needs to be checked.

2b. Triggers Tab

Begin the task “On a schedule”

One Time with any start time within a couple of minutes in the future

Advanced Settings:

Repeat task every “5 minutes” or “10 minutes” for a duration of: “Indefinitely”

Check “Enabled”

2c. Actions Tab:

Actions: “Start a program”

Program/Script: “powershell”

Add arguments: “-file c:\temp\vlcrtsp.ps1”’

Note that the arguments path should be where you saved your powershell script. I saved mine in c:\temp\ with the name of vlcrtsp.ps1

I’ll try to answer any questions that come up but I have been using this for the past week and the rtsp stream via blue iris has been on since.

You can set the “Hardware Acceleration Decode” to “No” under the Video tab of the camera’s settings in Blue Iris. This will typically fix the issue with needing to open VLC or creating a custom program/code.

I disabled my scheduled tasks and hardware acceleration decode. I have seen the wyzecam disconnect from blue iris on occasion but it reconnects without needing to start VLC. Thanks for the tip!

The two things I’ve done is:

  1. Use my router and the MAC address for each camera to assign a static IP address
  2. Use my NVR software to take a timelapse picture every 20 seconds for each camera

I then use a PowerShell script to create timelapse videos each morning for all my cameras.

This way the every 20 seconds keeps the camera alive, and I get a very good timelapse from all six cameras every morning uploaded to one of my YouTube channels.

1 Like

I have 2 x V2 cameras running on BI. One of them has been pretty rock steady for a month, but recently I noticed that BI can’t connect to it. What I need to do is “regenerate RTSP stream” and then BI will pick it up. This is happening on the V2v2, but not on the V2v1.

So the V2 Wyze cams have 2 versions, sensors are different. I don’t know how and/or IF this could make a difference in the way the RTSP stream is handles, but I presume it could since the sensors use different power and also likely have a different CPU “fingerprint”

I’m using BI5 btw, and also using FW 4.28.4.41 (beta?).

Regarding the FW, people are posting that they are using .48 FW for RTSP? Where is this? I checked the official RTSP post, and it’s not there, not labeled in any case. Also, I read somewhere that the RTSP FW is not in beta, but rather official.

Can someone point me to where this all is?

Thank you!

@teredactle You can find the RTSP FW in this support article here.

That’s v .41. There is another link lower “please test this”… Is that v .48??

I’m trying to find out for you. :+1:

I saw the post and replied to @StopICU33- I think I have that file stored on one of my drives from when I was testing RTSP on one of my cams. If you send me a private message with your email I will be glad to email it to you.

1 Like