V2 rtsp feedback - other cameras drop on the network

I’ll add my 2cents here.

got v2 cam Just flashed using the firmware with rtsp. No problems with that. Used 32 gig card, formatted in fat32.

Went to the advanced settings and turned on rstp and enter a username and password and it generated me a link and I integrated that into my blue iris server with no problem there.

My other two wireless cams, Dlink 936L starts dropping off the network. If i drop the quality to SD, it helps a little bit but not much, just slows it down. It’s almost like a countdown; I watch the bitrate of my dlinks and the wyze countdown to 0 and all cameras freeze up and in a few seconds, the camera comes back and bitrate climbs up again but it starts over. Until I unplug the wyze completely, then the dlinks return to normal.

What’s odd is my other two foscam and amcrest camera don’t have this issue. They are all connected via 2.4 ghz.

When it does work… the lag time is anywhere between 3-6 seconds. choppy and frame rate is inconsistent… at either quality setting.

1 Like

I had a very similar situation one of the times I connected to my RTSP test cam, all the others went silent (stuck on connecting step 1)in the app for a bit. Even my smart garage door opener went dark one time, though that could have been just a bad coincidence.
Hasn’t happened every time though so it would be hard to troubleshoot on my end. I use a Unify AC-PRO for my wifi and its only at about 23% device capacity and on a basically unused channel so it shouldn’t be my network getting congested.

It seems like you could be having network or server issues if your other camera’s are dropping their connection. You would need to do some troubleshooting.

I can give you a base line to work from that might help. After updating the firmware I started to see the camera loose connection in BI using Beta Version 4.19.4.48 on Wyze Cam V2. This went on for quite a while and I assumed it was network related but the camera said it had 80-90% signal strength. I did a ping test from the the BI server to the camera over 5 minutes and the pings latency was erratic from 4ms to 1000ms. The other Wyze Cam that I updated did not show the same symptoms. I tried a reboot of the camera and it resolved the erratic ping issues but would still get many frame drops. Both camera’s were performing the same now but I still had frame drops and 2-4 sec video delay. I changed some settings that seemed like it stabilized the frame drop in BI meaning it did not eliminate the frame drop but it did seem less erratic. Both VLC and BI performed the same when viewing the stream.
image
This is only day two for me running the new firmware. The camera’s stayed up over the night but did drop the connection twice once for less than a minute and another time for almost 4 minutes. This could just be wireless communications problems but I’m not in a highly congested wireless area so seems weird. I’m thinking the 2-4 second delay and frame drop is probably the current state of the beta at the moment. I don’t care for that much delay but the frame drops are more concerning. That would probably be a deal breaker for me as I can’t deploy a camera solution that would end up missing the theft or vandalism because it was during a frame drop. I hope they continue to improve the beta, so far a job well done!

1 Like

I am also having some issues with the RTSP firmware. I run BI and it frequently shows frame drops and dropped connections. Sometimes the connection will come back but more often than not, i have to turn RTSP off and back on again in wyze app settings, then it will reconnect. Most of the time it does work good outside of these hiccups. Thanks for releasing the RTSP firmware and look forward to updates for it to be fine tuned.

I had previously posted about dropped connections in Blue Iris. Most of my Wyze cams were connected to my UniFi access point. I tried connecting some of them directly to the modem’s WiFi. Even though the signal strength is a bit less for some, I have not dropped any cameras since making that change. So it would appear to be a network issue with my access point that caused the problem.

How do you connect to the modem’s wifi? I have the surfboard modem from Charter and a Asus RT AC5300 WIFI router.

Hmm, I wonder if there is some default setting in our Unify equipment that is causing this? This is way out of my area of expertise if it is.

question, have you tried to add your wyze cams a static ip? I know I had this issue a while back with some dlink cams, They were fighting for IP’s and knocking each other offline, I recall adding them static ip or reserved ip in my router settings and the nonsense stopped. my 02./

Yeah all my stuff on my network is either static or reserved DHCP. Did that a while ago for the exact reason you mentioned.

I am also using static IPs. Jreink01, I use AT&T, and their modem incorporates a router. I have five Wyze cams, two UniFi APs, and also a Netgear range extender that helps with a spot in my back yard. Initially, I had one Wyze cam on the Netgear and the other four on the Unifi APs. Unfortunately, I do not know how those were allocated between the two APs. As I said earlier, I was pretty consistently experiencing loss of signal in Blue Iris, even though the Wyze app showed the camera’s signal to be fine.

So then I moved the one cam off of the Netgear extender to the AT&T modem/router. I moved two other cams from the APs to the modem/router. And for a while there were no issues. That is when I made my previous post. Since then the occasional loss of signal has happened. It is not nearly as bad as before. And all of the lost signals have been on cams connected directly to the AT&T router (of which there are three).

The only other thing that I noticed is that when I experimented with setting Blue Iris to record continuously, as opposed to only triggering with motion, I did not drop any cameras.

Something I have noticed when my cameras lose signal in BI is that when I go into the Wyze app for that particular camera, advanced settings, RTSP is turned off. Sometimes I am able to just turn it back on, other times I have to completely close out the app and open back up, then I am able to turn it back on so I would have to guess its not really a network issue but some kind of issue with RTSP inside the Wyze app. Something else to note is that I have 2 other version 1 cameras that, even though not compatible with RTSP, do not lose connectivity and I have several foscam cameras in the BI software that do not lose signal either. Just to explain my setup, I have charter surfboard modem with Asus RT AC 5300 which is one of Asus’s top tier wifi router. I currently have 25 devices connected to 3 networks (1 2.4 and 2 5 networks) and was told by Asus that this particular router can handle up to 250-300 clients with no issues so I highly doubt that just 25 devices would cause network issues. My internet speed is 115dl, 20upload speed.

UPDATE
I went into my router settings and set up the three version 2 wzye cams to static ip and its been 48 since I did that and not once have I noticed has the cams lost signal in BI. So far so good. I have noticed though when reviewing video footage that frames skip quite a bit.

Update
Thank you Arthur for the response. Just wanted to let you know about my setup, issues and what I have observed. I currently have 3 version 2 cameras running RTSP firmware, a powerful labtop running Blue Iris, and a very good router Asus RT AC 5300, have Charter internet with 100 down, 20 upload. When first integrating them into Blue Iris I was getting disconnects in Bl very frequently. I set up a static IP on each of the cameras and now it has been rare for it to disconnect. When it does disconnect, in the Wyze app its still up and running. I have to turn off RTSP, or, if its already off, it won’t let me turn it back on, I have to exit out of the app, then it will let me turn RTSP back on, a few seconds later, I have a good feed in BI. I do have issues with the frame skip issues as you mentioned. I hope anything I have mentioned can help you to continue troubleshooting these issues. I have been in contact with Blue Iris support different times over the last few years so if the issues prove to be beyond your firmware, app, hopefully we can coordinate with them to work together to get these issues resolved. Thank you for releasing this long awaited feature and look forward to the final build. If I can help in any other way, please let me know, thanks.

Wouldn’t the static IP only matter for initial connection? Once DHCP issues an IP to a MAC, that doesn’t change and shouldn’t matter until TTL expires. In any event, it wouldn’t hurt to make the IPs static and certainly benefit applications like BI that probably have the cams identified by IP.

I do observe the dropped frame issue while viewing the RSTP feed directly in VLC. Perhaps @WyzeGwendolyn or someone in Wyze dev can suggest adjustments to eliminate the effect. In fact I am trying to play with values since it is a lot worse in my iSpy application than in VLC itself. iSpy uses a VLC plugin.

  • In comparison to the feed via the WyzeApp, RTSP is clearly dropping frames.
  • The delay before the stream seems to update is reasonable I guess at 1 - 3 secs.
  • One more interesting point. Maybe someone can help me understand, but the perceived dropped frame(s) do not match the dropped frame count in the VLC media statistics windows. I perceive a dropped frame, the count does not increment, however I have seen where the picture does not change at all, but the count increments. Does anyone know if this is just a delay in VLC reporting the dropped frames or is there something else to understand about dropped frames?

I’m sorry, I’m kinda useless when it comes to RTSP right now. I’m working on learning but I’m not very helpful here yet. I’ll see about getting someone more knowledgeable in here. :slight_smile:

3 Likes

@WyzeArthur is our guy! :slight_smile:

2 Likes

ok, where is he?

Hi there. Sorry for the late response. To your questions, I am aware of the frame skip issues, and that it is worse in certain players, and that RTSP feed pushing other devices off the network.
If you run into any issues with RTSP, please check if the video is still available on Wyze App, and try to run the same URL in other players. If both Live View and other player work well, it is not likely a problem on our side.
RTSP is a open, standard protocol and things should be smoothly integrated with any compatible device and app. But unfortunately that seems not always the case.
It is a three part process of how videos work: (#1) camera generate the video feed, (#2) data transmitted from camera to the player, and (#3) players decode and play the video.
With Wyze Cam feed playing on Wyze App, we can control the process from end to end, troubleshoot and optimize the performance.
But with RTSP, we cannot really control the latter 2 parts. Data transmission (#2 part) largely depends on the router and network configuration, and players (#3 part) belong to other companies.
That being said, I am still collecting information (error codes from players, e.g. 8000274D on Blue Iris, router configuration changes that solved the issue) and trying to troubleshoot with our engineer. Please message me if you have such information.
It is really hard and could take a while to fix. Thank you for your understanding.

2 Likes

Thanks for the reply and enlightenment @WyzeArthur . I don’t know about the others, but I also have other RTSP cameras streaming to the same applications the WyzeCam has been added to (iSpy on PC & IPCamViewer on smartphone). I’m just saying if the other brands are smooth and stable, then its achievable.

Great job so far though. Thanks so much!

Tested the RTSP feature lastnight but its kinda laggy and theres a long delay time compared to the original streaming from the mobile phones. Anyone else noticed that?

I’m more worried about the fact that it is randomly kicking devices off the network. I’ve never had a single non wyze device drop from my network but within 10 minutes of installing the RTSP firmware my smart garage door system went offline for the first time since I installed it over a year ago. It went offline again this morning when I was trying to leave for work. I unplugged my RTSP test camera and the garage door came back online immediately.

I’m not sure what info I can provide to troubleshoot, I’ve been building networks for over 20 years but my certifications expired after I left corporate IT 15 years ago, so I’m woefully out of date. If anybody has any ideas here is a rough topology: I have about 28 devices, some 2.4, some 5 Ghz, all connecting to a Unifi AC-PRO that is hardwired to a Google Fiber provided router that has its built in wifi disabled. All devices on my network are either reserved DHCP or static set IP (wyzecams and garage door are reserved dhcp). I am not running QoS anywhere and haven’t strayed from default settings when it comes to network performance options.

2 Likes