V2 rtsp feedback - other cameras drop on the network

new to this forum but had the same problem with the wyse cam dropping - used the settings rom another wifi cam i had and boom no more dropping of the network for the rtsp stream - not much lag either on blue iris i will post when i get home from work

i guess using http in the setting vs rtsp worked really well for latency and changing the frame rate to 30 fps made a huse difference in the ability to keep the stream alive .

I havent seen it drop to that nosignal page in 4 days b4 it would drop ever fre hrs some times even minutes

sorry new users can only put one image in a post

1 Like

1 Like

Thanks for that. I’d like to try it out, but what firmware version are you running?

How does this work as HTTP if the protocol provided is RTSP? And do you still have the /live at the end of the URL? I tried setting up in iSpy as HTTP using your example but it didn’t work for me…

*Noticed your option to send RTSP keep-alives while doing HTTP… Guess I don’t understand enough about protocols for that to make sense to me…

no live at the end just the IP of the cam. yes im using firmware version 4.29.4.40 rtsp beta 2.
it still uses RTSP but configured differently

*The /live goes in the video path
*Port :554
*not sure if the ONVIF port is really relevant
*Audio sucks
*havent tried the PTZ control

  • stable video
1 Like

Yeah, this doesn’t work in Blue Iris. I have tried several iterations, including exactly like you have shown. Are you using BI 5?

1 Like

I was able to use the settings post by @richie.digital in BI. Note that you need to change the RTSP port from 8554 to 554. I missed it the first time, and got no signal. Changed it, and it works now. Am still testing the stability part though.

I also have issues with other cameras dropping, but it is because my 2.4ghz band is dropping completely when RTSP is being used from the Wyze cameras. I can leave it on the settings, and everything is fine. The moment I begin to stream one of the cameras via RTSP, my 2.4ghz band goes down and everything drops from the network. I can stream other cameras via RTSP, and have no issues. Just when I stream the Wyze. Using VLC, iSpy, and/or iVideon to stream. Testing out the 3 to see which I like best, not using them at the same time.

Scientific proof.

Yeah, i finally managed to get it working with those settings (thanks!) but like others, I am having connectivity issues. The camera worked great the first week, then it started to drop and drop constantly. I engaged support and it ended up being the camera itself. With support I flashed the firmware back to the latest version and was still getting drops just using the app. Then we did some network testing and the network is fine (I hope, it’s what I do for a living!). So they sent me a new camera. I just got it yesterday, so I plan on trying again this weekend.

My issue is that they state that they cannot continue to support two protocol paths for the development of the feature rich app and the RTSP for those of us that would like to use that with our security grid. But they already have. They spent the time and created a RTSP firmware and offered it to people. The very least, the company should finish development to a stable, working version. We don;t need anything fancy, just a stable release. The beta they tossed out seems to be anything but stable.

Otherwise I like the cameras, I am just not a huge cell phone fanatic and I like my recording history to be all day, every day. Not limited to the size of an SD card or otherwise, I don’t sit here staring at my cameras on my phone all day :slight_smile:

1 Like

Cool, keep us updated on your test result if there’s just the camera’s issue. I agreed with the RTSP firmware path. I prefer it supports RTSP well and stable. No motion detecting or any other fancy feature is needed, since people needs its RTSP to be connected to somewhere which likely to have more computing power and advanced features,

1 Like

Does it sound like RTSP dev is shelved for the moment?

This update didn’t sound that way.

Same information as the original one, just shorter. The only difference is this statement says they are working on it. If it was truly in beta and truly being worked on, there would be updates as they make changes. That is the entire purpose of a beta version.

really happy to find this thread, i was going sort of crazy. I want to use motioneyeOS on a raspberry pi3 to supervise 4-6 cams.

I only got all 4 cams working at the same time for a couple seconds, Then one went away. On VLC opening each one independently works, but as soon as i started to launch several they crashed all the same.

Before that i was using only one cam on a network and it did always end up crashing, even though she was the only one on the network. It took days more than minutes though.
Looking forward to a correction!

my cam doesnt drop frame any more

they just released a beta 2 firmware https://support.wyzecam.com/hc/en-us/articles/360026245231-Wyze-Cam-RTSP

2 Likes

OK. Off to try beta firmware.
will post the results.

OK. After upgrading the cams stay connected. Performance is not optimal but I guess that has to do with the raspberry pi3 handling the 5 video streams.

No more disconnecting​:+1::+1:

1 Like

Could you please give us the specs of your pi3 system?

RTSP instability issues with Blue Iris V5. (Here is how I solved the issue I was experiencing)

I hope this helps others. I am tagging some people that I came across reading through the various threads on this forum to give them a heads up and thank them for their posts.
@WyzeArthur
@WyzeGwendolyn
@gemniii
@richie.digital
MMediaman
mtuck

Here is my setup.
-Blue Iris version 5
-4 WyzeCam V2
-1 WyzeCamPan
-2 Wyze Sensor Bridges
-3 Wyze Contact Sensors
-1 Wyze Motion Sensor
I am using the beta 2 version of the RTSP firmware.

I have been experiencing instability with all five Wyze Cameras hooked to my Blue Iris V5 with the following settings.
GENERAL TAB
-Max Rate = 15fps

VIDEO TAB - Then under ‘Configure’
-Address = rtsp://192.168.x.x/live
-RTSP port = 554
-Discovery/ONVIF port = 8999
-receive buffer (MB) = 10
Radio (checkboxs) with checks are,
‘Send RTSP keep-alives’
‘USE RTSP/stream timecode’
‘Skip initial HTTPS DNS and reachability tests’

AND THIS IS WHAT I BELIEVE IS THE WORKAROUND (at least it worked for me)
WATCHDOG TAB
uncheck the box ‘Detect loss of signal’

I have not had a problem since i implemented this yesterday. Time will tell. I will report back if i start having the problem again.

3 Likes