Unable to perform network setup of Wyze Robot Vacuum

Just to close the loop on this: after reading all these helpful inputs I accessed my router and disabled the 5 ghz option leaving only the 2.4 Ghz band (Is that the right term?) AFter the "connecting mode stalled twice I persevered and I now have an operational robot vacuum!

After 3 days of pulling my hair out, using an older Android phone LG Astro worked liked a charm.

I have Google WiFi mesh which uses 2.4 GHz and 5 Ghz arbitrarily without your control. I tried walking away to find a spot between the bands, turning off mobile data, disabling auto-connect, using guest network, and a promising hotspot trick. Started to give up and preparing to return the sucker but then came across an advice to use an older phone which cannot connect to 5 Ghz. Have a bunch of them but the first one did the trick.

When opened Wyze app on my newer phone which refused to connect (a 3-year-old Samsung Note 8), vacuum already showed up and offered normal control. Did my first happy cleanup.