Wyze Finally Works With Google Assistant!

Got the same issue and it’s really a pain in the ass :frowning:

I tested and my Pan Cam took quite a while but eventually came on. My v2 will not connect. I’m using nest hub. Will try again in a couple of days.

Nope, no go on Google, tries and tries but fails.

1 Like

It doesn’t work on any of my google displays around the house it just flickers a black screen and keeps buffering when it does works only does it for a short while after 2 minutes waiting

1 Like

Same here, buffers flickers and stops.

1 Like

Hello

Couldn’t understand why is it so hard to recreate the issue. Can we have an engineer provide a status update ?

I am in the same boat. I have 6 cams, and nothing works (it was trying to connect, and saying the camera is not available for streaming or something like that). However, what i found out is that, if you unlink your wyze cam account from google home app, and relink back in, it works for a few weeks. and I have to do the same thing again when it does not work. very annoying.

Hello

For me re linking made no difference.

Thank you for letting me know, folks. I am continuing to follow up for updates but don’t have anything concrete to report back other than that we and the partner teams are trying to get this figured out.

2 Likes

Hard to believe that this can’t be reproduced easily. you have multiple users with multiple threads all with the same complaint. I can only stream my cameras to the nest hub very rarely and that is after long lag to load ( minutes) and then only for a few seconds. This is despite dropping the quality to 360. My home wifi is google mesh and I can test throughput to both the cameras and the hub- both look great. I can also prioratize the bandwidth to the hub- makes no difference. This clearly seems to be on the wyze integration side since the apps work flawlessly on my network as does tinycam pro. You advertised this as working which is why I purchased the nest hub.

1 Like

Exactly same complaint from all of us. This issue affect my desire to purchase additional products. Thanks for sharing.

1 Like

I could not agree with you more!

I hear your frustration. This is something that we are very aware is causing a lot of pain and we are working on it but in order to give you some perspective, here is what is happening a little bit behind the scene.

We have been able to isolate the problems. We know that not all devices are being affected. So the problem is not systematic. We have collected several users information to be able to troubleshoot and have been ab le to reproduce the problem internally.

So far, we have been able to identified the problem but not been able to root cause it. Here is our understanding:

  1. Alexa users do not have that problem. (it’s important and you will see why later)
  2. We are using an RTMP stream from the camera to a self hosted Wowza server.
  3. The Wowza server is transcoding the RTMP stream into RTSP for Alexa and into MPEG-DASH for Google Home.
  4. Google Home is known to have a very strict implementation of the video protocols.
  5. Using VLC, we are able to view the MPEG-DASH stream properly without dropping anything (video or audio)
  6. The number of parties involved to get that system up and running is 6. Yes 6 different companies and subsidiaries.

Knowing those points, we still have too many scenario that can be the source of the problem:

  1. Does Google have a bug in their rendering engine? We tried to troubleshoot this kind of issue in the past and the result was just that the video stream adheres strictly to the video standard. It takes also a very long time to be able to monopolize the right resources on Google side to get the troubleshooting required deep into the google nest hub. Reason being that we are using the standard display renderers.
  2. Does the Wyze camera has a bug? It’s possible that we are not sending the information in the RTMP stream properly. It is unlikely but possible. The library that we are using is a 3rd party library and not something that we have developed ourselves from what I understand… Moreover, it is working just fine with Alexa so the RTMP stream is most likely correct.
  3. Does Wowza has a bug? From all we have seen above, it sounds like it and something is happening in the transcoding. But again, are we getting the proper signal out of the RTMP streams for transcoding to MPEG-DASH? We don’t know for sure.

So what is our working theory: Wowza is not transcoding to Google’s standards. We had that in the past when we tried to implement HLS for Google Home but had to fall back on MPEG-DASH.

As a consequence, we have opened a high severity ticket with Wowza to try to get to a resolution. Problem is: we are at the mercy of Wowza Tech Support at this point. I have to spare you the details but that communications is not the easiest because of geography and contracts…

What’s next?
Short term: we are continuing to push Wowza to help us troubleshoot the problem and help us address the problem.
Mid & Long term: we are working on implementing WebRTC to replace the complete stack that we have currently in place. This would give us way more control over the entire stack and would also cut some of the systemic issues that we have with the current implementation while allowing new set of features (hello local connection and two way communication)!

14 Likes

This is perhaps the best, most honest response I have ever heard from a dev team. Anyone who wants to moan and complain simply doesn’t understand how difficult these problems are to solve.

Mod Edit to correct spelling

3 Likes

Thank you for your answer. Ironically, when I was using google home hub as a beta tester, it worked great. It responded every time, and frame rate was also very good. What is different comparing now and beta period? Only thing I can think of is the number of users since you limited the number of beta testers back then. Just curious…

1 Like

That’s the thing. Not much.

We have more users but we scaled the servers up so that should not have any impact. We found some memory issues but it does not seem to impact the performance.
We have made some changes to the firmware of the camera but did not touch any of the code related to the RTMP server.

So we are kinda baffled that it has started to not behave properly.

Hopefully we can figure this one out quickly.

3 Likes

Thank you for the response and being transparent on what is going on behind the scenes.

If it helps, my Wyze cameras were streaming seamlessly fine on my chromecast devices when I bought them back in September 2019. It wasn’t until December 2019 when I tried to stream it on my nest hub and noticed the problem. If you think wowza has a bug then perhaps they made a change on their end between that time period that effects certain version of chromecast and nest hub.

My nest hub is on system firmware version: 184686 & cast firmware version: 1.44.184686.

And my Chromecast is on cast firmware: 1,42,183786

Can anyone on this thread with a working system confirm if they are on the same firmware version?

Also I know there was a firmware upgrade in the cameras during that time.

2 Likes

Appreciated the effort and detailed report ! Will support your products till you resolve !

Please keep it up !

Same here, with all 6 of my v2’s streaming to a Gen. 3 Chromecast dongle (plugged into Sony TV). Streaming via GA worked perfectly when I first set it up (Aug/Sept timeframe?), but starting in late Nov (a guess) the problem started - namely, it initially connects, after about 15-30 seconds the Live stream plays on my TV, then after a minute or two the “buffering” starts.

1 Like

Good info, similar to my experience …