Wyze bulb schedule syncs to time zone of app, not time zone of router

Got all my bulbs set up on a series of schedules. But when I physically left the time zone and opened the app, all of the scheduled rules began to run on the time zone where my phone/app is, not the time zone where the bulbs/router are.

Not exactly helpful for setting up an away schedule for lights to go on and off. I’ve seen there is a sync option for the cameras, but I have not seen anything about the bulbs having this problem. Did I miss something?

1 Like

This is a serious issue for someone who travels extensively to different time zones! (and a serious design oversight!). Bulb / Thermostat / Camera / Door Locks … should be assigned a TIME ZONE during the setup process. It should not matter what time zone the user interface device is in. I have a dozen bulbs with AM and PM schedules for each that vary on different days of the week!

Setting up schedules is tedious enough - but to have to re-do them every time I move time zones is just not acceptable. Wish I had known this before purchasing WYZE devices.

1 Like

What happens when someone who I have shared a device control with accesses it from a different time zone? This issue will start to get a LOT more attention once folks start traveling again!

1 Like


Didn’t even think of that, excellent point.

I seem to remember this happening to me and resolved it by going to iPhone/iPad Privacy/Location Services and setting the Wyze app Location Access to “Never”. Not sure if that still works. There needs to be a way to lock the app to a time zone, or a time zone awareness toggle like Calendar has.

1 Like

Thanks that’s a good suggestion will give it a try.

FWIW, I also noticed that when I am on cellular data (not wifi) in my “home” time zone, an IP address check occasionally reports my location (ie my cellular provider location) as being in a neighboring state, which is another time zone. Turning Wyze location access to “never” seems to keep that from becoming a problem.

1 Like

Again, great advice thank you! I went ahead and turned it off. I am not using anything that requires the app to know where I am anyway. No reason to share my location.