Robot Vacuum Software Dissapointment

Hey you may want to see if Wyze has programming positions open so you can help them sort out the issues.

Some posts in this thread have been treading on the very edge of the Community Guidelines. None have been edited or removed so far, but this is a reminder to please address the subject and not each other. Please flag posts that violate the guidelines so the moderators can respond appropriately.

Key points from the guidelines to keep in mind:

  • Remember to criticize ideas, not people
  • Please avoid name-calling
  • Don’t divert a topic by changing it midstream
  • Keep posts relevant to Wyze

Important sections:

Always Be Civil

Somtimes We Disagree

1 Like

I wish I knew how you are splitting rooms. I have found no way to manipulate rooms at all, except, of course, using virtual walls (blocks) - which are not very flexible - to prevent the vacuum from entering an area. When my house was mapped, only one room (my laundry room) was identified as a single room. I have been unable to discern any way to split other rooms. It’s too bad that the documentation for using the app is non-existent, because if there are ways to use it more fully, it isn’t intuitive. That said, I’m still very happy with my vacuum, and will become happier as functionality expands.

@brewstew I have a similar issue as you. I think they push the new beta features out to small groups first and slowly expand it, which is probably why we don’t see that functionality to split rooms yet.

Today I reset the map, shut all the doors to rooms I don’t want to map, and kicked off a cleaning. I was hoping it would run the perimeter and map out the rooms, but instead, it cleaned the room where it started, then moved around the house and cleaned in stages, never moving all the way across the available space. About half-way through, it got stuck under a bookshelf (in a room that I previously had blocked off by a virtual wall) and it asked me for help and shut off. I pushed it back out from under the bookshelf, and made the mistake of hitting the home button instead of the power button. Back to the charger, with no map retention. So I’m now kicking off yet another cleaning cycle. Since it will run out of juice soon, I can see this taking all morning long. Arrrggghhhhh…

Keep trying. I got lucky and it ran the perimeter and I finally got everything mapped.

Just wanted to update that my 2nd run was 7 min shorter (probably due to the initial mapping) and had no issues. I do have hardwood floors and the living room, dining room, kitchen and guest bath are all on the same floor. Many obstacles and it works like a charm. Hoping everyone else gets their issues resolved but i am really enjoying this vacuum and it has worked flawless from setup to 2nd use.

How many times did you try before it worked correctly? I just deleted everything, map, cleaning history, the device itself, reinstalled it, and started a run. I worked for a few minutes, following the wall like a blind mouse, but about a quarter of the way through the house, it decided to turn around and come back to clean the room it is docked in. I’ll let it fully charge and try again, but this is really frustrating.

Can anyone confirm that selecting a cleaning schedule for 1 room results in only that room being cleaned?

My experience has been to have the vacuum clean from the dock to and including the designated room. That takes much longer than I want.

I’ve experienced both ways. I’ve also experienced where instead of cleaning the scheduled room, it cleans the entire mapped floor.

If you are asking me one time for everything. Initial setup through 2nd use has been flawless for me (again i have wood floor so not sure that is variable helping). I stated prior i have lived through the wyze software growth on the cams and understand for the price point it could take some time. The vacuum is working as i wanted and a doing a great job (cleans really well).

At least 15 times. I moved the base to be centrally located on the outside wall vs being on an interior wall on my open floor plan. Not sure if that helped but this was about the 3rd or 4th time I tried from this location. Once it just cleaned the room it is in and got stuck under the sofa. I’m also on the beta firmware and app.

Update for Run 3. 11 more minutes shaved off (looking at almost 17 total so far) and still grabbing all the doggo hair while avoiding the obstacle course that is our main floor. Wife loves is nagging me to write a positive review on yelp or the like (I plan to after at least 5 or more runs). Could not be happier and for the price point and my interaction to date flawless for my use. Thanks Wyze cant wait to see whats next (buddy keeps going on how great the noise canceling headphones are!).

Another update. My only requirement of this vacuum at this point is to follow a daily schedule to vacuum my laundry room, which contains the cat litter box. Sometimes it works, sometimes it wants to clean the whole house. This morning, it started on the whole house, so I sent it back to the charger, deleted the schedule, and set it up again for a little bit later. When it kicked off again, it headed straight for the laundry room, did it’s thing, and docked. Maybe the firmware update I got yesterday messed something up? Hopefully, it will do what it was asked to do tomorrow morning, without any intervention. Hopefully, I will soon get the ability to name rooms/areas in my house so I can have the vacuum clean the kitchen without also cleaning the whole rest of the downstairs. Right now I am limited to commanding cleaning of only the rooms which the robot has identified, which is inadequate, or just cleaning the whole house, which is certainly unnecessary on a daily basis.

Since I have restricted the robot vacuum to one portion of the lower floor of my home (< 900 sq ft), it has performed admirably. I shut all the doors, remove hang hazards, block off entries to the underside of cabinets/sofas, and remove rugs, By the time it docks, it is at 17% battery. I will probably just buy one for the downstairs bedroom so I don’t mess up the mapping, which is working great for this restricted area.
I was sanitizing my cell phone with my UV sanitizing cabinet when it dawned on me that it would be cool if this vacuum did that too. I am sure that would not be pet/people friendly, but you could run it when nobody was present in the room. This would definitely run down the battery though. I guess a mopbot accessory would be nice too.

I understand but you are comparing robots that are old and inferior to the hardware on this robot. I am currently comparing to 360 S6. They have the same hardware. I would say the Wyze hardware is equal or better than the 360 s6. Its the software that’s the problem. The 360 s6 is far superior in that’s aspect. You can pick what room you want cleaned. It will give you no go areas. In short 360 s6 will go vacuum that area of my choosing when I want and not get stuck. The Wyze vacuum can not do that as of right now. Right now it compares to my old Rumba without lidar or smart mapping and gets stuck. You would be far more impressed with a robot that has Lidar and the correct software. I do think Wyze will come out with a update to fix that. I am also a big fan of Wyze and own multiple products that all work great As of right now the Vacuum is not their yet.

Here’s my take - and I’ve owned a lot of Wyze products. They have a history of getting good hardware out quickly with software that is arguably not fully developed. But they DO follow up with continuous improvements to the software/firmware side of things. If you figure out the best use for now in your situation, the software will follow and it will get there. No affiliation.

1 Like

There is also a brand new app update that came in for my iPhone which I haven’t explored yet.

Just updated the firmware and app to the latest beta and finally the map editing function was there. The original mapping had my kitchen, family room, living room, office and a hallway all as one room. Using the map editing function I was able to split the kitchen/family room and living room/office/hallway into separate rooms. I was also able to merge the master bedroom/master bath into a single room. So far I’ve only had a chance to clean the master bedroom/master bath but the WRV worked perfectly. I have two keep out areas in the master bedroom that kept the WRV from getting stuck. Each area runs about an hour so no recharge is needed in the middle of cleaning. You might give the beta software a go, it has pretty much solved my complaints about the WRV. Now if they only had multiple floors…

Downloaded the beta app a couple of days ago, but no new functionality, yet. Firmware update yesterday was 1.6.95. Plugin Version is 1.6.1. Knowing that the map editing function is coming is great news! WAIT - as soon as I published this, I realized that I now have map editing! Now we’re talkin’!