WyzeCam v2 often doesn't work with Schedule Rules

Ok, so I have a v2 and v3 camera set up and the v3 is fine, but v2 will not always work with the schedule I have set up in the app. The shortcuts/triggers I setup with custom actions work fine, but schedules will often be completely or partially ignored. I say partially because sometimes the camera will turn on, but motion detection and/or notifications won’t turn on. Or when the “On” schedule ends, it won’t turn off the camera but does turn off detection and notifications, but sometimes all of the schedule items work correctly both when it activates and deactivates, but this is rare.

Can you post screenshots of all your applicable rules pages, and make sure all actions included in the rule are included in the screenshot. If possible can you also upload screenshots of your rule history page covering the times that you’re having issues, and make sure to open up the drop-down on the rules on the history page by clicking the little icon on the far right to expand that line.

1 Like

Hi,

Thanks for this feedback. Could you please go to app → Rules → Lower right corner “History”. Are you able to see the schedule of this V2 has been running? You can click on each process to see if it is successful or fail. If you can see that schedule is triggered at right time but some of functions still don’t work. Please help me submit a log related to this camera and we will take a look.

Thanks!

I don’t see any rule history.


CC @WyzeDesmond

which app version you currently use?

You can only access history via account > rules > history.

4 Likes

Funny that neither of the others mentioned this. Also seems like an oversight that both pages are identical EXCEPT the two buttons at the bottom.

@WyzeDesmond:

Here’s some history for one of the nights the v2 cam didn’t work, yet all of the items show “succeeded”. I am also on the latest build, according to the Play Store; v2.34.0 (75).

Got it. Could you please submit a log for this? And the rules you are missing here is sep 5? Any recent time (in the past 24 hours) that the camera fails to trigger since logs for Sep 5 might already been overwritten. Thanks!

2 Likes

My first recommendation is to remove the actions “Turn on motion detection” and “turn on notifications” from this rule and only use “turn on camera”.

Now go into the camera device settings and enable motion detection and enable notifications. I recommend this because when the camera is off. It doesn’t detect motion or send notifications anyway so using only the one rule action to turn on the camera is all you should need. Are there any actions that are below the ones above, that you’d need to scroll down to see?


The rule logic is that at the start time, all the included rule actions will be blasted at the camera and things may not be received in the order that they should be or missed because they are all being received at one time. Your rule history even shows this may be happening. Compare your action list with your rule history list.

The above may be what is causing you to experience this:

I don’t have access to the logs or any behind the scenes data, I just know what I have experienced or seen happen in the forums.

3 Likes

I don’t have anything as obvious as that, since the night of Sept 5th it didn’t turn on at all and got no captures (events or local recordings).

The next time I run into this issue I will submit logs so that it’s fresh (I see in the support area of the app where I can submit an issue with logs).

@Omgitstony Thanks, I will try that for now. Though it definitely still seems like a bug since the v3 hasn’t shown any of the issues. Seems like it should do the actions in order, rather than random or attempt all at once.

2 Likes

I totally agree. I have Alexa routines that fire off in an order. But by trimming down the rule actions will cut out this worry by only using the turn on rule action in the scheduled rule and setting the camera settings to have notifications enabled and motion detection enabled.

1 Like

OmgitsScience!

I just created a shortcut to visually test the rule order and commands received issues.

I first created a shortcut named “test on” with “turn on” and “turn off” one of my bulbs. See below:

With the bulb off, I waited a bit after I created the shortcut then pressed the shortcut. In all, I pressed the shortcut four times, and the bulb only turned on twice, and remained off the other two times. Each time the bulb turned on, I would click the button next to the device on my home screen to turn it off.

According to my rules history, this is what history showed with some marks to show which shortcuts actually turned on the bulb or not.


Note the orders of the actions changed when shown in the rules history compared to the shortcut rule itself, and when the bulb did turn on it was not necessarily when the turn on action was listed first. Also note that each of the actions stated “successful” but there were time that the bulb did not turn on.

3 Likes

I’m glad @WyzeDesmond is looking into this. I too have seen this sort of thing before. In my case I was trying to adjust the brightness, color, and on/off state of a Bulb.

I hoped to turn a bathroom light dimly red at night when motion was detected, but I started off using the double-click of a Wyze Switch. In any case I found the multiple action process didn’t work. Some steps were randomly missed, making the process unusable. History always said everything was fine.

At the time I did not know if the multiple action process was at fault, or the firmware in the bulb or switch I was using. Maybe it was also that the Bulb couldn’t accept commands if it was off. I thought I’d get back to the project to get more details, but I never did.

So hoping this gets fixed! :slight_smile:

3 Likes

THanks! I will take a look into this.

2 Likes

The cam didn’t turn on last night and I submitted logs (714565).

@Newshound @matthewrjwilson @IEatBeans @Omgitstony I just had a quick discussion with dev team on the schedule and rule. There is one thing I would like to let you know first before we investigate other things.

So when you add action, please make sure you don’t put on and off together into one rule. Since there is no sequence actually. When the rule is executed all the actions will be processed randomly. So even we put “on” first and then “off”. Which might still end up with “off” first and then turn on.

We will make some improvement in the future app release to make sure this logic won’t happen. As for now a better approach will be “turn on for certain seconds/mins”. I know some of you may not experience this issue but just a reminder. We are still working on other investigations and I will keep you posted.

4 Likes

As you can see in my screenshot above for the rule, it’s only “on” for each item. I also do not have additional schedules set up to conflict with the one I shared an image of.

Yes. We are still investigating your issue. Thanks for your patience.

1 Like

Thanks for confirming this, this is what my suspicions have been and then my science experiments above show happens.

3 Likes

Yea that’s what I had thought, thanks for the confirmation :slight_smile:

May want to add a little message to the app, if it detects conflicting actions like on and off, or set brightness to 10 then set it to 100, stuff that wouldn’t work as intended, it can explain this to the user.

2 Likes