Wyze1 the 3.9.2.30 - getting video data (3/3) - stuck here

support
#43

That is exactly my thought as well. The Wyze service rep mentioned the N router giving an “intermittent connection” to teh cameras since they are designed for the AC routers, even though there is no mention of that on the FAQ page. Simply that they will run on a 2.4 GHZ network with WPA or WPA2 protocols. But, bottom line is that they were working on this same network before. Flawlessly. Now they aren’t and the only difference is the updated firmware.

0 Likes

#44

Add me to the list. I have 3 cameras installed at 2 different locations. After a few days they all start developing the connection loop getting stuck at “3/3” then eventually move on to “Connection failed (-90)”. If I unplug and plug back in they work again for a few days. This is not a convenient fix since I am usually not at the house with the problem when it happens. I am installing a new router at one location so we’ll see if things improve.

 

0 Likes

#45

For those having the “Getting video data (3/3)” problem … how many of you have your cams pointed through a window? I have 2 of my 3 cameras positioned about 1" from the glass (can’t get the cam any closer due to window frame). Infrared always off of course. Almost always, when I get the (3/3) problem, if I pick up the camera from the windowsill and point it elsewhere in the room, the cam instantly connects and starts showing Live video. When I rest the camera back on the windowsill, the Live video will freeze again. Why proximity to the glass might be affecting this is beyond me, but curious to know if any others have witnessed the same behavior.

0 Likes

#46

I have one camera pointed out the window and it fails at about the same rate as my other two. I will try moving it next time to see if it makes a difference. In fact, I will try moving all the cams instead of just unplugging. You never know!

0 Likes

#47

I have one out of the three troubled, but that is the only one which “came back to life” by itself (still were not able to visit the location and fix them (reinstall).

0 Likes

#48

I have five cameras, two of which stick on 3/3 and three which work. I moved the cameras around so that my less important views will be the ones that fail. Two of my cameras point outside. After jumbling the cameras around the same two which failed before continued to fail in new locations and the same three which worked before continued to work in their new locations. In my experience the window is not the problem. And even if it were… it’s the same silly question: “but why did they work before the firmware update?”

0 Likes

#49

Yeah, I have one cam pointed through a window and one not. Both have the problem. Intermittent loading. Sometimes one will load, and the other wont. Sometimes it is the opposite. Sometimes both will load and sometimes neither will. Again, this is all since the latest firmware update.

It sure would be nice for someone at Wyze to address this issue, as not being able to load the camera feeds while away from the camera pretty much makes the cameras useless to me.

0 Likes

#50

I have four cameras, currently 3 get stuck on ‘getting video data 3/3’ and only one will connect a live stream. At various times in the last few weeks different cameras have had this problem. However they always send notifications and I can play the recorded notification video clips. Have updated the iOs app and rebooted my iPhone, that doesn’t help. The only thing that does fix stuck cameras is cycling the power on the camera. The cameras are in a vacation home in vermont that is currently unoccupied so I am only accessing them remotely and the only way I can fix them remotely is by waiting for a power outage, which fortunately have been frequent lately (big winter storms!), and that fixes them (at least for a while). Have only been seeing this problem for the last few weeks, it seems to be since a recent firmware upgrade or perhaps some recent change to the cloud network. The comments several others have made about seeing MAC addresses changing spontaneously seem significant to me. I suspect this is what is happening, it would explain why the app can’t connect, although the camera is still able to upload notification video clips. Would be nice if wysecam acknowledged they have a problem here and are working on debugging it.

0 Likes

#51

A work-around?

I have one cam and it is also showing the problem where it drops off my network until it’s power-cycled. I checked my the router logs and saw that after the cam disappears a mystery device with an unknown MAC appears and asks for an IP address. Others have noted that these cams can change MACs. My network is configured to ignore unknown devices, so it seems that the MAC change could be the problem. As a work around I added that second MAC address to the router allowed devices list and the camera then connected and was visible from the outside world. It’s been OK all day so this may have fixed the problem. HTH.

0 Likes

#52

Yesterday I visited the three cams which don’t work. Re-installed them (deleted from the app, re-connected).

They were working like charm while I was on the same WiFi network. As soon as I switched to mobile net on my phone, they keep stuck on the 3rd step in connecting. From home (again on WiFi), they worked just fine. I stared to put the blame on my mobile net provider.

This morning checked, they are not working from the WiFi and from the mobile net, nada…

I always believed that in computers it is 0 or 1, so this erratic behaviour is unexplained…

I will try adding the MAC addresses to the router, but I am not qualified to investigate those unidentified addresses, and adding them too. How is it done?

I hope wyze is listening to this problem, and get a firmware update, which - for a change - does not break what was properly working until now.

If not working, I have a set of three cams, unopened (so with the old firmware), I will swap, and check if they work properly or not. That will easily answer the question, of either the firware or the router is the culprit.

0 Likes

#53

It seems to me that the MAC address changing would only be a problem if your router has its “MAC address filtering” function turned on. That’s the case on my router, and my work-around has been successful for all of 24 hours. I’d guess that many folks don’t use this filter function because it’s a hassle to keep adding devices to the router as they come into your house. So, even if this fix works for me for now, there may be other things going on to cause problems others are seeing.

 

 

0 Likes

#54

I have the MAC address problem without “MAC address filtering”. While the camera is working, the correct MAC address shows up on my router. Eventually the MAC address changes, the router shows the change but the mobile app can’t connect. It apparently is looking for the original MAC address. I have no clue how to fix this. I can’t tell the app to move on to the new MAC address. If there is a way to work with this, let me know. Meanwhile, I added a timer switch to reset one camera at 2am every day. This is a work around that I shouldn’t need but I’ll see how it works.

 

0 Likes

#55

Agreed, I was about to post the following …

I’ve noticed the same behavior re: the MAC address changing. For me, it usually happens immediately after re-setting up one or more of my cameras. The “proper” IP address usually returns after I power-cycle the camera once or twice. Let us know how your testing goes, but as long as everyone’s DHCP pool is large enough and they’re not using MAC filtering as I believe you are (most don’t even know what this is), then it technically shouldn’t matter that the address is changing, should it? It does seem odd that this is happening, but as long as the cameras can obtain an IP address when they need one, I’d like to think they’d be happy. Note that I’ve experimented with manually assigning IP addresses (within the DHCP pool) to each of my 3 cameras, but abandoned the approach after noticing that the MAC was occasionally changing. Anyway, I hope that made sense! :wink:

p.s. after having said all this, my 3 cameras have actually been pretty well-behaved lately after, for testing purposes, sidelining my Chromecast dongle (unplugging from my TV) and changing a couple settings in the 2.4 GHz band on my ASUS router (Channel bandwidth to 20 MHz and Control Channel to 11, the least busy in my area) YMMV

0 Likes

#56

PROOF, that the firmware is the problem!!!

Today, I spent a considerable time to troubleshoot the cams.

I tried tweaking the router, but finally, I unpacked a new cam, refused to update, and VOILÁ, it just works.

Changed all three cams to new, unopened ones, and I DID NOT update the firmware. All three work just (almost) fine.

At least now I can access the cameras. HOWEVER, all three behave slow, and produce these effects:

  • slow connection, even though the measured spped of the net is close to 50Mbps
  • when connected, going into landscape mode, the app reconnects, and sometimes it takes ages. Sometimes only the sound is there, but picture is not refreshed.
  • picture has vertical artifacts (stipes) - see attached pic.

0 Likes

#57

Let us know in a few days. Mine connect for awhile - maybe a few hours, maybe days.

0 Likes

#58

I just installed a new camera and the app looks to use the MAC address as the initial “name” of the device until you rename it. Assuming the MAC is the way the app identifies the cameras, the MAC changing is a big deal. That most likely can be fixed with a firmware update so this should clear up eventually.

0 Likes

#59

This makes sense, my camera went to connection failed -90 status and looking at the router both macs are listed. It’s probably why the cams notifications are still working but the app can’t connect to the original mac that it was set to prior to changing. I really hope this can be addressed soon as this toy is losing its appeal very quickly…

0 Likes

#60

Similar here,

2 cams - both updated firmware.

Cam1 always connects and behaves properly.

Cam2 fails to connect at step 3/3.

Cam2 will occasionally connect at night when the cam has a black field of view. A very low data rate is shown in upper left of cam view.

 

0 Likes

#61

Any fix from Wyze yet? Same issue here!

0 Likes

#62

Not yet. In fact, there has been no mention of this as an actual problem by Wyze as far as I know.

0 Likes