Wyze Watch not syncing with Google Fit

I had a Wyze Band and it was syncing steps and heartrate to Google Fit after I authorized it, but since switching to Wyze Watch, it shows authorized but no data is coming across.
I had to fully remove the Wyze app to get notifications working properly on Watch and then I could properly authorize Fit again, but still no data is coming over.

4 Likes

I’m having the same problem.

1 Like

Me too! I had hoped sleep data would also sync over, but no dice!

2 Likes

I had to download and install the latest Wyze beta app and after that the sleep data & heart rate started syncing with Google fit. I also had to authorize Google fit again after updating the app.

1 Like

And how do I download this beta Wyze app?

depends on ios or android…more info here:

https://wyze.com/become-a-beta-tester

1 Like

I have the beta app and I am seeing the same issue. It sync’s after I authorized it the first time, but does not continue to sync. I have to remove the authorization and then set it back up again to get it to sync each time.

2 Likes

Having the exact same issue. I actually had to go to the Play store and look up the wyze app and saw that there was an update pending. In the update patch notes I noticed, Fixed incorrect personal information for Wyze Watch 47mm. Updating now before heading to bed and we’ll see if this helps thanks for the heads up.

1 Like

I’m having the same issue. I ordered the watch at the request of my doctor to track my heart and sleep, and it’s not syncing with Fit. Please help.

An update. I updated the app last night and now my watch is tracking sleep. This update caused a reauth to Google Fit. This morning, Google is showing 0 steps and no sleep data, but my watch recorded 7 hours of sleep and 61 steps. Harumph.

1 Like

Having the same issue with no sync to Google Fit happening. If I remove auth to Google Fit then readd it the data will sync the one time. Having to do this daily sucks though, would love a fix for this issue.

Upgrading to Beta app (Android) worked for me but I had to authorize Google Fit twice, the first time when I selected authorize from the Android app, it popped me over to the Fit app. The second time, it actually brought up the Google authorization and explained that Google would receive Sleep data. Then data appeared in Google Fit after that … so with that, you may want to try revoking the authorization, then re-authorizing if it is still not working. Too bad it is this much hassle to get it to work.

Even on the beta app and beta watch firmware for me the initial sync works but it doesn’t continue syncing. The only way I can get data to sync again is to unauth then reauth Google Fit. This same process made the non beta app sync the data also.

beta watch firmware

How can I switch to the beta watch firmware releases?

You may need to join the beta by going here: Become a Beta Tester . But you can try the steps below first.

To select which Devices you would like Beta FW for do the following:

  • Start the Wyze App
  • Tap Account at the bottom of the screen
  • Tap About
  • Tap Beta Program (If you don’t have this, you will need to sign-up for the Beta Testing Program Frst), If it exists, simply tap on it
  • Tap the Edit link at the top
  • Select Which devices you would like Beta FW for. I select All Devices.
  • Click Save

I would then shut the app down, and then start it again. Probably not needed, but I do this to be sure. Then go to the Watch and see if the FW is available.