Wyze Watch 47 Battery Drain

Hello! Just this week my Watch 47 will not hold a charge. I can charge it overnight to 100% and within 3-4 hours or normal use, the battery is dead. Last week I was able to go almost a full week before I needed to change. I have the heart rate monitor scheduled to run but I have had that set since getting my watch a month ago and have not had battery issues. I am currently on firmware version 0.12.43. Any thoughts/help would be greatly appreciated. Thanks!

1 Like

submit a ticket to support immediately

1 Like

Hi @jiskraj and welcome to the community forum! :slightly_smiling_face:

The 47 watch should run for over a week with out needing a charge.
As @gemniii suggests, open a ticket with Wyze Support.

Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

1 Like

I have the exact same problem. I pulled my Wyze watch off the charger when it was at 100% and by the time I got to work it was dead.

I had the same problem and even got a replacement. I am still having some problems. Just yesterday it freaked out and was vibrating really fast for a while then just restarted. It lost like 10% battery from that.

I recently had an issue during an update that made it act weird (not battery issues though). I factory reset the watch, deleted from the app, added it back, and that fixed all the oddities. Don’t know if that applies here but just thought I would offer it up.

When in doubt, format. :slight_smile:

The 47 here lost most of yesterday data (06/15/2021). May be have been server issues.
Have no inside info, only speculation. Anyway, worked today! :slightly_smiling_face:

I tried that today and now my watch is unable to load watch faces. Not sure if it is the new background sync processes or something with the app. I also am sometimes unable to change settings with the app before it tells me the watch is “disconnected.” Just to make sure it wasn’t the Apple HealthKit sync causing the problems I de-authorized Wyze and tried again. Still failing watchface upload

I was able to get my watch to upload new watch faces. Had to revert the app to previous beta build, then remove/add the device under the older version of the app. Works as it should. Will monitor the battery drain over the next day or so to see if it also addresses the issue.

Old app did not fix the battery drain issue. Full charge as of 16 hours ago, now down to 55%. So it is definitely something introduced with one of the newer firmwares. I can open my iPhone’s bluetooth settings page and I can see the Watch connecting and dropping constantly. I’m pretty sure this is probably the cause of the battery drain I see from my phone and the watch.

Did you open a ticket or contact Wyze about this?

Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

I have the Watch 47 with and not experiencing this issue at all. I test with both Android and iOS. My Colleague had an issue with the 47, not battery, and he corrected the issue by removing the app from the app, factory resetting the watch and then rejoining it to the iOS device. his issue was with the BlueTooth connection. He also removed the connection from bluetooth on th phone and established the connection again. This Bluetooth issue may be what the issue is.

Yes, called the number and I was told since I am running beta firmware and software they pointed me here. I gave them the log IDs and explained my issues anyway since my experience is obviously not ideal. It definitely is related to BT, I’ve removed the watch and dropped the BT connection and added them back in the current and previous versions of the app. Still the same behavior. I can’t regress the watch to 0.12.43 because the app is in a constant state of flux with the watch. It is the only thing that I haven’t done to get a baseline of what I had previously, prior to the current firmware. Since I use the app for the doorbell as well I am going to see if forgetting the BT connection to the Watch improves the battery life for both, knowing full well it will break notification and auto-sync just so I can try and isolate the issue even more.

I get it is Beta, so I know things like this will happen. I’m posting here my experiences and my troubleshooting steps hoping it is helpful for Wyze and others who may be monitoring these threads.

are you on the 14.6 version of iOS? wonder if they made some changes to the BT stack.

Yea, being in beta has its benefits and its drawbacks. But having a good attitude about it helps out. I will check with another community member and see if he is willing to test his watch and see if there is a battery drain on his. He likes his Galaxy watch and has stuck with it. :slight_smile:

Yup, 14.6. Not sure what changes could have been made that might cause this particular behavior. My son has a cheap fitness tracker that also pairs with my phone and it (like many cheap trackers) uses the veryfitpro app and I’m not seeing the battery drain on his device, or from the app on my battery readout.

I really like the watch, for the price point and the feature set it addresses about 90% of my needs. the last 10% could be covered using a more expensive watch, but the cost to the relative value of that last 10% stops me from seriously considering a switch. If I had something like a Galaxy watch previously, I probably would be in the same boat.

my daily driver is an Android phone. At the end of the day I am at 89% remaining. I even have the continuous heart rate turned on. trying to see where the breaking point is. So far, no issues.

The individual will be performing the tests for me. I will report back or have him,

I appreciate the help trying to nail this one down. I’m taking my son camping this weekend so I won’t be able to really dig into this until next week. Again, thanks!

Not a problem, know how it is. Have a great weekend

1 Like

Just read this in the forum. Might be something to look into:

If you’re running a VPN on your iPhone 12, try turning it off. Also… go to iOS Settings on your phone > Wi-Fi > tap [ios13-info-icon] to the right of your AP’s SSID > toggle “Private Address” off.

Until I hear back from the community member.

Having the same battery drain and issues here

Android app version 2.22.21
Wyze watch 47 firmware 0.12.49

Watch will not update watch faces (error installation failed - please try again). Even the watch face page has issues loading. Cameras not affected. Watch will lose 15+% every day, whereas a month or so ago it was doing fine, and only losing about 5ish% a day.

I have removed the BT device from BT settings and deleted the watch from the app. I have repaired the watch as well, no change. Cannot update watch faces now. Cannot downgrade watch firmware back to earlier 0.12.xx either.

This has rendered the watch useless, as charging it every day or so is not the reason I bought it.

I will contact wyze support tomorrow, but this is a recent issue that Im sure stems from newer firmware or the wyze app itself.

1 Like

Since recent firmware update my 47 watch drains the battery in one day. Before the update, the watch would run over a week without a re-charge.