Wyze video fails in Android 12 fullscreen (EDIT: at 720 dpi)

I updated my S21 Ultra to Android 12 this morning and developed a problem with the Wyze app (2.26.22). I can still view my cameras properly, except that if I try to view one in full-screen mode, the app crashes. Clearing the app’s cache and restarting it doesn’t help. Wyze full-screen mode worked properly in Android 11, and my phone’s other video apps still work properly in full-screen mode in Android 12.

EDIT1: I’ve submitted logs under ID 369610.
EDIT2: It only happens at 720 dpi setting (see below).

Which Camera are you trying to view Full Screen? I assume you mean Landscape.

Can you provide the Firmware of the camera you are seeing this in?

Asking because there was an issue with the V3 camera’s viewing landscaped causing crashes. the latest Firmware updates corrected this.

Wyze v3, firmware 4.36.722 (latest), 3 different cameras. Yes, the Wyze app’s full-screen video is in landscape orientation. It was working fine for me (through several successive camera firmware versions) until I updated my phone to Android 12 this morning.

I have a different version for the v3 as I also beta test. I am on 4.36.8.15. I am also on Android 12 Pixel 5 and a Pixel 6. Both work without issues.

You cleared the App Cache, but did you do this in the app itself under Account, App Settiings? You should clear the Cache in bot area’s, in the App as I mentioned and the through the OS by Long Pressing the app, doing a force stop and the go to Storage and Cache and clear Cache.

the other option I would do is to log out of the app, restart the phone. Then when you start the app and logon everything should be cleared out. Just trying to provide options. What I have mentioned above helped me out in the past.

You can always going the Beta Program, understanding that at times there could be some issues. If you want to try you can go here: Become a Beta Tester, after you join, remove the app then go to the app store and install it again. Then in the Account, About menu choice, you will see Beta Program. Click on that, then select Edit in the top right and select the Devices you would like to Beta Test the FW for. Click save and then go to Firmware Update and see if the Beta is available to you.

1 Like

Thanks for the info and suggestions. I tried the steps you recommended in the 1st two paragraphs, but they didn’t solve the problem. The info you provided shows that the Wyze app (or at least the beta version) is not inherently incompatible with Android 12, although possibly that it has some incompatibility with the Samsung-specific Android 12. So I wonder if others with S21s etc. have tried Wyze with the new Android 12 on those phones. Or if it turns out that it’s just my own phone that’s having the problem, then I’d be happy to experiment further to look for the cause.

I found a relevant factor. I had my display dpi set to 720 in the phone’s Developer Options (the Minimum WIdth setting). When I reduced it to 715 (the default value is 384), the Wyze app was able to show full-screen video properly.

So it appears that the app doesn’t properly support a high custom display dpi setting, but it used to work (at 720 dpi) until today’s update to Android 12 (and all my other video apps still work properly in full-screen mode at 720 dpi), so maybe that’s something the developers would want to address.