Wyze Video Doorbell "QR code is incorrect"

Received the replacement today. Hooked it up and was installed in 5 minutes. Everything is working great.

This error happened to me with my router. I had to temporarily disable 5ghz and try again. That seemed to do the trick.

I think error message needs to be updated , it is pretty generic right now and even misleading.
My router had blocked the mac address of doorbell. I changed router settings to unblock the MAC address to fix "QR code incorrect " issue.
The error should say, “unable to connect to internet” with specific error code that user can share with WYZE.

I installed the failed doorbell at a different home with success – 600 miles from the original failed installation. No difference in procedure, just a different network environment.

Installed VDB and it worked perfectly fine. Our internet went down a few days later and the VDB would not reconnect. Tried to reinstall and got the QR CODE IS INCORRECT. Did every troubleshooting step they gave and nada. I have had success with all my other Wyze devices, this is the first dud.

It’s now late April and no resolution. I’ve filed three tickets with support and gotten zero answers other than automated responses. This is my last Wyze purchase. The answers on the self help page are non sensical. Cant connect? Try upgrading your firmware. How can they not realize you can’t update firmware without connecting the device. Wyze has a lot of potential…unfortunately piss poor tech support has been the downfall of many a great start up.

I have to conclude Wyze does not have this bug figured out. It has been languishing for months. My experience with one VDB was fine, but a second experienced the dreaded QR code issue. It only resolved by moving to a completely new network environment where the QR code issue magically vanished. If it was simply a known firmware bug in the VDB, why hasn’t Wyze shipped replacements to stranded customers that can’t connect?

My issue was eventually solved when I discovered that the VDB was trying to PING a certain IP as part of the setup but couldn’t. Once I opened up ICMP on my firewall, setup finished and I was able to get the VDB working.

This appears to be a different requirement from their other devices as I’ve not had to do this for any of their cameras, plugs, etc.

Hope this helps someone.

My problem resolved when I turned off cellular and data on my phone. These same settings had caused similar issues setting up a SmartThings product some time ago.

Daniel Wille
412.983.3665