Wyze Video Doorbell "QR code is incorrect"

I had a similar problem. After the upgrade, completely reset t doorbell and Wyze system. The QR worked for me.

If you ordered it in September all those orders will be shipped by February 27 and for the people that ordered in October 1-11 will be shipped by March 3rd any orders ordered after October 11 will be shipped at a later date with no info yet.

It’s Tuesday now and there’s nothing on this thread to indicate the problem’s been resolved. Also nobody has replied with a solution to the ticket I raised that included my MAC.
@WyzeGwendolyn, can you please let us know the status?

I’ve fixed this (no help from Wyze). It was a weak wifi signal at the doorbell - put in a range extender and it now reads the QR code, connects and maintains the connection. Hope this may help others struggling with the ‘QR code incorrect’ message.

@WyzeGwendolyn according to support this is still ongoing and there’s nothing they can do by providing the MAC address. Any updates from your end?

Just got my doorbell today, and sure enough, “QR code is incorrect.” I can see it both on the access point, and the router. So it correctly connects to the wifi, and gets an IP address, but then after a few minutes it speaks the dreaded phrase, and just flashes blue.

Out of curiosity I ran a packet capture while the doorbell was failing to connect. This is what it did:

  1. Sent out a DHCP request, and received a response
  2. Sent out an ARP request for the router, and received a response
  3. Did a DNS query for www.google.com and received a response
  4. Pinged www.google.com five times, and received five replies
  5. Did a DNS query for clock.fmt.he.net, and received a response
  6. Sent an NTP (time) query to clock.fmt.he.net, and received a response
  7. Did a DNS query for ntp0.cornell.edu and received a response
  8. Sent an NTP query to ntp0.cornell.edu and received a response
  9. Did a DNS query for api.wyzecam.com, and did not get an answer
  10. Re-ARP router
  11. two more DNS queries for api.wyzecam.com and failures

A DNS query from this computer, which uses the exact same DNS server the doorbell was using, gives results for api.wyzecam.com.

I do not know enough about DNS to figure out why when the doorbell sends a query for api.wyzecam.com there is not Answer field in the replies.

Thanks for the work @sir_tainly . I did some research and it appears that api.wyzecam.com resolves for me on my network. I’m going to hardcode the resolution in my DHCP server and see if that helps. Will report back soon.

Tried statically setting the DNS resolution in my router, still getting the same error. My guess, without having access to the OS of the doorbell, is that there are statically set DNS servers in the doorbell which may not be working properly or from some locations.

Success! Disabling DNSSEC seemed to do it.

I had a reasonably complicated DNS setup, in which dnsmasq on my router sends queries to stubby (also on the router), which then uses DNS over TLS to send out the DNS query to Cloudflare. I thought I had it configured to not do DNSSEC. Checking from a computer, it was doing DNSSEC, even though neither stubby nor dnsmasq have it enabled. Very strange.

I took stubby out of it, set the router to send queries to Cloudflare using normal UDP 53, and confirmed DNSSEC is not working, and now the doorbell works. I have not done the test of deliberately enabling DNSSEC to see if that breaks the doorbell, or if the firmware update that just installed fixes the problem. A Wyze cam did work just fine on the existing network.

Now I can’t get the chime to pair, but I’m guessing that’s not a DNS issue.

Did wyze ever fix this issue? I received mine a few days ago and attempted to install. I got the same qr code incorrect message. Tried everything, reset, extender and it refuses to connect.

2 Likes

No fix for me yet.

This am I used my old phone and for some reason it hooked up no issue.I saw a post on reddit about this, thought I’d give it a try. I worked on this for hours yesterday. I have no idea why it would make a difference. My new phone uses android 10 my old one uses 9. Hope this helps someone.

same issue doorbell not connecting what needs to be done?

I tried for hours and gave up. The next day I read on reddit that someone used their old phone. I had turned off my router access control, not sure if that did anything since I had allowed new devices the day before. I then used my old phone using android 9 and the dang thing hooked right up.

When I first tried it it was very sunny out. I got incorrect qr code 3 times then just did it now when it was dark, no problem. It took less than 5 min once accepted.

Wierd. I tried from afternoon untill after dark. I didn’t have any of these issues with my other wyze products.

After reset it started working

Thanks
Pankaj

Oh good. I tried resetting the cam and router multiple times.

Received my doorbell yesterday and am having this same issue. Submitted a ticket and waiting for a response. Hoping this gets resolved soon.