Wyze Vacuum WIFI connection

I am having the same issue with trying to connect the WYZE vacuum to the wifi network.
I have followed the instructions and agree with some other posts they are not up to par for WYZE instructions.
I have installed the WYZE thermostat which required me to install the C-wire puck on the outside unit to make it work and those instructions front start to finish were by far the best instructions I have ever seen! Then we get to this vacuum. Maybe it is only because it isn’t working but no where near the level of detail of the thermostat.
I have connected to house wifi (2.4) started the install guide, pushed the 2 buttons (white lights flash), entered my house wifi password, then switched to the vacuum wifi network but comes up with the no internet may be available, unsecure network. go back to wyze app and tries to connect for minutes. Finally timing out or saying couldnt connect.
I don’t know what else to try. unless there is an issue else where.
it seems pretty straight forward, i have tried also on airplane mode and with cellular data off and all my wifi networks set to non-autoconnect, so that it will stay on the vacuum wifi (which does nothing)

I have the latest wyze app and is pretty frustrating.

The other thing I noticed while watching some videos on youtube, is that it would have been nice to know upfront that we needed a space 4 foot by 4 foot to store this thing in. maybe this is the same with all robovacs, but this is our first one, only becuase it is WYZE and matched the rest of our system. now the spot we had picked out will not work and will need to look for a new one. Wife doesn’t want it out in the open.

Any New help that hasn’t been repeated in the previous 10 posts would be much appreciated.


My wife wants me to return it! I tried it manually and it went to work. Pickup everything it found. I just want to get it on my network!