Wyze vacuum -- good and bad so far

it has a limit on what it can see, its on the user to make sure things like cable are either not where they can get snagged or are marked off using the virtual walls.

and on this one, I think im misunderstanding, is this what is happening with you? it has been reported that is ou lift and move the robot the map can reset, I have had mine get stuck on things and I have paused it, removed the item from it, and then resumed the clean without losing my map.

this does save the map, I don’t have the details of how or where it is saved, but I have had no issues in losing my map.

I agree with you on never being able to set up a map, but I’m sure you will agree, there is some onus on the user to know what the “visual” limits of the robot are as to what it can see and avoid and what it can not. my issue comes with cat toys ( and a tree skirt once because I didn’t think enough), so I have to be aware to make sure my cat doesn’t leave certain toys out, but as far as cables or wires or other small things that would be on the user.

when you say update… what do you mean by update? I might be able to give you some insight on this.

So from what the current users are saying the map is not being updated after everyone run. Is there a way to update the map without it having to recreate the whole thing. For example, if I removed my Christmas tree that would just be a huge dead zone now.

Thanks for all of the insight to those who have deployed their new bot… about to send mine on its maiden voyage… half tempted to put a WCO on it and let’er rip.

if you had a virtual wall around it, and then removed the tree and deleted the virtual wall it should read it as an open zone ( digitally) and with the lidar not seeing anything there it should get adventurous and go do it’s thing. I have a couple chairs in my office that are never in the same place and it does a good job or going where they used to be without issue.

I would give it a shot and just be mindful of it when it goes to that area. if for some reason it doesn’t go to that spot I would send a log in because it definitely should!

I’ve noticed the map on mine gets a bit more accurate every time the unit runs like if I open a door between a room it will then venture into that room. BUT… the map still shows the entire home where the unit goes as one single room - even though it is four separate areas. I did notice that when I moved the base to another location I had to reset the map because it still went to the old spot.

1 Like

I came into this unit with minimal expectations as I have never owned a robovac. I appreciate reading everyone else’s insights so thought I would share my high level first thoughts going from out of box to first pass here.

Setup went fairly smooth, everything I needed to know was found in the Quick Start guide or WYZE Robot Vacuum Manual. The firmware updated instantly upon setup. Once charged I sent it on its way on my main floor (about 1600 sq ft minus what ever furniture covers)

Got almost 900 sq ft, then scurried home for a charge(Clean interrupted message) . I sent it with a 96% charge.

It found its way around very well, and I did remove anything that would obstruct, i.e. chairs, cords, etc… it did find a wayward nerf disc, I was alerted by some grinding sounds. Cleared it… all was good.

I was also impressed by what I found in the bin after having just shark vacuumed the floors 2 days ago. (8 people in the house)

It made its way over some low nap area rugs with no problems, but was mostly on textured laminate.

Even found a tissue hiding somewhere.

Again, I have no other experiences to compare this one to, so I am happy to this point. Curious if it will pick up where it left off once charged again.

All done on production latest release… will try with beta after a full first pass.

Pass 2

After 100% charge… I had to initiate the device to start again, it didnt just go. It took off and outlined the remainder of the primary floor then started cleaning the open areas… Odd to me that it didn’t go back to the rooms it outlined that it hadn’t swept but started cleaning an area it had already swept.

My primary floor is wide open minus the bathroom and an office near the living room, but I found it interesting it labeled some of the “rooms” and somewhat well.

I won’t make this any longer because the pics will get this post super deep. So here is the 2nd pass.

huh

Ok so said I was done, but all the sudden as I am chilling on my couch. I hear recharge complete resuming cleaning from the robovac… look at app and its at 60% and and its off and running? And in a “room” it mapped but didn’t sweep. Hmmmm?

I promise last one… :grin: but I wanted to share for those that may come across this thread.

The robovac completed its job overnight all on it’s own and fully mapped my main floor very well. I even sent it on a short mission this morning using a scheduled cleaning (room 1) to see if it would lose the map starting a new clean and the map has held in place. Now… that being said, I did download the beta app to see if the map editor was there and it is not. I am happy with the results so far, but the 2.5 hour cleaning is more like 6-7 hours with charges in between, the way it has identified rooms is not the way I would want it… but no doubt these options will become available, when is the question… but I am a patient person, and know that this is was a pre-order that I got even earlier than I expected.

6 Likes

I’m using the beta app and don’t see the editor. Just got the vacuum today, so still getting used to it. I have an open floor plan too and really need an editor.
Do you know if there is beta firmware on the device? Since I’m in the beta program I assume it would include the vacuum.
Thanks

I am on Android, Samsung Note10+ running the WYZE beta app and look as if the firmware is the same for the vacuum

Same here. Since its new, bug reporting will be very helpful. And then maybe we’ll get a beta to test.

My vac muffed up on its first run out of the box, only cleaned part of the house, and got lost on its way back to charge, and did not save a map… It was only showing ≈60% battery out of the box so when I found it stranded I put it back on its charger and figured I would try again.

The next day the little guy went out and did its job without any problems, and saved a perfect map of the house. Its been out two more times without any issues aside from bumping into the dogs a few times and snuck up on me when I was cleaning too, haha.

I can say this vac isn’t great at dog hair, and will keep running even though the bin is not full, but plugged with fur. I have been watching it and have been pausing its clean cycle to empty the bin as it’s on its route, and that hasn’t really confused it at all, it picks up right where it left off.

Mine can run a 1.4 hour route and make it back to its home on the quiet mode without any problems.

I’m wondering if upping the suction mode will allow it to fill the bin better without clogging up with dog fur. I’m hoping running this thing every other day will let it get ontop of the dog hair problem to the point it can run a full cycle without having to be emptied, but there isn’t much that can keep up with a shedding yellow lab, haha

2 Likes

I received mine yesterday. Connected to wifi (Orbi ‘mesh’) without issue, charged it and let it run. It mapped the space quickly and I’m impressed with the efficiency vs. old Roomba drunken sailor pattern.

However, while running and monitoring in the app it simply dropped from network reporting ‘not connected to internet’. So far I’ve not been able to get it to reconnect. I’ve tried resetting wifi connection but it no longer broadcasts the temp wifi connection to configure.

Stuck with no network connection. Any ideas for more complete reset? Seems as though the wifi module may have died.

I’ve tried a couple more factory resets and finally got it to show its temp wifi. Both clean runs and map were stored and ‘restored’ in the ‘new’ setup. So far so good.

Got the unit 2 days ago. Took a few tries to connect to wifi (saying poor signal twice when it and the phone were physically less than 10 feet from the router). Learned the hard way that the map disappears on manual on/off. Also, just called support and learned that if you move to a 2nd floor, the map from the 1st floor is overridden (not great) so when it’s back on the 1st floor, back to square one.

It does a very good job cleaning and mapping - returned to the base just fine when needed (no manual intervention required) on the 2nd pass.

Thats funny, mine went a little “drunken sailor” last night. No clue why as it pulled my map very well.

Per my layout it even got out of the house and made it’s way through walls, deep freezer, and some other solid objects. Magical :mage:

1 Like

Just curious - did Wyze say anything about them adding support for multiple levels (and maps) sometime in the future?

I have a two story home and it’d be a nice feature. I pre-ordered mine and I’m just waiting for it to ship.

Mine has done the same thing over the past two days. I am going to delete the map today and have it reconstruct the map.

I didn’t ask and they didn’t mention. I told them it was not the answer I was hoping to hear - but that didn’t generate any response like “it’s coming in next update” or anything.

1 Like

I just had an experience where my robovac disconnected from the network. Walked past it and the home and power buttons were flashing white… popped open the app and a disconnected message appeared. All my other WYZE devices and IoT devices were still connected and working fine.

For fear of losing my map power cycling the vac, I decided to reboot my IoT WAP ( I have a secondary access point for just IoT) and the robovac reconnected. Map and Virtual walls were still intact.

So trouble shooting step 1 worked but, the idea of having to take down connection to all things sucks, but it took many hours to get my full map.

I like the concept of this device, but implementation is definitely buggy. I ran it after a full charge, it mapped the house, but when it was time to return to the charging station, it complained that it didn’t have enough power so I had to manually dock it. I did.

Once it was charged up again, I tried running it again to have it finish, and the map it had created disappeared. It had to draw it all over again. I forced it to walk around and map part of the house (sucks that we don’t get a remote to manually tell it where to move), and then docked it as soon as it got the map. This time the map was saved and Rooms were named!

I ran it again this morning having it discover the second half of the house. Once it did, I asked it to go back to charge, but it got stuck on the way, and after getting it unstuck and resuming, it completely lost its sense of direction and started adding the wrong map data.

I manually put it back on the charger.

The most annoying part is that if you lose the map, you lose all the zones you had added.

If I understand correctly, if you pause the cleaning cycle before you lift the unit (when it gets stuck) it will not lose the map. Am I correct?

That hasn’t been the case in my experience. The first time I ran it, I paused it a couple of times to empty the dust bin. It still failed to save the map when I had to carry it back to the station.

The only time I noticed it saving the map was when I had it return to the charging station after it had mapped things for a bit.