Wyze thermostat, the current network is not good?

Anyone else have this issue?

I have lots of other wyze products and never seen this issue with either of them, my network is fine.

Welcome to the Wyze community @jredecop!
Have you tried forcing close of the Wyze app and opening it again? How do your devices work after doing this?

What happens when you press “try again”?

It takes me to a page showing my wiring is correct. I hit next, then begin on the next page and then same message. It’s a loop. I’ve done a factory reset on the thermostat. Closed app and relaunched. Deleted app and reinstalled. Tried another router. Nothing works. Called tech support, they don’t know either. I bought 2 and they both doing this.

How far a yaw is the the from your router or access point? Is there anything that could possibly be causing this issue? It seems that it may be a network issue.
Make sure your WiFi is 2.4 GHz and your phone is connected to it during setup.

My access point (ubiquiti) is about 4’ away. My phone has full bars and WiFi speeds of 400+ where the thermostat is at. Tech support had me install the routethis helps app and confirmed it’s not my network. Yes my network is broadcasting both 2.4 and 5. No other 2.4 devices have any issues.

Did you ask for replacements?

No I’m just going to return these. I don’t think it’s the devices. Funny thing I was able to update them under firmware update in the account tab where it shows all my devices. They are definitely connected, some other issue.

Could it be you phone? Is there anything unique about your network that may cause this?