Wyze thermostat temperature overshoot

Please add along if your wyze thermostat is overshooting the temperature everytime on heat cycle

Here is my observation

“I noticed that wyze overshoots the target temp almost everytime. Meaning if my home temp set 68 and I change from sleep to home in the morning, it will keep running till it hita 68 before turning off. But because my system runs purge cycle on the control board, it will keep blowing hot air another 2 mins and temp will hit either 69 or 70. My old dumb thermostat had much more temp control and never overshot”

3 Likes

I see a Coast to Cool setting, maybe they should have a Coast to Warm. Overshooting that much makes no sense. Unless the deadband is ± 2 degrees, but they aren’t disclosing this yet…

My WYZE thermometer does the same thing. I set my temperature at 66 and when that temp is reached the thermostat shuts off. But my system keeps blowing hot air for another 1 min and 45 seconds and the temperature will reach 68.

My Wyze thermostat sometimes overshoots by three degrees. It will never stop heating until it is one degree over what I have set the temperature to be. It will say “heating to XX in N minutes” while it’s already a degree over XX and the burner and fan stay on well beyond the temperature being XX + 1 degrees. In my living room it will dissipate, but the smaller bedrooms get incredibly hot because of the overshoot.

It also says it starts “heating to” 15 to 30 minutes before it actually turns on the heater, during which time the temperature is a degree under what I have set it to be. The App shows the orange “I’m heating” screen, however, the thermostat is its normal “I’m doing nothing” grey, and the heater does not run.

I hope the above two issues will be fixed sooner rather than later with an app or thermostat firmware update.

3 Likes

Vincent, my Wyze Thermostat behaves the same way as yours, although it overshoots by only 2 degrees (lucky me). But everything else is the same as yours.

I sure do hope Wyze will fix this with a firmware update.

2 Likes

It generally overshoots by no more than two degrees, but in the three days that it has been on the wall, I have seen a three degree overshoot several times.

I have the same issue. I hope they fix this with an update.

I have the same issue. The overshoot doesn’t bother me as I can set the temp lower. But what does it mean “Heating to xx in N minutes”?

When the heater is on, the App shows messages like Heating to in N minutes. It is a very confusing message. When I first saw it I was wondering whether that meant it would turn on the heater in the N amount of minutes, but apparently it means that in the N amount of minutes it will stop heating because the temperature has reached the set amount of degrees. However, it will always overshoot that amount of degrees, and I have a couple of musical instruments for which the temperature and humidity need to remain as stable as possible, so the overshoot is definitely a problem for those.

Here is my observation until now based on what I have seen. I think the wyze thermostat is only sensing 1degree temperature Delta and not in between them. What I noticed is that, if I set to 68, the heat won’t turn on until it hits 67. So it kind of suggest that there is no fine grade control for temp Delta less than 1 degree.

I am hoping this is just a firmware coding issue and not really a limitation of wyze thermostat temp sensor. If this is hardware limited, then for sure it is not a product to replace any thermostat even though it is dumb or smart.

My day job until August 2020 has been writing firmware for power managment for server processors. All control system rely of something called PID controller (please search on Wikipedia). These basically have a feedback or temporary fluctuations on tiny amount of temp change and they is fed to PID control part of firmware code. There are some fancy systems which rely on heuristic and hysteresis, but even keeping those aside, PID controller should smooth out the on/off of any control system. Current wyze thermostat performance is called sawtoothing of PID control. This can happen either there is a no proper fine tune granularity of feedback loop ‘or’ weights of PID are not properly tuned. If it is earlier then it cannot be fixed with firmware update alone. If it is latter, some sure missed tuning these before product launch

I get that for temperature purposes you need some kind of Schmitt trigger logic, so as to not have it turn on and off repeatedly when temperature hits and lingers around a certain temperature.

But what I see happen is that the Wyze thermostat does not turn on the heater immediately when the temperature is shown as one degree under, and does not immediately turn off the heater once the temperature hits one degree over. If the thermometer is not capable of measuring within degrees, I would assume that at least the App logic can work with the number changes to base its commands on.

An added apparent bug is that, when the temperature shows below what I have set it to, the App on my phone will show the orange heating background, but it can take half an hour, or even longer, for the thermostat to in fact turn on the heater. That definitely seems incorrect behavior. If the App and the thermostat are not agreeing on their respective states, then I’m wondering what other discrepancies there may be.

I have this same issue. It’s total crap. What a disappointment

Same issues. I set my awake temp to heat to 71. Stupid thing does not turn on even when it is reading 70. Then when I do set it to 71 from the app it overshoots before it turns off… somewhere around 73 and my rooms are too hot. How hard is is to make a thermostat keep the house at a temperature I want? I am returning and getting ecobee.

I’m dealing with the same issue. So far, I have not found any replies from WYZE on the issue. I’m close to pulling the WYZE thermostat and putting my ecobee back on the wall.

Same deal here. This may be by design but doesn’t make sense that changing your Behavior mode to “Max comfort” should eliminate this. My t-stat waits until it drops 2 degrees and heats to 2 degrees above setpoint. This makes perfect sense to me to only run my heatpump for 30 mins every 3-4 hours vs kick on for 10 mins every 45 mins.

i have provided the feedback in the app with this forum post, you all can do the same. So hopefully wyze sees and fixes the issue. I’ll give it a month and if they still dont fix it, i’ll have to return as well.
BTW, I noticed that my Gas consumption is up by ~20% from the time I installed it. probably have to do with the way this is overrunning the heater than my old honeywell thermostat
Will wait another week and see it is not due to holiday cooking.

When you are setting the temperature preferences, note that it doesn’t just say “heat to 71”, it says Heat to above 71. so it’s working as intended. Just set your heat lower.

Yes, the hysteresis is high. It is more energy efficient to run the system for a longer period of time less often than to constantly short cycle to maintain a temperature.
Yes, you will not have the same temperature set as your old thermostat. It’s a different thermostat, it has different quirks, just set it lower. I had my old thermostat set to 63, and have my wyze set to 61, and it’s working pretty much the same as the old one was.

1 Like

Speadie, I don’t know where you see that, but in my App, wherever I can set the temperatures (including the temperature preferences screen) it definitely says “heat to” and “heating to”, not heat(ing) to above. I just double checked, and it really says just “to”

Settings>temperature preferences.
Yes, the display when it is actually running is different.
image

So you mean that I have to go to the temperature preferences window where it will say “heating to above”? Because as you can see on the attached picture, on the main screen it says “heating to”, not “heating to above”.

Screenshot from 2021-01-04 10-00-15|453x470