Wyze thermostat schedule not working

Hello. I’ve set the schedule and the temperature is not changing according to this schedule. Also, the mode of operation such as Home or away is also not changing as the schedule. I have not been “holding” the temperature either.

Reading the forum, I was able to setup different blocks of temp.

Right now I am wondering if they will work. Also, what’s the difference between sleep/Home and auto function detecting if I’m away or not. I would think sleep/home means I’m home, and not away?! Let’s say I leave during the “sleep” or during “home” state, the detection will be the sam?

Home:
This is your default block for when you are home and active. You can set multiple levels using multiple blocks and overriding the default temp bands.

Sleep:
This is your default block for how you want the temp set when you’re asleep. You should use this for night time or other times you’re at home but don’t require the same comfort level as your home setting to save energy. You can set multiple blocks and override the defaults for this as well.

Away:
This is your default block for when you are not at your house. This block works the same as the other two except the auto switch function will activate this block if you are farther than 3 miles from your house. It will also switch back to home if you are within 3 miles on auto switch or it detects movement past the thermostat.

In your example, if you leave during sleep or home and go more than 3 miles from your house, autoswitch will pause the schedule and switch the thermostat to away mode. When you return, it will set you to home. I am uncertain if it always returns to the home state or if it will return to the sleep state if that is dictated by the schedule.

1 Like

Also, the thermostat’s sensor will switch you out of Away mode and back into Home mode if you walk in front of the thermostat, but it will not switch you out of Sleep mode,

2 Likes

Thank you! Very thorough explanation, I’m very thankful for this!!

In my case, the temperature at night staying accurate is at the main goal. I’d do about anything for my child to sleep comfortably at night and it’s too hot at first, but it’s too cold at the end of the night for him. Can’t use the blanket well yet.
That’s why the old thermostat and one temperature wasn’t working.

Now I’ve set several modes, back to back and they are called “home”.
Based on the explanation, I’d think I won’t use the “sleep mode” at all, because the “home mode” will be more accurate for the night (for sleep, when I need an exact temperature).

1 Like

By the way, how do you know this? Is there an owners manual somewhere I wasn’t aware of?
I trust wyze will improve the app very fast and it’s going to be even more advanced. I’ve had the thermostat for over a week and today is when I am finally able to set up the schedule to my linking, thanks for helpful people on this forum. Wyze - for the future please have some manuals available, online are just fine.

For all intents and purposes, the names of the modes are just cosmetic for Home and Sleep. There’s no difference in accuracy, but it does let you set a default pref for the mode which can be handy.

The only one that really matters is the Away mode due to the auto-switch and the thermostat automatically pulling you out of the Away mode when it detects motion.

I know this through trial and error along with a dash of prior knowledge from other systems and apps.

Honestly I couldn’t figure out why schedule was not running either.

Then I went into controls from the Home Screen and clicked “stop holding”

Now the schedule is running.

So give that a try before sending it back.

So what you are saying is that the temperature doesn’t come out of the setting from the sleep mode? This is what I’m noticing, when the schedule time change to home mode the temp kept the setting from the sleep mode. What can I do? Create two home modes and eliminate the sleep mode?

I have my location off because now during the day there will always be someone at the house. So what do I need to do if my schedule mode changes but not the temperature. The temperature on mine stays with the temp setting in sleep mode(cooler)

Put screen shots in of your edit schedule and temperature preference screens and someone can likely determine what is going on.