Wyze Thermostat latest firmware issue

I’ve updated both of my thermostats to the latest firmware.
That would be 1.6.2
My general schedule is…starting at 9am, until 4pm, the schedule is set to Away.
For those that don’t know, previously, if someone walked by the thermostat while it was in Away mode, it went from Away mode to Home mode.
This does not with the latest firmware.
I got suspicious yesterday, then confirmed it for sure today.
Both thermostats are on latest firmware.
Neither thermostat switches from Away to Home with motion detected.
I’ve submitted a ticket.

I tested by manually setting the thermostat to away, then walked in front of it a few minutes later, it did change back to home.

Neither of mine are AND I try turning on presence detection, which also didn’t work.
And to correct my mistake above, firmware version is 1.1.8

I’m on the same firmware, but probably different app versions. I don’t see a setting for presence detection, it’s typically a automatic feature.

The presence detection in 1.6.2 of Android app might be new, I don’t recall seeing it before, but it enables phone location and other Wyze devices to determine if home/away. I don’t want to use (phone location) this as it runs constantly in the background AND it would require my family all to have the app installed. I want the simplicity of motion sensing on the thermostat to work as it did, since that’s is what my schedules are built around.

I can confirm that having away mode in a schedule seems to be broke with this latest firmware update. The thermostat display comes on when you walk by, but the mode doesn’t change like it did in the prior firmware (switch from away to home). I didn’t try manually putting it in away mode like Ken did to see if it comes out when not in a schedule; I will confirm the results of that when I have a chance.

I “spoke” with support this AM. They are looking into the issue.
Worth noting: when you submit a log, you are sent an email thanking you and instructing you to “connect with a member of our team” which I took to mean support.
Support sez…“My team here in support does not review your log or follow its progress. We’re working on developing a process so that we can track these logs on our end, but it’s still very much in progress. We hope to have the ability to receive more details from your log submissions soon.”

Same issue for me. Mode does not switch from Away to Home if you walk by the stat, like it used to. Screen does light up however, so motion is detected. Issue exists since 1.1.8 fw upgrade. I also do not want to use Auto Switch option based on phones location–useful for some people I’m sure, just not what I’d like.

Agree senses motion (as screen lights up) but doesn’t change mode.
I also do NOT want to use autoswitch…though it didn’t work for me either.

FYI all, this is what support has told me to try, which I won’t be able to do for a few days…
“Please perform a factory reset on the device.
To reset your Wyze Thermostat, press and hold the control wheel for 10 seconds. After that, delete the Wyze Thermostat from the Wyze app and set it up as a new device.”

Interestingly, I tried manually switching to away and then walked in front of it and as was mentioned by Ken, it does switch to home. So the problem seems to be isolated to state switching within schedules.