Wyze thermostat HELP!

Good day everyone. I just recently purchased a wyze thermostat. My home only has a 3 wire set up and only 2 of them are connected to my furnace (red white) green is not connected. Now my question is… is it possible to run this with the red white and green? I have a heating only system. There was no thermostat set up in the house just the wire. I see some use an adapter wire but that seems like it’s a bit don’t mind rigging and splicing wires but not something that controls my heat in my home…

Any help would be greatly appreciated
Really don’t wanna return

Thanks

Take pictures of the furnace side and the thermostat side. I will show you where to connect the wires so that your wyze works.

1 Like

That dirty wire is the thermostat has green red white. Green is not connected.

I have never seen this kinda of device on any of my previous rentals.
This is our first house so now getting right into the thick of it haha.

That’s a 120V oil boiler aquastat, it doesn’t have enough 24v power to run anything. You’ll need an external transformer to run the wyze. If you don’t have somewhere close to the thermostat location to install the transformer, then you can use a 24V relay and a 24V transformer in the boiler room. I have a thread detailing these connections here. Wyze thermostat simplified block diagrams - #10 by speadie

So basically follow the videos I’m seeing on YT? But that plug for the wall with 2 wires? No green connected is ok?

If you have a place to plug in a 24V transformer near your thermostat, then connect its wires to Rc and C (orientation does not matter here). Connect the red thermostat wire to W1 and the white thermostat wire to Rh. Tell the wyze that you have Rh, Rc, W, C wires on your “old” thermostat during setup. You do not need the green wire.

Is this what I would want to get ?

That would work, yes.

Great thanks so much for your help :+1:

Alright I got it wired up it’s got juice but it’s not giving me anything when I try to add the device keep getting is your hvac system turned on when it is.

What happens when you plug the thermostat in to the backing plate? You should see the wyze logo on the thermostat.

I do see the wyze logo. I go through the mount set up. When I get to the pairing process it’s saying check if your hvac system is on.

Am I missing something? Did I wire it correctly?

If you see the logo on the thermostat, then you probably have it wired correctly. Try turning on GPS on your phone, and make sure bluetooth is also on. some people have reported that this helps them connect. The wyze app needs the permissions to use bluetooth and location in order to communicate with the thermostat in order to set it up.

Got it working thanks again :+1:

1 Like