Wyze Sense Hub will not set up

Backed the home monitoring when it was first released and received the unit back in March. Due to a move to a new home I left it all in the box until now. Finally try to set it all up and noting works so far. Cant seem to get the hub to connect to my wifi it goes to “connection has timed out” within 6 seconds of entering the wifi password. After some troubleshooting reading forums and searching on google I figured out it may be my Google Nest wifi pucks not being on 2.4 GhZ so I tried the setup further away from my routers to force my phone to go on 2.4 and still it times out instantly and will not set up. My assumption is that because the unit is a few months old the firmware is now outdated and I can not use it. Tech support has not been able to help much.

I now see that they already have a V2 hub and sensors becoming available. Is my V1 unit even worth attempting to fix? I have a bunch of sensors that may be a waste now too. Can this stuff be returned past the 30 day period? Very disappointing so far to say the least.

Your sensors are not V1s if they came with the HMS, they are V2s. Can you connect the hub to your router via ethernet? You can switch to wifi after you have it setup, working and up to date.

Bill,

I have not been able to set up the hub on wifi or when directly connected to the router via Ethernet cable. After the prompt for the wifi password It says “Connection has timed out” about 5 seconds later. I’ve tried the Ethernet cable, wifi, made sure my wifi connection on my phone was on the 2.4ghz network. Reset routers, reset the hub……. No matter what I try I get “connection has times out” within a few seconds of entering the wifi password on the WYZE app.

As for the V1 vs V2 I was referring to the hub mostly. If my V1 hub connects it’s a non issue of course.

Did you try to complete the HMS setup when using ethernet? You need to setup HMS and get the hub connected to your account BEFORE trying to setup the wifi. There is an option for the hub to switch network connections but only after it is setup.

There may be other problems at play here since I’ve seen several similar posts about not being able to setup the hub or attach sensors to the hub. An ethernet connection should at least get HMS up and running. Another option is to temporarily disable an 5ghz network on your routers while you setup the hub. You should also consider what special characters you may have in your SSID or password, as well as the password length. Both can cause problems.

Here is one such post:

Yeah I tried the Ethernet cable plugged directly into the router a bunch of times and it didn’t workout. Because I use a google nest mesh network there is no option to force it to 2.4ghz. The workaround was to take my phone and the hub far enough from the router that the 5ghz wouldn’t reach the phone and only the 2.4 network would reach. I did that and confirmed my phone was connected via 2.4 ghz and still it instantly timed out.

You do bring up a good point though that I will address with WYZE support…. There is a space in my ssid so maybe that space is causing the problem with the hub even though it’s never been an issue with any of my other WYZE products.

I’m still not clear about something. When you connected the hub to an ethernet connection and pressed the setup button, were you able to configure the HUB and HMS? You should be able to do that without any need for wifi.

That’s what I would think. When I connect directly to the router with the Ethernet cable the setup process remained unchanged. I follow the prompts in the app, heard the “ready to connect prompt” then the hub would connect to my phone, still ask about wifi passwords on the app, then instantly time out when I provide the wifi password. I thought it was strange that even when plugged directly into the router the wifi password prompt would come up but it did.

Definitely not correct behaviour of the hub. Do a search in the forum on how to factory reset the hub. (I think it has to do with how long you hold the setup button but cannot remember.) It seems to be stuck with the wifi setup. Either that or you have some problem with the cable or connection on your router. Use the same cable and plug something else in and see if ethernet works or try another cable and port for the hub.

I’m the guy who submitted that other post about hub setup. It’s been a struggle. Here’s a couple of suggestions. After connecting the hub via Ethernet, pull up your router connection app and check and make sure the hub has actually made the connection to your router. If it is listed and it still asks you for a wifi password, then the problem is with the hub. If it isn’t listed, check and make sure your router’s access control function isn’t blocking the hub from connecting.

Thanks Bill. Yeah I tried the resets by holding the connect button with the power disconnected until it turns off a bunch of times. Tried pretty much everything i could find between the forums and Reddit lol. WYZE is sending a replacement unit so hopefully that does the trick.