Wyze sense Alexa integration issues?

Yes, you do need the main ring base alarm system to work with their other sensors. So, that becomes a fairly substantial investment if you only need motion sensors.

1 Like

As of this morning, it looks like my routines are working normally again.

At around 12:00 PM EDT, all my Wyze devices stopped communicating with Alexa. I kept getting a “device is unresponsive” message when checking any of my cameras or sensors in the Alexa app.

I suspected maybe they did something to the Alexa skill since it seems as though they like to do their maintenance on Fridays. So I once again disabled the Wyze skill and deleted my devices.

After relinking the skill and rediscovering my devices, everything started working as normal. I noticed that my Wyze plugs were responding a faster to Alexa commands than before.

So far, it’s been over 8 hours and I have been constantly triggering the sensor and I haven’t noticed it fail.

It looks like they finally fixed the issue for good thins time. Fingers crossed.

Hope this works for you guys if your still having trouble with your Alexa routines.

I will try to do more testing tomorrow including disabling/enabling the skill. The skill itself indicates it was last updated 6 months ago.

I noticed that too. They must have done backend work that may not necessarily require the skill itself to be updated.

I wish they would be more transparent at least let us know when they’re working on something that could affect our devices.

I am being cautiously optimistic, but after disabling my skill and re enabling it everything seems to be working.

Interesting thing is I have done that a couple of weeks ago as well.

Fingers crossed.

1 Like

I did some testing today. It removed the skill, deleted the motion sensor from Alexa, and then added the skill/device back. I created a new routine and the delayed no motion action weekend once and did not work after that. I reiterated the steps and it continue to not work. I will try again later into next week.

I believe that the reason it worked for you this time around is that they probably changed something in the Alexa integration yesterday and relinking your account likely reset the skill or something to that effect.

@isignedup One other thing I didn’t see mentioned that sometimes helps me with sensors issues is, unplugging the bridge, rebooting the cam and plugging it back in.

I don’t know if it will work for you, but might be worth a shot.

Thanks @rodaimi!

I think I previously had remotely restarted the camera during prior testing. If I remember correctly, I had to physically power the device off and on again (unplug/replug the power for a full reboot) before it helped make routines function again. So, I did that again and that seems to have allowed my delayed no motion detected Alexa routine to start working again. Based on that, it seems that unplugging the camera with the bridge from power and replugging it back in is the 1st thing that should be done when troubleshooting issues with Wyze Sense Alexa routines.

Another notes:
1)I have the Wyze camera with the bridge connected to a UPS. A Wyze Base station (for wireless Wyze outdoor camera), modem, and router also connected to the UPS. Such setup allows for some WiFi functionality in case of power failure (i.e. I can get to my Ring alarm/sensors, Wyze Outdoor camera, etc. locally/remotely).
2) I signed up for the Wyze Beta software program which utilizes iOS Test Flight for beta app versions of Wyze. I believe after doing such, I got a firmware update for my Wyze Base station (for Wyze Outdoor camera). I might have also received newer beta version firmware updates for my cameras as the versions I have are newer than the “What’s new” notes. But things were not working prior to all of that anyways and it may be that I have to do a complete power reset when new firmware updates are applied (if so, that might be a bug and something I will now try to pay attention to).

My no motion detected routine has worked 5 times in a row now including changing the no motion trigger time from 5 to 10 minutes.

Indeed this is one of the first steps you should take when troubleshooting any sensor issues. Not just Alexa related. Doing this helped temporarily restore my motion routines when they first started to fail.

I actually never thought about connecting my router to a UPS. I might do that at some point although I have been lucky enough to have avoided experiencing a major power outage in the past two years.

I too use the Wyze beta app, which is how wyze delivers their beta FW updates. Unfortunately, they don’t publish release notes for any beta firmwares.

While the recent beta firmware updates most likely had nothing to do with the sensor issues, there was an incident earlier this year where wyze released a buggy beta update for the Cam Pan which stopped the cam from recentering properly.

If you ever suspect an issue is related to a beta firmware update, you can roll back the firmware from the camera’s device info menu.

Another tip with beta updates, update one cam first and wait a few days before updating the rest.

Thanks again for your help, suggestions, and information.

I am doing more testing with one of my routines. I am able get a light to turn off with a delayed no motion Alexa routine and now back to working on the original item of having a ceiling fan turn off with a delayed no motion routine issue. The ceiling fan is not WiFi and uses the old-fashion RF remote. I have a Bond device (RF and IR blaster) that works well via Alexa voice commands, but seems to sometimes struggle within the delayed no motion detected Alexa routine. I previously did a double action with a wait in-between and that appears to makes things work more consistently. My 1st and 3rd (just now) test worked. So, I am just down to trying to figure out if soemthing isn’t flowing correctly or if I just need to do a double command with a wait step (really no harm doing such and I have to do that with some lights - turn them on, then set brightness/color in another step after a wait).

Today I did more testing and I think a pattern emerged such that when adjusting the delayed no motion detected timeout within the Alexa routine, the routine stopped functioning until a restart of the camera/bridge. I will do some more testing to see if that process holds true. If so, that would explain some of the frustrations that have been occuring with delayed no motioned detected routines. The simplest workaround for such would be to always remember to restart the camera/bridge after adjusting any Alexa routine (especially if adjusting delayed no motion detected timeout).

Not sure if testing is a good idea now when there is an update going on ?

For me, I noticed issues with my no motion routine even if I don’t make any changes to my Alexa routine. I think what your experiencing is just a coincidence and doesn’t really have anything to do with changing the Alexa routine itself.

Since rebooting the camera with the bridge seems to temporarily solve the issue, I now believe that the camera’s FW could have a bug contributing to this issue, but I really don’t know.

Another thing I noticed is my routine usually fails when my camera is turned off from the Wyze app or Wyze schedule (not physically unplugged) however, rebooting and turning the camera back off fixes the issue.

I’m currently experimenting using a Wyze plug to reboot my camera every twelve hours. Since I installed the plug yesterday, everything seems to be working fine. If you don’t have a wyze plug, you can probably use a christmas light timer and set it to turn off twice a day and see if that helps.

I’m going to try sending wyze cam logs as well as the sensor logs next time I notice the routine fail. I’ll report back with my results after another day or so.

1 Like

I thought things were working for a couple of days and now they are not again.

Same issue… motion detected and lights come on… motion not detected and lights never turn off.

I have disabled and re-enabled my Wyze skill, rebuilt my routines and rebooted the camera that has the bridge in it.

I seem to have some intermittent success, but nothing that sticks

Today’s update… This afternoon my delayed timeout routine started to run without doing anything. I changed the delayed timeout twice on the Alexa routine and both times it has worked. I have had no app (really don’t see how it could be the app because the trigger is with the sensor, Alexa, and the Wyze/Amazon clouds) or firmware updates (I am using beta versions). I also have not done any reboots. Also, remember that my camera with the bridge is connected to a UPS and thus, I have had no reboots either due to power loss, etc.

I guess I will give it a few more days before buying a Ring motion detector (since I have not had any issues with those when using them in routines including delayed no motion detected routines). Unfortunately, the 2nd generation ring motion sensors are 5 times the price of a Wyze motion sensor, but a motion sensor that can’t reliably implement routines isn’t worth anything.

1 Like

Also - similar discussion started today - Motion sensor cleared not executing alexa routine

I contacted support yesterday via chat this time, I directed the support agent to this thread. Maybe they’ll be able to look at the testing we have done to narrow down the problem. That’s assuming they’re actually investigating this issue.

I’m going to give them until next Friday to do something about this issue. I’m tired of having to mess around with my motion sensor and cameras. I might have to look into a reliable local camera and smarthome setup.

2 Likes

Guess I’m late to the party but glad I found it nonetheless because I was starting to believe I had either something wrong with my network setup or just plain had bad sensors. The fact that everything else works fine except for this same “motion cleared trigger” not working issue is ccx what kept me poking around. What’s discouraging is seeing the timeline of this thread with no support direction. Should have done more research before buying 8 of the sensors… wonder if they take returns, I haven’t opened them.

I noticed if I reboot my camera every so often it works for a bit…

What a wild issue… Seems I am now rebooting my camera every day and it works most of the day…

1 Like