Wyze scale problem. Help. Won’t turn on

Scale arrived today and booted it up. My son steeped on and it registered his weight. I connected scale to app and got a firmware notice. Updated firmware and it threw “er 3” at about 88%. Now it won’t turn on. Pulled batteries for a few minutes. And put back in. Nothing.

1 Like

I don’t have a resolution, just connecting dots. Looks very similar to this issue:

https://forums.wyzecam.com/t/wyze-scale-died-during-firmware-upgrade/95825

Yep. Thanks for the link. Didn’t see that one

The link is dead. My scale should be arriving soon and I would not like bricking it.

I just updated mine, which is an older model, with zero problems. So, - no help from me.
I will tag in the @moderators who hopefully will move this up and get some eyes on the issue ASAP.

I even pulled stickers looking for reset switch. I would think with BT there would be a reset switch somewhere to enable pairing. Must go into pairing mode everyone you replace batteries.

Can a @moderators combine this thread with this other thread? Thx!

https://forums.wyzecam.com/t/wyze-scale-died-during-firmware-upgrade/95825

[Moderator Note: the threads have been merged.]

1 Like

Was doing the first firmware upgrade and at 88% it froze and scale had an Err 4. Opened a support ticket. Scale is dead even after pulling batteries. Can’t even weigh myself now.

Hi Barry, we are working on this issue, will keep you posted if any update. May I ask what phone you are using? Thanks!

1 Like

Wyze app not detecting scale. Bluetooth on, imternet working. Scale registers weight. Anyone else?

1 Like

Resolved on its own, thx

1 Like

Same thing happened to me. Scale showed up, I connected to app, stepped on to register. Then was hit with update firmware. Got an Er 4 now scale does nothing.

In case this helps you debug logic… scale showed up a few days ago, started up Wyze app via Android 10 phone, installed batteries in scale, added scale via Wyze app, set up my scale profile, the update firmware message popped up, I dismissed it and stepped on the scale. Satisfied with the results, I recorded a heartbeat rate. Then I updated the scale firmware. Everything is still working well on day 3.

I had the exact same issue myself and have also opened a support ticket.

I have an iPhone XS. I am on version 2.10.31 (beta) on the app. Support is sending me a new one out. The question is, should try to reproduce this again with my existing beta app, to see if beta is the issue or should I go back to production.

Hi Matthew,

May I have the ticket number? We will ship you a replacement. Thanks!

you are not alone. i’ve just contacted their customer service and got a replacement. Even if it is repairable over the phone or through email, something is buggy about THAT PARTICULAR camera and I would want it replaced.

I am also using and iPhone XS and had the same issue.

Best Regards
Matthew Leman

Hi All, please just use production for now, we are working on this, will keep you posted. Thanks!

Thanks for letting us know. The firmware upgrade failure is a corner case, we already found the root cause, will fix it.

1 Like