Wyze Robot Vacuum Cliff Sensors Explained

Hello Wyze Robot Vacuum users,

As you may know, Wyze Robot Vacuum has 4 cliff sensors on its bottom edge. Do you know how the cliff sensors work to avoid falling off the stairs?

Cliff sensors measure the distance between the robot base and the floor, usually by bouncing infrared light off the floor. If there is a sudden increase in the distance to the floor, the amount of reflected light off a surface changes. That means the robot is getting close to a stair edge or something similar, so it will back off to avoid falling over it (hence the “cliff sensor” name).

Why does my vacuum refuse to clean dark carpet?

Sometimes, Wyze Robot Vacuum may not run on certain dark or black-colored surfaces because they’re not reflective enough for the infrared. In this case, the cliff sensors are triggered in the same way as they would be if there were a drop.

Any workaround to disable the cliff sensors?

At present, there is no immediate solution to disable the cliff sensors as they are essential in many homes. It also involves complex underlying navigation algorithms and requires a lot of effort to make changes. A workaround is to tape over the 4 cliff sensors with white/light-colored paper to manually disable them if you have to. Please DO NOT use this workaround if there are any stairs/cliffs in your home.

Keep the cliff sensors clean

Remember to clean the cliff sensors once in a while to ensure optimal performance. To clean the cliff sensors:

  • Start by turning your vacuum upside down
  • Wipe each cliff sensor opening with a clean dry cloth
  • Make sure to clean all four cliff sensors

Please feel free to share your experience with your Wyze Robot Vacuum and the cliff sensors. We would love to hear from you! If you encounter any bugs, glitches, lack of functionality, or other problems, please let us know immediately by submitting a log and contacting our Wyze Customer Support.

https://wyzelabs.zendesk.com/hc/en-us

Warmly,

The Wyze Robot Vacuum team

7 Likes

Thank you for taking the time to post this. While it is true that many of us understood the way these work in general, it is nice to get something officially written by a Wyze employee, also to get definite confirmation, and have a reference to refer others to about this.

It’s also nice to understand why Wyze hasn’t created a setting to switch these off (ie: that it is tied into the main navigation algorithm and it will be a complicated process to separate this from the existing code to be a separate subroutine/function that only activates when selected in settings…having some programming experience I can understand that deconstructing an existing algorithm to do something like this can be complicated if it wasn’t originally coded with a bunch of separate subroutines…if parts of it are kind of like spaghetti code, it could even effectively be impossible without rewriting most of the entire firmware. I recognize that while Wyze did some of the coding for this firmware themselves, some of it was pre-existing from the supplier/manufacturer, and that Wyze simply added some of their own customizations to the code…meaning that a lot of the original coding structure probably is not Wyze’s fault.

Anyway, It was nice to read that you did not deny us of all hope that this could possibly happen at some day, though from what I understand of the issue and my programming experience, I think I agree that the amount of effort it would take to fix it is not worth the cost it would take to dedicate employees for. It’s much easier just to tell people to tape something light colored over the sensors for the few people who absolutely need this…it will still be frustrating to many people, but at least there is a workaround.

Thanks for sharing.

2 Likes