Wyze Plug stopped working -- just making a ticking noise

I recently purchased two wyze-plugs and one just stopped working yesterday. I came into the room and there’s a reasonably loud ticking noise – kind of like the tick-tock of an old-school wall clock. The blue light is on, but it’s completely unresponsive. I unplugged it and plugged back in, but no change. I tried a different room/outlet – no change. I tried a factory reset – no change. What do I need to do to restore use of this device? I’m concerned the tick-tock noise is a selenoid or relay and don’t want it overheating, so it’s just unplugged now…

If it’s clicking continuously without you asking it to in the app, it sounds like relay chatter. If that’s the case, I would contact support for warranty replacement since that would be a hardware issue.

Along with @raym64 advice, if you have not already I would unplug it. Definitely contact suport

WYZE Support

Live support is available:

+1-206-339-9646

Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT

1 Like

Thank you. I definitely left it unplugged. I chatted with someone in support today and they arranged for a warranty replacement. Thanks!

2 Likes

I am on chat with support now. same issue. hoping they will set up warranty replacement.