Wyze Plug Setup-Early Access

As a WiFi device the Wyze Plug will have a lot of the same general caveats as the Bulb. That said, if you are having setup troubles, make sure none of these things are interfering:

To start, if you are on iOS 13, confirm that you are using the most recent version. Also, iOS 13 users should update to version 2.5.53 or above of the Wyze app using the Apple App Store. iOS 13 won’t allow the app to see your local networks if location services for the app are turned off. You can turn the location permission off again once the last device is set up (Settings > Wyze app).

Environmental:

  • Plugs must have access to a 2.4 GHz network.

Phone:

  • Turn off mobile data (some phones don’t like connecting to a WiFi network that doesn’t have an Internet connection, which is what the plug looks like to them).

  • On Android, after connecting to the Wyze Plug, wait 5-10 seconds to see if it warns you that the network has no internet access, asking if you want to stay connected anyway. Tap Yes you want to remain connected, then proceed with the rest of the Wyze Plug setup.

Router:

  • Turn any MAC filtering off during setup (you should know if you engaged this unusual item on your router.)

  • Sufficient range of DHCP network addresses must be available (some people restrict this).

  • Depending on your Plug’s firmware version, if your network name (SSID) is 25 characters or over, you may have trouble setting up the Plug. The workaround is to set up the Plug on another network (like your Guest network), update the firmware, then set it up on your intended network. If using another network isn’t an option, then reducing your network name (SSID) long enough to set up and update the Plug will be necessary.

  • If you have a PLUME WiFi mesh network and your Plug times out repeatedly (you may also get a 404 error), then temporarily disable “Online Protection” and/or the “Advanced IoT Protection”, as they appear to block access to either Wyze or the Plug. After the plug is activated you can re-enable protections.

  • If you are having trouble connecting to the plugs, check to be sure WMM (Wi-Fi Multimedia) is turned off in your router options.

  • If you have band steering on your router, know that some implementations won’t allow the Plugs to connect to the 2.4 GHz network if the 5 GHz network is available. The solution is to turn off the broadcast of your 5 GHz network long enough to set up the Plugs.

Tip:

  • When the app asks you to input your network name and password, click the closed eye at the end of the password line to see the password you enter. Remember the password is case-sensitive.

  • Set up the plugs close to the router. Once all settings are in and the plugs are working, they can be moved to the desired location and all the settings will remain.


7 Likes

Tip: As hard as it will be, try to exercise patience while waiting for the plugs to be delivered. :grin:

1 Like

I’ll mention one Android-specific step that I always run into:

  • After connecting to the Wyze Plug SSID, wait 5-10 seconds for Android to warn you that the network has no internet access and ask you if you want to stay connected anyway. Tap Yes, then proceed with the rest of the Wyze Plug setup.

If you don’t tap Yes or try to start setup before that popup appears, the setup will time out. This has been verified on Android 7 and 10:


6 Likes

Hm, on my Android 10 Pixel 3, I never got that warning. It would just reconnect to my main WIFI network without asking. I finally got it to work by turning off cellular data. Ideas on why I wouldn’t get that “no Internet” warning?

I’m not sure, but two of my coworkers have Pixel 3s and they have major issues with the corporate WiFi. I think they can connect, but it takes too long to get an IP so the Pixel thinks it has no internet and just drops the WiFi connection/retries. May or may not be the same issue. I’m not sure if that behavior is controlled by a setting somewhere or just a built-in helpful “feature” of the Pixel 3.

Sorry, @thequietman44, I didn’t notice your post. I will add it to the caveats now.

I’m not even getting to the countdown connection screen!! It won’t let me pass the “connect the the plug” screen… I’ve never had this much trouble connecting to a Wyze product before!

If you go back to your WiFi settings, is the Plug still selected as your network?

Yeah everything is connected and it is on a 2.4ghz network :sob:

If you’ve done everything in the first post, then it’s probably time to submit a ticket:

https://support.wyzecam.com/hc/en-us/requests/new

Anyone have a plug were their status light is no longer on?
It was on before today
The plug works in Alexa and in the wyze app but there is no status light on, and I did not turn it off in the app

All of mine are still on, have you tried turning it off and then back on

Turned it off and back on unplugged it and plugged it back in, no light
Edit it blinked when I plugged it back in but then went off and stayed off
Edit 2 , status light is on when plug is on

How about cycling the option in the app?

I checked mine just now and it is working.

Did that too

Ok so after a ticket was filed we figured out that it was because I was on iOS13. If you’re having issues… try it on an older device! Worked perfectly on my Amazon Fire

2 Likes

Make sure you have location services on in the app. A setting in iOS 13 won’t allow set up with off. @WyzeGwendolyn tipped me off to that today on the Facebook group.

3 Likes

What exact version of iOS 13 were you using when setup failed? I have heard the problem may have been fixed in 13.1.