WYZE Plug schedule - timer problem

I have a WYZE plug (ver 1.2.0.93) and I have schedules created to turn ON and OFF a water pump 5 times a day for 3 minutes each time. It turns on at the correct time, BUT for only for 1 minute. Currently each schedule has the start time and a end time. Any help will be appreciated.

2 Likes

Can you post a screen shot of one of the rules? And the rules history from the app? Maybe fresh eyes on it will see something.

2 Likes

As Omgitstony mentioned… can we see your rules? I can try to duplicate the same with a plug here.

2 Likes

My gut thinks that maybe the rule is set to trigger at the top of the hour, and maybe doesn’t actually trigger until the :01 or :02 mark due to peak server load at that time. Then the end of the rule triggers at :03, ergo the one minute of on time. We shall see! :slight_smile:

2 Likes

The plug group, plug and schedule

2 Likes

Hmmm. What about the “rule history”? It’s under “account - rules history”

1 Like

Here it is…

I did some tests with my plug. I’m not sure I replicated your scenario exactly, but here are my results and some thoughts.

I set a 3 minute schedule using rules. See screenshots. Tests were successful, and my lights stayed on for 3 minutes.

Comparing my screenshots to yours. I had my rule set to turn on at 2:55, and off at 2:58. My “Rules History” shows both of those events, right at those times. In your rule, it looks like you have it set to come on at 4:30, and off at 4:33. I see that it came on, but not until 4:36. And then no history of it going off. Something strange there. Do your other plugs miss their on-time schedule by 5 or 6 minutes like that? Also, does your history show other plugs recording the on event as well as the off event?

Could there be other rules with actions attached to “hydroponic pump”, or a group of plugs with that plug in it? I only ask because I’ve renamed devices before, forgetting to remove them from the actions list of other rules, only to wonder why my lights and things were not behaving properly. (Might check any routines you may have setup with Alexa or Google as well.)

It’s a pain…but you might try disabling all your other rules and try this 3 minute test again. Or, if you’re in a production environment…setup a test Wyze account, and add this one plug to it, and try the 3 minute test.

You might also try deleting the plug from your account, and re-adding it. I think that would remove any old references in rules, etc.

Let us know what you find!

1 Like

Well, I missed the first timer at 4:30 am for the pump today … but i’ve changed all the start times to be 13 minutes after the hour and end times to be 16 minutes after the hour. The plug shows it has two minutes of run time so far. I should add 12 more minutes of run time by 7:30 tonight. If I dont, I will remove the plug and start over.

1 Like

It seemed to work much better moving the start times. But this morning the 4:13am - 4:16am timer ( in rule history) didn’t start until 4:19am and only ran for 1 minute. So tomorrow I will delete the plug from service and re-add it…

1 Like

The starting late and running short thing is off-putting. Is it only this one plug that’s doing it? The rest are consistently correct?

Yes, I think … but the rest of the plugs have schedules that run hours not minutes… I will watch them closely this weekend.

1 Like

After watching the Fan, UV light, the Grow light, and Pump they all can be off by tens of minutes from time to time. The grow light this morning was scheduled to come on that 4am… didn’t come on until 4:16. The Pump was scheduled to turn on at 4:13 and off at 4:16, turned on at 4:19 and turned off at 4:20.
#Omgitstony hinted at it might be WYZE server loads and that sounds plausible. For now, I have just increased the pump timer to be on additional minutes to mask the issues with the plugs. I would appreciate any new thoughts and I appreciate all the help so far.

1 Like

Even if your disregard everything else, the starting late issue is baffling. Maaaybe server load, but offsetting by 6 or 10 minutes seems like it should handle that. If you don’t mind, what time zone are you in? I want to try and recreate the same conditions. I’ll set a plug or two for the same time and zone and let it run for a few nights.

Once you set the schedule in the app, the plug doesn’t wait for the phone to tell it to turn on, right? The instructions are coming straight from the server over the internebz, afaik.

Any network-wide VPN going on? Just trying to think of anything that might cause a weird delay.

I’m in Pacific time - California. I currently have the wyze sprinkler controller, 2 wyze thermostats, 7 active wyze cameras, and 6 wyze plugs. 4 of the plugs are used for the hydroponics. No Alexa or goggle assistant. Just the out-of-the box Spectrum internet router for the home network. Which offers no settings controls except for the SSID and wifi password. Other devices on network include 4 smart TV’s, 3 PC’s, 3 iPhones, 1 printer, 2 Raspberry Pi’s. Speedtests show download speeds at around 400Mbps and upload speeds at around 22Mbps. Thanks again for your time.

1 Like

Thanks for the info. A similar setup to mine in a lot of ways. I’ll set a few timers and see what happens.

L. I. B. … I was able to reproduce what you’re seeing. I set three plugs to come on at 530am. Two regular plugs, and one outdoor plug for good measure.

All three came on about 5 minutes late, and only stayed on for 1 minute. Even if that’s an off-by-a-few-seconds error due to network latency or something, that’s still on 5 minutes late, and not on long enough.

I reset them to do the same test at 130pm. (I also added a bulb in the mix, just to get a good spread).

All 4 came on right (smack) at 130, and turn off a few seconds before 133 (they show 132…that’s why I wonder about the off-by-a-few-seconds that I mentioned before.)

So…successful in the afternoon, not successful in the morning. Now I’m looking harder at @Omgitstony’s idea about server load.

I think I’ll do some more tests with the same set to try and feel out the trouble window. 430amPT is 730ET. Could be a lot going on server wise as people wake up. I think I’ll try a few hours before that, when presumably the bulk of the country is slumbering.

Note: 530 is not exactly the same timezone as I’m Central Time…but we’re up and around at 630 and the lights would be coming on via motion sensors.

Also… @WyzeGwendolyn If anyone there knows about server load in the morning causing a delay, and what the time window with the heaviest load is, that would be really helpful and would save us some tests. :slight_smile:

2 Likes