WYZE plug on/off issue

Wondering if anyone else is having an issue with Wyze plug scheduling. Auto on/off is not consistent. I have had my plug set up now for about 2 weeks. I have a floor lamp set to turn on at 7pm and turn off at 11pm. It has gone on at 7pm consistently 100% of the time but has only turned off at 11pm approximately 50% of the time. I wake up in the middle of the night and need to turn the plug off manually through my Android app. It has a mind of its own as to if it will turn off by itself. I updated the firmware on the plug and I have the beta app. I have reprogrammed it a few times but that defeats the purpose of having it. Any ideas? Thank you!

4 Likes

I have not experienced your specific scenario but for 3 days running my Hue light would not turn on when my Ring contact sensor opened on my sliding back door. Then all of a sudden it started working again. I was using an Alexa based routine. Welcome to the wonderful world of IoT!

Yes the mystery world of IT. Many gremlins in it. I went to my phone settings and enabled “Shut Off Immediately” after closing the Wyze App. Maybe that will help.

2 Likes

This has happened to me too. One day the 2 rules worked and the second day they didn’t with to turn it my plug. I changed it to a single rule now and I feel it has been running more smoothly. Do you have it set up as one rule or two rules?

1 Like

Hi and thanks! I do have it set as one rule. I find that deleting and then recreating the rule has helped for a couple of days and them it goes back to not wanting to turn off. I’m going to replace it with my spare and see if I have the same issue. I probably should have thought of that already. DOH! Thank you!

2 Likes

Indeed! Scheduling does appear to be ready for prime time! In addition to erratic on-off behavior, the app is not clear as to how to actually program the schedule.

Welcome to the community, @xerothecat! You can find many helpful articles on the Wyze support pages. :slightly_smiling_face:

Rules & Schedules

2 Likes

Probably the easiest solution would be to create another event to turn the light off a second time at 11:01 pm.

Sure. But that won’t help with the WyzePlug randomly turning on. The problem is that the app is poorly designed and and it probably isn’t even a beta version at this point.

That is truly odd behavior. Fortunately my plugs are rock solid. I would definitely open an issue with Support.

You can create a ticket here.

I have deleted all previous scheduled on/off times, quit the app and shut down my phone and restarted it. I selected the Wyze Plug and added a rule to turn on the plug at 7:00 p.m. (the was at around 6:30) , I set another time to turn off at 1:30 a.m… The Wizen plug turned on at 7:00 however it turned itself off around 8:30p.m… Later, it turned itself on again around 10:05 p.m. I am about to go to bed and will see if and when it turns itself off. I can turn the plug on and off manually with the app. It just turned itself off at 10:27!

It appears the app is not working unless the actually hardware is faulty.

1 Like

I am having a similar problem. The Wyze plug alwaysworks when I manually turn it on or off using the app, but the scheduled turn off time does not usually work. I had two schedules at 11pm (the other one not plug related), so I changed the plug schedule to 11:01pm hoping that would fix the issue. It didn’t.

Did you ever find a solution to this apparently erratic behavior? Thanks,

2 Likes

Not sure if it permanently solved the issue but I no longer just modify the times if/when I need to modify. Rather, I delete the entire rule and start with it from scratch. So far it has been working for the past 10 days on the 2 plugs that I use. Both plugs have a rule for turn on @5pm, turn off @11:30pm. Fingers are crossed and so far so good! And falling back to standard time was automatic and also worked perfectly on both plugs.

2 Likes

Thanks… I’ll give it a try.

My plug randomly turns off…
Setup went fine, works great from app, firmware updated to latest…

Yes, I think you are right! Modifying a rule never seems to work. Maybe there is s some weird trick when you modify, and then restart the camera or iPhone but I haven’t had any success with that…

Same here, the plugs worked fine for almost a year then one started turning off late. Now I have 2 with the same behavior. I deleted the rules, created new ones but still turn off late.

I have a light schedule to turn on at 9am and off at 9pm. The plug sometimes just decides to shut off at random times in between, even when the wyze app is not open on my phone. I do not recommend using these plugs over traditional timers, which are reliable.

You could try setting up your schedule for the plug in the Alexa app instead or just eliminate the plug like I did and use a wyze smart bulb, but then again that bulb might not work in your situation

The bulb wouldn’t work as its a fancy aquarium reef LED light. It worked fine for a day. I deleted the schedules and created new independent ones for on and off instead. We will see how it works. Still doesn’t explain its odd behavior to turn off at 7pm and then around 8:30pm, for zero reason. I actually wondered if my LED light broke but then remembered I’m using “Wyze” products haha.