Wyze plug issues with Alexa voice commands

Wyze plug works with Alexa app but not voice command. The response is “Sorry provider is having trouble”

“Sorry I didn’t find a device named plug”
Is what Alexa tells me even though “plug” can be operated from the Alexa app.

Did you name the plug , plug when you set it up , or did you name it something else?

Something else

You have to use whatever name that you named it for voice commands
look in your Alexa app and see if the plug is listed in there

It is

The name you see in the Alexa app is the name you need to use for voice commands

If Alexa is not working with the plug try , disable the wyze skill and then enable the skill back again

Still no good

Plug was named “plug” when setup.

I was referring to voice commands using the Fire TV Stick 4K with latest software 6.2.6.5. When the TV is on, Alexa replies through the tv “Sorry I didn’t find a device named plug”.

I now realize that the Alexa app can do voice commands. That works.

Should I also be able to use the Fire tc stick to control the Wyze plug?

The Alexa app says the Fire device is offline. Not sure how to get it online.

I’m not sure about that yet , haven’t tried it.
I can view my cameras on my fire TV by using voice commands to my echo dot

Solved I named the plug with a 3 letter word, initially renamed to same word with plug added. I named it Tea to turn on my hot water in the AM, Renamed to Teaplug and now it responds to the voice commands

1 Like

Glad ya got it working
Yes I have found with Alexa you need to name things with 2 words, that works much better
I named a plug, plug one and it worked just fine in Alexa