Wyze Plug Firmware Failed

Of the two Smart Plugs, ones will not upgrade its firmware. Gets too 100% and fails. I’ve recycled the power on it and still won’t take. The first one did the same thing but after a couple of tries finally took. This one won’t. Anyone else having this issue?

I have not had this issue personally. All of my plugs were able to update and reported success by the time the progress bar reached 22%.

Thanks for the reply. Must just be me ;(

Could be a problem with the specific device if others work for you.

Late last night finally got it working. Ran the update on my iPad and it went through. Strange but at least it went.

2 Likes

i am still facing this issue. i deleted the device and now it doesnt connect anymore

I ran into this issue with one of mine.
I had to try a few times and finally got it to work.
A couple suggestions…
Reset it and re-add it to your account.
Do the firmware update from the 2.4GHz network that it is connected to.
May or may not be the answer, but that’s what finally worked for me. Could be coincidence.

1 Like