Wyze forces Outdoor Plug Stuck as Channel 1 even when moved in App - Causing mild Tiny Cam Pro issues

This is a very technical post regarding Channel Numbers.

I was hoping I could instead submit a cool Tips & Tricks post with a great workaround for everyone, but my multiple workaround attempts (well, except for one, which isn’t good enough to count as a long-term workaround) failed and were thwarted, so now I am left to posting an explanation of the bug to those affected and also hope there is something Wyze can do to allow us to change the channel numbers like we can with every other device.

Basically, I found a bug with the Outdoor plug or the App causing Outdoor Plug devices to be stuck at the top of the channel list. I was originally going to post this in Early Access, but the nature of the issue leads me to believe this might be a long-term problem that may need to be referred to for people without access to that sub-forum, I guessed that this might be a better place for it.
(Mods are of course welcome to move this topic to a better spot if desired.)

I hope someone @WyzeTeam will take notice and address this issue…Maybe one of the Mods can help send this to Wyze’s attention if any of you who read this agree it is a good one for them to be aware of, I’d appreciate it (it’s definitely over the heads of anyone in general support to do anything about, and not necessarily something where submitting a log is probably relevant).

Summary:

The Outdoor plug is stuck on Channel one. I tried moving the virtual nodes (plug 1 and 2) around, even to the very bottom, but it didn’t move the channel number at all. So I put them in a device group and moved it around, but the channel still never moved (as it would with ANY OTHER DEVICE). Nothing would change the channel number.

Granted, this really only matters for third party access stuff (like Tiny Cam Pro use in order to stream our Wyze Cams through a browser or locally to other devices, and other similar uses).

I am still not sure whether Wyze is doing this intentionally (since it always resets the plug to the top of the channel list if I try to manipulate the order with a workaround) or if Wyze doesn’t realize it is happening. I will explain in more detail now:


More detailed overview/explanation:

You can verify all of the following explanation by using something like Tiny Cam [Free or Pro]. Set up a Wyze camera, then in the settings for that camera, select Camera Status at the very top. It will then give you the details of the information coming through the Wyze Cloud Protocol. At the bottom where it says “Wyze Devices” it will list all your devices in order of channel number. If you don’t have a Wyze Outdoor Plug, then this order should exactly correspond with your Wyze App Home Screen Device order. If you have a Wyze Outdoor Plug, then it will likely be out of order and messed up.

Normally, the “Channel Number” of the Wyze smart device matches exactly where it is located in the Home screen list.

For example, if on the home screen, your devices are ordered as:

  1. Wyze Scale
  2. Front of house Cam
  3. Desk Lamp Wyze Bulb
  4. Backyard Cam

Then the channel numbers would be exactly as listed above (Scale = Channel 1; Front of House Cam = Channel 2; etc.

If you rearrange the order of the devices in your app, the device changes channels corresponding to it’s new location.

If you put devices in a group, then the channel still follows the same order within the group. So if you had:

  1. Wyze Scale
  2. Outside Cameras Group
    a) Front of house Cam
    b) Backyard Cam
  3. Desk Lamp Wyze Bulb

With groups as above, channels still follow the total order they are in. So in the above example: Scale = Channel 1; Front of house cam = channel 2; Backyard Cam = Channel 3; Desk Lamp Wyze Bulb = Channel 4.

Okay, so now my real-life example from my actual app:

  1. Scale (Should be Channel 1)
  2. Upstairs camera group (6 cams - Should be Channel 2-7)
  3. Downstairs Cams (2 cams - Should be Channel 8-9)
  4. Outside Cams (5 cams - Should be Channel 10-14)
  5. Outdoor Cam (my 1 WCO - Should be Channel 15)
  6. Backdoor sensor (Should be Channel 15)
  7. Den Storage Bulb Should be Channel 16)
  8. Plugs Group (Should be Channel 17)

Here’s the screenshot of the lineup:

Here’s what the Wyze server shows the ACTUAL channel lineup is:

Note that Channel 1 is not the Scale, even though the scale is at the top of the app. It is forcing the Outoor Plug to be at the top of the Channel list for some reason. It also doesn’t update the plug’s actual name, and leaves it listed as “Unknown Device” while every other device lists what the edited name of the device is (Ie: “Piano Room Cam” on Channel 3 is properly named what I named it)

I believe this is caused because the Plug device itself is not available to see in the home screen of the Wyze App, but lets us see and move virtual representations of the 2 nodes (Socket A and Socket B, which both use the same channel number, but won’t change the order no matter where they are located) within that device In theory, this should’ve meant that if you activated a new camera (or other device) after an outdoor plug, then the outdoor plug would move down to channel 2. This indeed happens!

Okay, so then if I moved a camera, or camera group or device ABOVE that new device, then those devices should remain ABOVE the hidden Plug. That should be a work around to get all the cameras back in order to the top of the Channel list and match back up with my TinyCam named order, right?

Sadly, NO…while activating a new device DOES put the new device ABOVE the Outdoor Plug in the channel line up…any attempt to manually edit the device order in the Wyze App (to move other cams above the new device, and thus in theory above the Outdoor Plug), causes the Outdoor Plug to be RESET back to the top of all the devices, including the one it used to be listed as being underneath a moment ago, and thus becomes listed as Channel 1 again, though the order of the rest of the devices will otherwise go in the correct order as intended (except for the Plug going back to being channel 1, and now nothing is above it anymore).

Basically, if you use Tiny Cam Free/Pro, then everytime you get another Wyze Outdoor Plug, it is going to seriously screw up your Camera order and cause you a bunch of work to manually edit/update the channel number of every single camera. Sadly, that’s the only realistic solution. In theory, you could just delete every camera from your app and set them all up again in reverse order, but then the moment you add any other device, it’s all screwed up again, and if you ever manually edit the device list, the Outdoor plug will go back to be channel 1 again anyway, so that’s a terrible workaround.

I only purchased/activated a single Outdoor Plug device, so I cannot verify what Wyze does if you have more than one. How does it choose which Outdoor plug to be at the top at Channel 1? Can anyone with 2 Outdoor plugs verify if both stay at the top, and does Wyze keep in Activation order to determine Channel 1 and 2, or is it alphabetical or seemingly no pattern?

Has anybody else with Tiny Cam noticed this issue yet?

I regret that my attempts at a workaround were ultimately unproductive. Thought I’d at least post this to help anyone else who becomes curious why their cams get all screwed up out of order every time they activate an Outdoor Plug.

Can anyone else please verify that their Outdoor Plug is also stuck at the top, or moves to the top when they try to edit the Device order so we can have confirmation this is not an isolated incident?

2 Likes