Wyze fails to help with missing Cam Plus subscription

I purchased my second V3 camera bundled with an annual Cam Plus subscription on January 28th, received it, did the normal setup and it came up with the (what I assumed was normal) 14 day Cam Plus trial). When that ran out I expected to see my new annual subscription (would be my third) - but nothing new showed up in the Account/Services/Cam Plus section either on my phone or on the Wyze website for my account. So I created Wyze support ticket 1060336 asking for help with the missing subscription. I got one unhelpful response with directions to cancel my free trial - which I had already explained was over. My two replies for additional help on this ticket have gone unanswered and the new Cam Plus subscription I’ve paid for is still not showing up in my account.

Anyone encounter this annoying problem before and get help? Any recommendations what to do next? Create another ticket??

Phil

You and numerous other people including me, but I got mine resolved. Did you get an email from WYZE to redeem your new cam plus license? They usually arrive in about a week and give you a code to redeem it, activate it. There are about 10 other post on this forum dealing with the same subject. Just because you have 2 , 3 or four other cam plus cameras you still need to add the new one and activate.

Antonius - thanks for the helpful info on what should have happened. However, I cannot find any email from Wyze with a code to redeem my new subscription. I do have MANY emails asking me to sign up for another Cam Plus subscription, and warning me the the trial period is ending… sigh!

Phil

Same here, new V3 I bought in January with Cam+ still does not show on my account. I have another Cam+ from AUGUST 2020 that shows as the only sub I have. Wyze you owe me $15 or a Cam+ sub.

I was still getting emails that my 10-day trial had expired yet I was completely unable to activate/assign cam plus for a new additional (second) camera. This was even though I ordered and paid for cam plus days before expiration, I finally discovered that plus subscription HAD been activated after all… even though that fact did not show up on my page at all, which still showed that it was still not assigned to the new camera. But it was. Next day, it finally showed up as assigned – somehow, some way. I don’t know who thought up this CP process but they are masters at making a simple thing very complex…

I got a least 4 emails telling me I had 6 days,4 days 2 days left on the trial and one that said it expired even though my CP license was active and I had been using it during that time. As I told support it should be activated as soon as the camera is activated, it would save a lot of people both the customers and their staff a lot of grief.

Antonius - I agree with you on the immediate activation instead of the trial confusion.

Good news - I did find a subscription code buried in my Gmail Promotions tab, and was able to activate my subscription. For some reason the start date was put back to the start dates of my previous two subscriptions (last August)! And I received a credit email from Wyze for $8.24, which I assume is for the reduced “annual” length of time. Maybe that’s normal to have all annual subscriptions align…? And why the activation code email ended up buried in my Promotions tab when all the other Wyze emails telling me my Cam Plus trial was ending and it was time to subscribe came into my Primary email tab is a big mystery. Hopefully, I’ve fixed this for future emails from < no-reply@hello.wyze.com>.

Thanks everyone (except Wyze) for help on this -

Phil

Today I spent over an hour on Wyze Chat support trying to resolve my missing Cam Plus subscription. I told them that The code they sent me in an email did not work and says “you already have a subscription”…yes…I have one from AUGUST 2020…but NOT the new one from the V3 I bought in January. It was an hour of being jerked around and going in circles with support. I finally told the guy, Edison, that this is not worth anymore of my time for $15 and I was not going to be jerked around anymore. Wyze use to be good, but I have bought my LAST WYZE ANYTHING. Sounds like a lot of people are having the same issue with the “forced” to buy cam plus to get a V3…even though I was already a Cam Plus sub. Not worth it.