Wyze Cams and Asus Routers - connectivity issues resolved


#1

I recently purchased two Wyze cams (cam and pan). I was having connection issues outside my network in the Wyze app where it would get stuck on step 1 of connecting. I was able to connect successfully about 20% of the time.

The solution is to Disable “Airtime Fairness” on the 2.4GHz band on your router. It is located under Wireless > Professional tab. Reboot the router and now no connection issues.

Support does not mention this anywhere, and it took me a while to find this solution. It would be great if it was added to the Connectivity FAQ,


Can’t connect to cameras 90% of the time.
Can't remotely connect to live stream
#2

Thanks for posting that…very good info.

I think this setting is specific to this brand of router, or at least a smallish subset of routers, so I’m not sure putting it in the FAQ makes sense. But by posting this here, people searching the forum for Asus will find it and be helped greatly. Thanks!


#3

No problem. I really added it because I spoke to Wyze Tech Support the other day and mentioned I had a Asus router, but they all the suggested was the normal reboot everything. At least having them know that there is a default setting on Asus routers that directly influences Wyze cameras would be a good thing as I was 24 hours from returning them for a refund. My other IP cams (D-Link, Foscam, Amcrest) have no such issues with the router.


#4

@WyzeMars FYI - ASUS is quite popular router and we had issues with it too. This is quite a handy tip for our support.


#5

Thanks for bringing this to my attention! I’ll definitely pass this along to our team :slight_smile:


#6

Here’s the guide I wrote on how to disable “Airtime Fairness”: Asus Routers and “Airtime Fairness”

Thanks for bringing this up and providing a solution, @Max!! Super helpful :slight_smile:


#7

I have been having very similar issues with my two wyze cam’s. I would say about 80% of the time it fails to connect to the Wyze cam and I often don’t get all of the notifications on my phone from the wyze cam. I have a asus router as well so I’m eager to give this a shot and see if I fixes the issue.


#8

Wow Max thank you very much. That made a HUGE difference. Fairness is not fair at all!!!


#9

Good stuff. I’ve had exactly zero issues since I made the change, other than I spent more $$$ on more cameras!


#10

I bought and installed 2 Wyze cams a few days ago. I have an Asus router and haven’t had any problems. After seeing this thread I checked and airtime fairness is already disabled in my router.


#11

I actually just followed this guide to adjust my asus router. My one suggestion would be to make sure you tell users to select the 2.4 Ghz Band under general wireless settings, otherwise they may end up only turning off airtime fairness for the 5Ghz connection (which is selected by default in this case).


I’m really hopeful that making this change will help fix the notification issues I have been having with my two wyze cams.


#12

@djferens I’m so glad the guide was helpful! I’ll go ahead and add that note about the 2.4 Ghz Band to help prevent confusion in the future.
Thanks so much for the feedback!!

Edit: Article is now updated :mage:


#13

My D-Link cameras had that same issue with my Asus RT-AC68U router which I had previously pinpointed to the Airtime Fairness setting, so I was ready to go for these WyzeCams, hah.


#14

The problem is NOT with ‘Airtime Fairness’ (ATF) though. That feature is used on many routers, since more and more devices are being hooked up, and ATF is a way to handle many devices to all share bandwidth, instead of having the first device that connects hog everything, and slowing down everything else.

The real problem is the flawed drivers that don’t gracefully accept what ATF is doing. So, this is actually a bug in the way the cams operate with ATF.
Would be better to fix the drivers than to claim this is a solution.


#15

Our understanding is the ATF is better suited for public areas such as cafeteria. For home use, the user would need to be savvy enough about their specific network environment, Because “slow” device, which is penalized by ATF, could be older devices, but could also be the devices that are farther way from the router. So unless user knows exactly how “ATF” works, it may or may not benefit their network situation.
Additionally, many devices ( I’ve seen common complains with sonos, chromecast etc ) got confused by ATF and result in some kind of connection issues. If you know any good info on how IOT devices should work with ATF, we would be interested in reading them.


#16

It isn’t uncommon to have 10+ devices in houses, and with more and more devices being “smart connected” that number is only going to rise.
This is why a more robust protocol for handling ATF is needed now, rather than later.
You can also notice how performance degrades when different people are looking at different cam’s feeds, one person is fine, the other person gets the message to switch to 360p mode, and that shouldn’t happen with ATF enabled.

This is one of the better explanations I have come across.

Guys, think of Airtime fairness as a toggle to decide whether the amount of data, or the amount of time should be fair, among actively receiving clients.

w/ airtime fairness (ATF), each devices gets the same amount of time, so a faster client (better modulation) can get more data in it’s time, and a slower client gets less.

w/o, all devices get equal throughput. A fast device will get 2kb, then a slow client will get 2kb and back and forth.

If you usually have just 1 or 2 devices with good signal needing data, then turning ATF off can help maximize throughput because data is basically just send out the buffers in FIFO so it works pretty well. ATF on will only hurt a little bit here, so this is probably too specific a case for most people that have a couple phones, tablets, laptop etc.

I like ATF on because it makes wifi predictable. I know that my AP is handling 7 active devices, so I know that my high modulation devices get 1/7th of their modulation worst case. For instance, right now my MacBook Air is at 92% signal, modulating at 300Mbps. There are 7 devices. Worst case with ATF on is I’ll get ~43Mbps of that no matter what the other devices modulate at. 60% of that is ~26Mbps which is my ‘rule of thumb’ for actual throughput based on modulation. It’s not likely that all of these are active all the time so I’m likely getting higher throughput most of the time, but I have a higher confidence of good performance in the worst case scenario.

Without ATF, the device at 35% signal modulates at ~20Mbps. That’s only 7% of the 300Mbps client. If they get the same amount of data from the AP then the slow client needs 300:20 = 15:1 of the airtime! So that 300Mbps client’s performance can collapse down to just 20Mbps! If you hear people say that wifi can be limited to the slowest clients modulation, it’s short-hand for this ratio. It’s not precisely true, but it stands up in worse case scenarios. These worst-cases are actually pretty likely because software typically requests data as fast as possible, so a 20Mbps client connection (less 40% for wifi overhead) will get hammered when they try to pull a web-page down, or stream a song because it tries to pre-buffer it.

In a nutshell, enable Airtime fairness unless you have a specific use case like min-rssi set to force high modulation and you want devices to have first-come/first-serve type data flow.


#17

do you know details on what kind of protocol for ATF ?


#18

I found toggling ‘Airtime Fairness’ from “Enable” to “Disable” (whatever that means) is what worked. Not sure if I’ve disabled it or enabled it, but my Wyze Cam’s connectivity has improved a 1000%. Thanks for the heads up, even if the semantics are confusing…for me, at least.