Wyze Camera Integration with Alexa Routines Not Reliable

Over the past few months, I have noticed that Person detection is not triggering Alexa routines consistently.

Most recently, this morning, I reproduced it in response to Wyze support telling me the issue had been corrected (again)… which is not true. As you can see by the included image(s), I triggered the Person Detection 5 times but only 3 of them made it to Amazon and the Alexa routines:

combo

Steps to reproduce:

  1. Add the Wyze Skill to Alexa, using the Alexa app and link it to your Wyze account.
  2. Setup an Alexa routine to trigger upon Person detection for a camera on your account.
  3. Setup the Wyze app for Person detection notifications to compare to your Alexa routine triggers.
  4. Walk in front of the Wyze camera several times with at least 5 minutes apart so that you allow for the cool down period.
  5. Compare the Person detection results against the Alexa routine history in the respective apps.

In this example, there are 5 detections and the two that did not trigger Alexa routines.

7:26am
7:43am
8:05am (did not trigger Alexa routine)
8:18am (did not trigger Alexa routine)
8:38am

Clearly, the camera detects a person, sends that to Wyze, Wyze sends that down to the phone but only tells Amazon about it inconsistently.

Seems to me that the Wyze to Amazon server integration is flaky but I can’t seem to get traction after filing multiple tickets and submitting multiple logs. They just tell me make sure I have the latest firmware and app version and don’t even really understand this is a service integration problem.

Basically, I have a camera at my front door and I have it announce someone is there. Pretty simple scenario but unfortunately not reliable at this point.

I have unlinked/relinked the skill. Updated camera firmwares, etc. Most things you would expect to try and solve the problem on my end.

Anyone else use Person Detection and have it integrated with Alexa routines?

If anyone has this problem too or even a solution, I would love to hear back. If Wyze community support is listening, I can give you all the ticket and log ids if it will help this go somewhere. I wonder why I pay for person detection if does not work well with Alexa (my use case).

I want to love Wyze like I did when they just did cameras but they make it so hard at this point. Open to other camera solution that would work outside of Wyze if I can’t get this fixed.

Thanks in advance.

Interesting, I have 9 cams (4 diff models) all working and sending person detection to Alexa. It works fine and consistently. However, I do not have now (and never did have) a routine set up in the Alexa app to do this. It just works from the Alexa Wyze camera skill.

Inside the Alexa app if I pull up a camera device from Alexa Devices and click on the Settings Gear, there is a option that says “Person Detection Announcements” and if the slider is set to on, it works fine with no routine set up and no cool down period, It will repeat over and over every few seconds.

Perhaps disable your Alexa routines and try this method via the Wyze skill instead. FYI - This only works for Person detection, not packages or pets.

Also, please note that I often have to disable the Wyze skill and then reenable it following SW updates from Wyze and/or Alexa.

I have much worse luck getting Alexa to display live cam footage on my Alexa’s. It is hit or miss if it will show live feed in the Alexa App or on a video Alexa.

Thank you for replying. I actually tried this exact scenario this morning since I noticed that feature recently in the Alexa app and was hopeful. However, I still have consistency issues. I perform a test every 10 minutes I typically lose 1 out of every 4 person detections to the Alexa device. I am part of the Person Detection (Legacy) service (not CamPlus) if that makes any difference. As I said I get 100% detection in the Wyze app.

I am indeed a Cam+ subscriber now. I once was legacy, then during a Cam+ sale I cut legacy down to just one cam (just in case) - eventually I just went all in.

You could try a free Cam+ trial on one of your cams and see if it makes a difference.

Hey Seanwo,

Did you ever get it figured out? I now have 1 cam that simply refuses to do people detection alerts now (a v2 pan). Stopped working after an upgrade…

I have a ticket open with Wyze. The problem is with my Legacy Person Detection subscription. Everything works fine with my Wyze Cam Plus subscription. My Legacy Person Detection cameras lose about 25% of all Alexa routine triggering. Last night there was an AWS outage affecting all Alexa integration including Cam Plus but that is back to normal. https://support.wyze.com/hc/en-us/articles/360015979872-Service-Status-Known-Issues. Were you affected by that event?

I was affected by the AWS outage on a number of platforms. I just presumed that was the cause of many fails.

But I guess my issue isn’t the same as yours as all of mine are Cam+ at this point. May have to open a ticket myself. I have 1 cam that just won’t do Alexa alerts and it has been that way since before the outage.