Wyze camera constantly focusing


Anyone have a solution to this. My camera recently started constantly focusing in and out. I have reset it, powered it off and on, and deleted it and re-initiated it. Nothing seems to help. It does not do it at night tho.

1 Like

The V2 lense doesn’t have an auto focus, what looks to be going on if I am seeing what you are seeing is maybe the white balance trying to adjust to the combination of hard sun and shadows that dot your frame. Also maybe there is a video quality issue where the displayed video has a hiccup.

I noticed mine doing the same yesterday and today. I’m pretty sure @Omgitstony is correct as it seems to happen only when I see stark contrast between many small sunlit areas and dark shaded areas. It’s especially prevalent when there’s contrast combined with movement. I see the same thing happen under the same conditions with my non-Wyze cameras, both with fixed-focus and auto-focus lenses.

1 Like

That’s definitely an artifact from video compression, not focus. Each “refocus” you’re seeing is actually a keyframe. Video compression algorithms work by starting with a keyframe and then adjusting subsequent frames based on the original keyframe. So for a video that’s 24FPS, for example, you might only have one keyframe per second, and 23 minor adjustments based on that keyframe before it resets to a new keyframe. (It’s not necessarily one keyframe per second, but you get the general idea.)

Do you have the video quality setting as high as possible? Lower-quality video adjusts either the resolution (1080p vs 720p for example) or the compression algorithm, or both.

I will try and changing the quality to SD or 360p and see if it helps. It is on HD right now tho.

If it’s on HD now, SD or 360p will only make it worse.

My only other thought is that they MAY compress the 12-second cloud clips more than the videos saved on the SD card. I’m not sure about that, though.

I just checked mine, and it definitely does the same thing. ¯\_(ツ)_/¯ I never paid much attention to it. Like I said, it’s just a compression artifact.