Wyze cam V3 stuck on solid red light

Speaking of the devil… Things weren’t rosy at Wyze…
Wyze almost went bankrupt…

I have noticed that my replacement V3s have Firmware (which is not a firmware release that is downloadable on Wyze’s website).

I don’t think it would be of much help in our bricking situation but just in case … Are there any hackers who may be able to come up with an explanation as to how differs from downloadable firmwares?

Same issue, tried everything listed here. Now I can’t even create a Wyze Cam V3 support ticket, you can’t select any Wyze Cam in the chat bot menu at the last step (see pics)! Is there another way to create a ticket?
Screenshot 2021-09-19 234714|406x500

There are many ways to contact Wyze. Their phone number is (206) 339-9646, or you can chat with an agent or create a ticket on the support site.

They’re open for support between 4 am-8 pm PT Monday through Friday, and 8 am-4 pm PT Saturday.

1 Like

Ive lost count now of the cameras that needed replacement. One of the “replacement” cams Wyze sent me, (updated and ran OK) have now crashed. They’re replacing it, but now it seems like its a weekly occurrence. WTH?

Added another V3 to the paperweight stack.


I have effectively banned firmware updates on the V3 of their bricking problems. Yet lately the cams for some unknown reason proceeded with inviting me to upgrade firmware as I if I had not already check the box asking to never ask.

Ok but then has there been a new firmware released this week?

On another note… While looking on Home Depot’s website… That issue is slowly getting some momentum it appears. Wyze REALLY need to fix this!!!

It happened again today! Yet I did disable update notifications on all cams last time I posted here! Is there a newly released update?

If I am correct, the ROM chips is where the firmware is saved to. If we find the ROM chip, then theoretically, we can replace it and re-write a working firmware and it should work!
I took mine apart and I believed I found the ROM chip (cfeon qh128a),…


Good thinking!!

Next step is to actually read /hack into the flash…

That is definitely something for well versed hackers I believe since there is most likely a unique ID / checksum in there which would prevent the use of a generic binary.

You can add me to the list of people with a dead v3. I bought one about two weeks ago, liked it, and bought another a few days later.

I glanced at my app yesterday and noticed the slightly older one was offline. I peeked outside and it was stuck at the red light.

I’ve been messing with it all morning. Things I’ve tried:

  1. Re-flashing the current firmware using the manual (sdcard) method – stays at the red light.

  2. Downgrading the firmware to – this actually seemed semi productive. The camera boots up into setup mode (flashing red light) but I can’t actually set it up. When you hit the setup button on first startup, it’s supposed to verbally tell you “ready to connect” but in my case it doesn’t do anything at all. I’m still able to scan the QR code and the camera seems to accept it, but it never actually connects. It briefly goes to a flashing blue/red light and then eventually goes back to flashing red. I tried holding the setup button down to factory reset it. It accepts the command and restarts, but still no sound.

  3. Comparing the file sizes of the various firmware versions, the biggest one (KB wise) is from Feb. I opted to flash this one, thinking that it’d overwrite as much of the ROM as possible just in case it was a firmware update that messed it up. After flashing, it behaves the exact same way as above: flashing red light/refuses to connect to wireless network.

  4. Flashed the initial firmware ( Same as the prior two firmwares: stuck at flashing red light/refuses to connect to wireless network.

  5. Flashed latest production build again just as a sanity check: stuck at red light.

At this point I’m confident it is indeed a firmware problem, but I don’t know if it’s a firmware problem that can be fixed with a subsequent firmware update. I fear they may have pushed one out that simply resulted in hardware failure of some other component within the camera.

I do have one of those firmware flashers listed in the post above but I am not going to bother tearing apart my camera in the name of science since mine is under warranty (and within my stores return period).

Definitely get it replaced under warranty as fast as possible cause the replacement doesn’t come with its own warranty. The warranty for the original purchase is the one that prevails.

update killed my v3, tired going back to older firmware, got past the purple led and then stuck at red led
now hoping they will replace it

Downgrading the firmware to worked for me
so I got my camera back temporary, I don’t know if it will let me update to because it was the update that killed the camera

edit, getting a replacement, updating in app or by sd card bricked the cam again, only works for some weird reason

Your mileage may vary, but you could enroll in the beta program and upgrade to the beta firmware if you’re feeling frisky.

There’s also a beta firmware here that adds RTSP. It is probably broken in other ways but if it gets a previously dead camera booting up again it’s worth it.

In my particular case, the RTSP beta firmware didn’t work either. I ultimately packed up the reject v3 and exchanged it for another at my local retailer.

I went ahead and enrolled in the beta program on both of my cameras. Fingers crossed they don’t suffer the same fate as the departed camera.

I have 4 wyze 3 camera’s. One of my camera’s failed after couple of days when I updated it with the rtsp firmware posted on wyze site. Did everything as indicated in this forum but it didn’t work. I am from Canada so think I am out of luck even though the camera’s are only 5 months old. I bought these camera’s through us amazon.com site.

You are indeed out of lock. If you live close to the border signup at Kinek (https://www.kinek.com) to get you RMA replacement sent to that American address and then cross the border to retrieve the replacement in November (if you are fully vaxxed). Otherwise you can have it shipped from Kinek but that is likely going to be as expensive as the cam itself.

Received my replacement camera
First thing after setup if prompt me to update to

At this point no sd card and I didn’t change any settings and I let it update the firmware

Now it’s stuck on solid red again I can hear the camera clicking but that’s it now showing device is offline

Edit 1 tried manually going to the .18 or .19 firmware it gives solid red

Roll it to .280 it works

Tried updating from 280 to .18 it goes solid red again

Interesting. I had 3 replaced. All 3 were fine with the regular update process (through the camera app) i wonder if it might be a manufactured or lot issue with specific cameras produced at a certain time?