Wyze cam V3 stuck on solid red light

Wyze is sending a replacement.

I now have 9 v3 and 2 v2 cameras online. Only 1 of the v3’s locked up with the solid red light. When I finally officially contacted Wyze for a warranty claim, they processed it quickly and I received a replacement Cam in about a week. It works great and all my cams have since had further firmware updates without an issue. I would say that Wyze has treated me well.

1 Like

Looks like the forced updates have started!

Out of 5 V3 cams :
1- is the sole survivor of the original 5 which I have updated to the latest firmware 4.36.8.26 (because I figured I might as well since it already had an update done and likely its days were numbered).

1- has 4.36.1.12 which I find suspicious not only because it originally had 4.36.1.10 (which I NEVER updated) but also because that one cam went half offline all of a sudden (meaning it showed Offline on main screen & Google Nest hub but responsive if I still tap on it in Wyze app) AND this is not the latest available firmware version. I had to unplug it from power to make it work (at least on surface). Is that semi offline status caused by a problematic Wyze forced update?:thinking:. We will see how long it will take before it finally dies on me…

2- went from 4.36.1.10 to 4.36.8.15

1- went from 4.36.1.10 to 4.36.8.18

Did something go wrong? Did Wyze found the bricking bug (explaining why the latest firmware hasn’t been forcibly pushed on everyone of my v3 cams)? Or is it that the forced updates require prior updates to be done in a chronological order first? Otherwise I am curious as to what explains such discrepancies between all my cams.

One thing for sure I will certainly NOT update the latest replacement cams on my own. If they ever die it will be all on Wyze.

Hey, I’m new to the forum so apologies if this was already discussed or found (I actually didn’t read all the previous posts) but thought I should share my findings.

I ordered two v3 cams in December 2021 and set them up. All was great until I upgraded the firmware and they had the solid red light with what seemed to be a camera stuck in a boot loop. I managed to flash them back to their original state so they could connect back and be usable again at least. Then I tried to flash any newer minor or major version without any luck…

I thought to myself, oh well Wyze will fix it at some point. Then comes the force upgrades and my cams go back to that brick/bootloop state with the solid red light… Flash them back and they are upgraded again… (clearly forced)

Contact Wyze support and let’s start troublehsooting, they ask me to do the basic network troublehshooting etc… We follow up back and forth until I get two v3 replacements.

Few days later I receive my cameras! Yay! Go to upgrade them and same thing happens again… Solid Red Light with brick/bootloop.

Must be my wifi right? Ok let’s try to get one of my old cam that had the issue connected to my phone’s hotspot for upgrade to see. Once setup and connected the upgrade actually worked!! So what’s the issue with my wifi? Troubleshooting time!

I have 2 wifi networks so tried to connect my second old cam with issues to the other network to see if the upgrades work. To my great surprise they do!
I’m now comparing what is different between my two wifi networks.

I’ll skip all the troubleshooting I’ve done for everyone’s sake to tell you that I narrowed it down to my WIFI PASSWORD!? I tried to change the password for the working wifi and use the bad password and it immediately triggered the solid red light with the brick/bootloop when I tried to upgrade the cam… I did more testing to figure out which characters caused the issue but couldn’t exactly pinpoint it. The only thing I know is that the characters % and # are not in my other password but all other special characters were in my other password. Testing % and # separately didn’t trigger the brick while upgrading so I guess it’s maybe a combination of characters!? I’ve advised Wyze Support about it as well so they can further figure it out.

One other thing I’ve noticed is that I tried to setup one of the cams that was on the latest version 4.36.8.26 to join the wifi with the bad password and it would simply not join or scan the QR code… During the setup I would get “Ready to connect” and then when trying to scan the QR code the camera would simply end up rebooting at soon as it scans the code…

I ended up changing my wifi password as well as on all my connected devices to a new one. So far it’s been working great.

Here was my old password that seems to have caused the issue if anyone wants to do aome testing: Yoh@dUmNfH4QWKH^6ig@Iyd2vJH02vdNL%xPhoZS@c#2%SF$GU

Now maybe I’m wrong and it was coincidental but changing the password clearly did the trick for me. :slight_smile: Hope it can help others!

2 Likes

Wow!! Fantastic post right there and nicely detailed!

Perhaps that may indeed help a few. Unfortunately most in this thread can’t even successfully flash an old firmware at all without the camera going back to solid red after getting the purple light.

Hopefully your findings will put Wyze on the right path to find this annoying bricking bug.

Adding my name to the Red LED Of Death list on a Cam V3. I don’t have an easy way to access my 32 GB SD card to put on an older version update. I haven’t seen anyone actually say “where” to download the earlier update “from”. FYI, my WiFi password doesn’t have any special characters in it, just lower case and upper case letters and 2 numbers.

1 Like

If you are ever able to get access to the camera you can try version firmware 4.36.0.280 from :

It worked for like 2-3 people on this thread. The rest have now fancy door stoppers.

Hi JeffB, Thanks for your reply. What is the correct procedure for flashing the firmware to a lower version? I’ve accessed my SD card and have downloaded the version 4.36.0.280 you recommended. I unzipped it and removed the demo_ so it now is named “wcv3_4.36.0.280.bin” and placed it on the root of the SD card. I inserted the SD card, powered up and pressed the SETUP button for over 10 seconds, but unfortunately still get the RLOD. I added the demo_ back to the filename so it reads “demo_wcv3_4.36.0.280.bin”, executed the same as before, but no difference.

One note, I did NOT do a FORMAT of the SD card, so it still contains the folders and files of when it was a working camera (alarm, log, rebooting, record, System Volume Info, time_lapse, and the 3 original files on the root). Nothing new is being written to any of the files or folders. I can format the SD card if you think it’s necessary or would help.

BTW, I do have 3 working v3 cameras on 4.36.8.26 and 6 working v2 cameras on 4.9.8.860, all of which were upgraded normally as the push came through telling of an upgrade.

Please let me know if I’m doing the downgrade incorrectly or you have any other suggestions. Since I only have 1 out of 10 cameras with the problem, I’m not desperate (nor angry). Thanks!!!

Hi,
the instructions are freely available on google…

The unzipped file needs to be named demo_wcv3.bin

Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid purple (blue & red light turned on), then release the button and wait for the flashing to go its course (the cam will attempt to reboot as it did the first time you turned it on after acquiring it). If you end up with only a red light on the cam and nothing else for hours you know your cam is bricked.

Good luck.

Hi JeffB,
Looks like I’m the proud owner of a 2 oz baby brick. It turns purple (blue & red) for approx 10 seconds, then the blue light turns off and the red light stays solid for eternity. I can do it over and over, same results (I know…insanity) so it’s tanked.
I’ll keep an eye out to see if Wyze ever addresses the issue. Meanwhile, I’ll function with 9 cameras instead of 10.
Thanks for your help and patience JeffB.
dabassmann (Rick)

Welcome to our very select (and very undesirable) club. :man_shrugging:

Thanks for confirming then it must have been a coincidence for the wifi password but what made it brick then? Nothing on my wifi setup means it’s likely from a Wyze server distributing a rogue upgrade image possibly?
I had set up a packet capture at first but it the upgrades were working. I did noticed it was connecting to weird domains too. I didn’t capture a failed upgrade though. Might be worth trying to compare. I still have the successful capture if needed.
At least my wifi password is changed now :slight_smile:

I read a little on the thread and what I’ve noticed was that for me only a specific old version worked for flashing so maybe if you have the time I would try them all starting with the latest until one hopefully works for you. In my case it was 4.36.1.4 I was using to flash back and it was working on the 4 cams (including the new ones received that were running at 4.36.1.12).

Hope this helps let us know.

I’m adding my name to V3 Solid Red Light Club. I think it occurred updating to the 4.36.8.32 firmware. My other camera’s all upgraded fine, but not this one. It’s with the warranty period but I can’t open a return ticket, contact via chat or find an email address that their system keeps kicking me back to the “EMAIL US” screen with no email address to be found anywhere! Hopefully there will be a time/date post indicating I was still in warranty when I tried to get hold of them.

Hi Ronnybone and welcome to the Forum. If you’d like to try to fix that 1 camera, I’m passing on JeffB’s suggestion and Link " How to flash your Wyze Cam firmware manually" and try to put version wcv3_4.36.0.280 and see if it will unbrick it. It didn’t help mine, but it has helped a couple of others (see thread above). Good Luck!
DaBassMann

Short Version: Yay, all is good now!

Long Version:
Thanks DaBassMann for the reply and suggestion. Coincidently, I received a support ticket from Wyze which also suggested the manual flash; however, they didn’t direct me to a specific version. They also provided two other solid red light troubleshooting suggestions related to the power cord…see below).

Below is a more detailed version of what I did in “Step 2” of the “Flash Firmware for Wyze Cam v3” from the link you (and Wyze) sent me, and then explain why I did what I did.

I downloaded 4.36.8.32 (March 17, 2022). In my case, this was the version it was trying to update to. The Zipped (and extracted) folder name appeared as “demo_wcv3_4.36.8.32” (Win8.1 computer…ya ya, I know). The “bin” file that extracted out was already named “demo_wcv3.bin” so despite what the instructions say in Step 2, I didn’t have to rename anything (maybe that’s a Win8.1 thing?). I copied the demo_wcv3.bin file onto a freshly formatted (empty) microSD card. Then I followed steps 3-5 (no issues, does exactly what is written).

Step 6. I had to re-setup the camera because the robot troubleshooting tree on their website has you delete the camera from the app. When powering down the camera, I took out the microSD card and removed the bin file, then put the card back in and re-setup the camera. All is good now.

The firmware version you mention wcv3_4.36.0.280 (March 29, 2021) wasn’t available for download. Also, the industry I’m in, we only flash with newer versions that can’t go backward so it was pretty natural for me to flash the latest 4.36.8.32 which is what it was suppose to update to before it crapped out.

For what it’s worth, the other 2 steps Wyze support suggested was using a different power cord (ideally, a known good one) if flashing from the app. I marked my cord incase this camera gets the red LED of death again. They state to contact them with order info etc (I assume they’ll send a new cord), if not I have several I can try.

Thanks again DaBassMann.
Good Luck everyone.
Ron

Hi Ron,
That’s awesome! Your success has inspired me to fiddle with mine again, but instead of going backwards, let’s see what the current one can do. I also liked that you removed the BIN file in Step 6. Food for thought if you will. I’ll let you know the outcome.

Thanks for all the details, Ron
Wish me luck
Rick

Well, if it looks like a brick, walks like a brick, quacks like a brick…
Oh well, I had nothing better to do on a Thursday morning.
Glad you got yours running again, Ron.
DaBassMann (Rick)

Oh man I’m gutted for you. At least I was able to give you another attempt at it. I assume yours is out of warranty? I have only good things to say about their customer service and resolution…even if it is out of warranty, point out you have 9 other camera’s of theirs and hope for some goodwill on their part. I was just irritated yesterday when no chat or email address (support@wyze.com) could be found on their website. I found an old email and contacted them that way and they’ve been in touch ever since…in fact I just told them to close my ticket…after verifying the camera was still working!
Thanks for contacting me to try the manual flash. It’s good to know there are some good people in the forum!
Ron

Oh yeah, out of warranty, LOL. I probably got all of my V2’s back in 2017 or 18, then the 4 V3’s in 2019 or 20.
There are a lot of good folks here in the Forum, I’ll not comment on the group over in Facebook. I just picked up where JeffB left off with me. I’m not sure who coined the phrase Red Light of Death (RLOD) but it stuck.
I’m doing fine with only 9 Cam’s…and it’s not like these things are crazy expensive. I just want to see Wyze come up with a fix before I buy any more, at least for the time being. Wyze is in a bit of growing pains right now, where they bit off a little more than they can chew too quickly. It will be interesting to watch as the dust settles.
I’ll be around,
Cheers!
Rick

Here we go again. Another cam bites the dust and went all out red light of death and I am out of warranty. Thanks Wyze.

1 Like