Wyze cam V3 stuck on solid red light

Correct 32gb, Fat32 and make sure to name the bin file “demo_wcv3.bin” and you will get the purple led (red and blue leds turned on)… but your cam will still remain bricked after manually flashing.

1 Like

I wished that my 4 cams could be brought back from RLOD by simply manually flashing them! All they do is go back to solid red after staying purple for a few seconds when manually flashing.

1 Like

I myself have 4 bricked cams after the last 2 firmware updates. I will not be updating the replacements until this issue gets resolved. Also these are for my main entrances, therefore I think it’s time to move to a different brand for those positions. Support has processed the replacements. When I get them i will place them elsewhere.

I think the problem you are having are different from issue many of us are having. Once the firmware update fails for us, that’s it, no way to bring them back.

I have the same issue with both of my Wyze Cam V3s. They were on firmware version and suddenly just appeared offline in the app with a solid red light. Flashing just resulted in the light being temporarily purple before turning solid red again. I tried to flash several different firmware versions. They failed within a week of each other.

I chatted with Wyze and they replaced the first one. I am waiting to hear back about the second. They were both purchased on the same day in May.

I think it is quite obvious by now that Wyze has a serious problem with the v3. I guess we are still somewhat the batch of initial buyers as the initial firmware is dated of November 15, 2020 (about 10 months ago).

1 Like

Just want to add my name to the list of people having this issue…

I tried to manualy flash the firmware with a 8gb microSD but the purple led goes back to red same as other mentioned.

This is pathetic… but hey wyze !!! lets release more vacuum and sprinkler YAY!!! we didn’t ask for it… we are just asking for stable devices. Sorry for those that want sprinkler but I jumped on wyze because of camera, motion etc… now i’m starting to move slowly away from wyze too many product and no stability. just my 2 cent. Sorry for those that are exited for sprinkler and vacuum.

I’m expecting my second V3 to become bricked. perhaps I should unplugged just in case.


At this point, don’t do any updates on the V3’s. I agree with you, they just buying all sorts of crap from Alibaba and renaming it. They been silent on this issue with V3’s, so it’s either not widespread and they rather replace cameras or could be hardware issue and not fixable by firmware. There’s no way any company would just ignore issue like this and let it ride. Seems like all the effort these days is with Cam+, that’s where money is. Classic example of a decent company going wrong path


Personally I am already making arrangements for when my 5 cams will die on me which I guess will be by spring 2022 (that is if my own bricking timeline is representative of how long they will remain functional). At this point I would not be surprised if Canada’s winter kill them anyway. To say that I have lost basically all confidence in the brand is an euphemism.

Annoying to be the preacher of good news telling everyone around me to buy only to turn around and take back my words and advise against. :unamused:

1 Like

I think there is no saving for the batch we have received and only a hardware revision will resolve this. So I guess enjoy your last cam v3 while it lasts

Sure looks like Wyze is not really confident in what it sales… So yeah… Enjoy while your cams last. I have just received 3 replacement that I will never update… We will see how they hold up.


When I received my replacement and I tried updating them, they bricked in the same way the first round did. They did ship me replacements for the second time. This was back in June and I haven’t tried to update since even though the app continually asked me to. Would like to but I would also like to see Wyze address this issue.

1 Like

The second time you update the replacement, did you have a MicroSD 128gb card inside?
It seems that could cause the issue. I had a card in my v3 (128gb) and it bricked the cam after the update and my friend who got the update didn’t have card and didn’t have issue.

I also don’t really have fate in wyze for resolving this issue and notifying all their customer because from previous issue with their product they just don’t talk about it.

ex: dead battery sensor issue → Thread

Instead they just replace the product if you fit in their warranty policy.

I’m from canada and I always been a first buyer to support them and yes I did take the risk of buying their product from amazon but at the time I didn’t know wyze was not covering warranty if we buy from amazon so I figured I was going to wait until they sale in canada and it took them over 2 years to find a reseller Petstore and lately HomeDepot but the damaged was already done so I won’t buy more of their product.

I feel complaining here is a waste of time because it’s not public enough… we should send a message on their reddit page, facebook and twitter perhaps this will catch their attention.
This forum seems to be just between customer and moderator.

I already started to spread the word on youtube reviews. People need to be aware that the v3s are time bombs.


Actually, I had a 32 GB card I bought specifically to test with. Still failed.


Well then I think that settles the question about the 128gb SD being the cause of brickings.

Cam v3 are straight up time bomb. Hope that it bricks within your 1 year warranty otherwise you are screwed.

Sucks though for us early adopters. Cause we are paying for R&D for those that will get reliable cam v3s.

1 Like

Same issue happened to me, I had a 32GB sd card in :frowning:

1 Like

Ditto here. 2 out of 7 V3 cams bricked. Cannot flash, reset button unresponsive. Support replaced, you have to really have patience with Wyze support. 30+ minutes per call.

1 Like

Has anyone ever been able to flash a V3 cam with the .BIN file and a Micro SD card?
Ive tried several times with the 3 (now) bad V3 cameras, I get a purple light for a minute or so, then solid red that never goes away. Reset button inoperative.


I had no luck. Have the same problem with 4 V3s


as far as i know, Nope no one has revived the dead cameras.
Get in touch in Wyze and start exchanging them. Don’t be surprised if you end up replacing all of them.