Wyze cam V3 stuck on solid red light

Downgrading the firmware to 4.36.0.280 worked for me

edit: its not a solution, its a temporary fix since you can’t update from this version without bricking the cam again

My oldest cam that never required replacement is running the latest firmware. My other 4 are stock. If you are in the USA then I guess why not considering that you can get a replacement shipped. I wouldn’t suggest the same for my fellow Canadians unless they are willing to deal with the hassle of RMA done on the other side of the border.

Looks like staying with old firmware no longer option, just got email from Wyze app’s and firmware needs too be up to date, or they will force the updates, for our safety :slight_smile:

:face_with_symbols_over_mouth: way to go and potentially cause “programmed obsolescence” by potentially bricking cams!!! And to make matters worst right at the end of my one year warranty!! :rage:

Email sent.

They better make sure their firmware is thight cause I will be hella pissed!

I have not yet received that email what does it say?

@NYC
A copy of the email is posted here

I asked for a replacement of my replacement cam (the one they replaced had the same issue), hopefully it will let me go beyond 4.36.0.280 with this new one

Wyze is sending a replacement.

I now have 9 v3 and 2 v2 cameras online. Only 1 of the v3’s locked up with the solid red light. When I finally officially contacted Wyze for a warranty claim, they processed it quickly and I received a replacement Cam in about a week. It works great and all my cams have since had further firmware updates without an issue. I would say that Wyze has treated me well.

1 Like

Looks like the forced updates have started!

Out of 5 V3 cams :
1- is the sole survivor of the original 5 which I have updated to the latest firmware 4.36.8.26 (because I figured I might as well since it already had an update done and likely its days were numbered).

1- has 4.36.1.12 which I find suspicious not only because it originally had 4.36.1.10 (which I NEVER updated) but also because that one cam went half offline all of a sudden (meaning it showed Offline on main screen & Google Nest hub but responsive if I still tap on it in Wyze app) AND this is not the latest available firmware version. I had to unplug it from power to make it work (at least on surface). Is that semi offline status caused by a problematic Wyze forced update?:thinking:. We will see how long it will take before it finally dies on me…

2- went from 4.36.1.10 to 4.36.8.15

1- went from 4.36.1.10 to 4.36.8.18

Did something go wrong? Did Wyze found the bricking bug (explaining why the latest firmware hasn’t been forcibly pushed on everyone of my v3 cams)? Or is it that the forced updates require prior updates to be done in a chronological order first? Otherwise I am curious as to what explains such discrepancies between all my cams.

One thing for sure I will certainly NOT update the latest replacement cams on my own. If they ever die it will be all on Wyze.

Hey, I’m new to the forum so apologies if this was already discussed or found (I actually didn’t read all the previous posts) but thought I should share my findings.

I ordered two v3 cams in December 2021 and set them up. All was great until I upgraded the firmware and they had the solid red light with what seemed to be a camera stuck in a boot loop. I managed to flash them back to their original state so they could connect back and be usable again at least. Then I tried to flash any newer minor or major version without any luck…

I thought to myself, oh well Wyze will fix it at some point. Then comes the force upgrades and my cams go back to that brick/bootloop state with the solid red light… Flash them back and they are upgraded again… (clearly forced)

Contact Wyze support and let’s start troublehsooting, they ask me to do the basic network troublehshooting etc… We follow up back and forth until I get two v3 replacements.

Few days later I receive my cameras! Yay! Go to upgrade them and same thing happens again… Solid Red Light with brick/bootloop.

Must be my wifi right? Ok let’s try to get one of my old cam that had the issue connected to my phone’s hotspot for upgrade to see. Once setup and connected the upgrade actually worked!! So what’s the issue with my wifi? Troubleshooting time!

I have 2 wifi networks so tried to connect my second old cam with issues to the other network to see if the upgrades work. To my great surprise they do!
I’m now comparing what is different between my two wifi networks.

I’ll skip all the troubleshooting I’ve done for everyone’s sake to tell you that I narrowed it down to my WIFI PASSWORD!? I tried to change the password for the working wifi and use the bad password and it immediately triggered the solid red light with the brick/bootloop when I tried to upgrade the cam… I did more testing to figure out which characters caused the issue but couldn’t exactly pinpoint it. The only thing I know is that the characters % and # are not in my other password but all other special characters were in my other password. Testing % and # separately didn’t trigger the brick while upgrading so I guess it’s maybe a combination of characters!? I’ve advised Wyze Support about it as well so they can further figure it out.

One other thing I’ve noticed is that I tried to setup one of the cams that was on the latest version 4.36.8.26 to join the wifi with the bad password and it would simply not join or scan the QR code… During the setup I would get “Ready to connect” and then when trying to scan the QR code the camera would simply end up rebooting at soon as it scans the code…

I ended up changing my wifi password as well as on all my connected devices to a new one. So far it’s been working great.

Here was my old password that seems to have caused the issue if anyone wants to do aome testing: Yoh@dUmNfH4QWKH^6ig@Iyd2vJH02vdNL%xPhoZS@c#2%SF$GU

Now maybe I’m wrong and it was coincidental but changing the password clearly did the trick for me. :slight_smile: Hope it can help others!

1 Like

Wow!! Fantastic post right there and nicely detailed!

Perhaps that may indeed help a few. Unfortunately most in this thread can’t even successfully flash an old firmware at all without the camera going back to solid red after getting the purple light.

Hopefully your findings will put Wyze on the right path to find this annoying bricking bug.

Adding my name to the Red LED Of Death list on a Cam V3. I don’t have an easy way to access my 32 GB SD card to put on an older version update. I haven’t seen anyone actually say “where” to download the earlier update “from”. FYI, my WiFi password doesn’t have any special characters in it, just lower case and upper case letters and 2 numbers.

1 Like

If you are ever able to get access to the camera you can try version firmware 4.36.0.280 from :

It worked for like 2-3 people on this thread. The rest have now fancy door stoppers.

Hi JeffB, Thanks for your reply. What is the correct procedure for flashing the firmware to a lower version? I’ve accessed my SD card and have downloaded the version 4.36.0.280 you recommended. I unzipped it and removed the demo_ so it now is named “wcv3_4.36.0.280.bin” and placed it on the root of the SD card. I inserted the SD card, powered up and pressed the SETUP button for over 10 seconds, but unfortunately still get the RLOD. I added the demo_ back to the filename so it reads “demo_wcv3_4.36.0.280.bin”, executed the same as before, but no difference.

One note, I did NOT do a FORMAT of the SD card, so it still contains the folders and files of when it was a working camera (alarm, log, rebooting, record, System Volume Info, time_lapse, and the 3 original files on the root). Nothing new is being written to any of the files or folders. I can format the SD card if you think it’s necessary or would help.

BTW, I do have 3 working v3 cameras on 4.36.8.26 and 6 working v2 cameras on 4.9.8.860, all of which were upgraded normally as the push came through telling of an upgrade.

Please let me know if I’m doing the downgrade incorrectly or you have any other suggestions. Since I only have 1 out of 10 cameras with the problem, I’m not desperate (nor angry). Thanks!!!

Hi,
the instructions are freely available on google…

The unzipped file needs to be named demo_wcv3.bin

Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid purple (blue & red light turned on), then release the button and wait for the flashing to go its course (the cam will attempt to reboot as it did the first time you turned it on after acquiring it). If you end up with only a red light on the cam and nothing else for hours you know your cam is bricked.

Good luck.

Hi JeffB,
Looks like I’m the proud owner of a 2 oz baby brick. It turns purple (blue & red) for approx 10 seconds, then the blue light turns off and the red light stays solid for eternity. I can do it over and over, same results (I know…insanity) so it’s tanked.
I’ll keep an eye out to see if Wyze ever addresses the issue. Meanwhile, I’ll function with 9 cameras instead of 10.
Thanks for your help and patience JeffB.
dabassmann (Rick)

Welcome to our very select (and very undesirable) club. :man_shrugging:

Thanks for confirming then it must have been a coincidence for the wifi password but what made it brick then? Nothing on my wifi setup means it’s likely from a Wyze server distributing a rogue upgrade image possibly?
I had set up a packet capture at first but it the upgrades were working. I did noticed it was connecting to weird domains too. I didn’t capture a failed upgrade though. Might be worth trying to compare. I still have the successful capture if needed.
At least my wifi password is changed now :slight_smile:

I read a little on the thread and what I’ve noticed was that for me only a specific old version worked for flashing so maybe if you have the time I would try them all starting with the latest until one hopefully works for you. In my case it was 4.36.1.4 I was using to flash back and it was working on the 4 cams (including the new ones received that were running at 4.36.1.12).

Hope this helps let us know.

I’m adding my name to V3 Solid Red Light Club. I think it occurred updating to the 4.36.8.32 firmware. My other camera’s all upgraded fine, but not this one. It’s with the warranty period but I can’t open a return ticket, contact via chat or find an email address that their system keeps kicking me back to the “EMAIL US” screen with no email address to be found anywhere! Hopefully there will be a time/date post indicating I was still in warranty when I tried to get hold of them.