Wyze Cam V3 keeps disconnecting (with error code 90)

This is the same exact issue many others have been reporting.
Within the last few weeks my Wyze cam V3 has started disconnecting from my wifi and will not reconnect unless I go through the entire “add device” process each time. I can’t have this happen while I am at work. It has been working fine since I purchased the cam until these last few weeks.
The Cam V3 was sitting right next to my router but when it started having issues I moved it about 8ft for a better view of my front door, it still disconnects all the time.
I do not use an SD card and I have the latest firmware update in the app.
After it disconnects the light either blinks blue or red and blue (currently red and blue).

1 Like

Sounds like a component failure, replace the camera should be under warranty

1 Like

Sorry for the trouble. Could you PM me the MAC of that V3? Thanks

I have a mix of battery and power V3 cameras.
It appears that the V3 cam electric-powered Cams has the error.
Had to do a complete Add Device to correct. The camera Restart did not work.
Disconnecting the power cord for several minutes did not work as well.
This error needs to be corrected without a complete Add Device.

I’m having the same issue. Suddenly stopped working (V3) and will not find local network connection. Tried restarting V3, app, router, wifi.

But will not reconnect even by deleting the device and adding it back.

Sorry for the trouble. Could you send me the MAC of that V3. Thanks

Same here. I’ve reset it and rejoined my network after unplugging and plugging back in, closed the app, re-opened it, all to no avail. My home network says it’s connected, but the app says it isn’t and there’s no live feed. Same error code 90. Firmware is latest version.

It seems to have failed. How do I get it replaced?

The MAC is 7C:78:82:3f:23:01. It’s not that clear so I can send a photo of it if that helps.

1 Like

You can try to update the firmware to the latest version and test it again. Thanks

Same here, I had connection for maybe 5 minutes, then disappeared. Unit WILLNOT recognize WIFI…tried the usual uninstall, etc. reboot, reinstall app. …all no good. This is a major problem with this Camera V3, Next move…MAC address…hard to read looks rubbed off…here’s the best I can read.

7C78B23AA925 Gimme some guidance…would update firmware work? How can I do that if it cant connect to wifi.?

I can’t install firmware because I deleted the camera off of my Wyze app. And when I looked onto my internet provider app, it thinks that Wyze is online. but the camera does not feel the same way.

1 Like

Power off (or unplug) your router for a few minutes to release Wyze cam resources, then power your router back up and verify that you have an internet connection before trying to reset/re-add your cam.

1 Like