Wyze Cam v3 firmware versions and and Wyze Buds Pro firmware Released - 8/26/21

Anyone had success with the latest update. I tried it on one V3 now it’s stuck on red light like the previous update did my previous V3s before these replacements.

I installed both updates yesterday without any issues on my one V3.

I just upgraded 8 V3s. One struggled to come up and stay online after the update pair was applied, but a power cycle made it normal again. The others had no issues.

My Experience: I have a small 1500 sq ft ranch with cameras indoors & outdoors. I have a solid, reliable, modern router. I always upgrade one at a time, and always stay on the individual upgrade page until it confirms. Those steps shouldn’t be necessary, but that’s where my experience lies. I have many, many devices, have never bricked any, and have been around for over 3 years. But I’m probably so cautious with the steps because I read about other people’s struggles.

I have had issues, just no bricks. A few in those 3 years hung and failed to report completion, but when I went back into the device later I found it had updated. Nothing like that today tho. And then there are the watches. But still no bricks.

A lot of my incidents were using Beta updates that I strongly recommend most people steer clear of. Only if you are interested in finding and calmly reporting bugs should you be using Beta updates! Don’t load them if all you are interested in are new features. They aren’t ready yet. But don’t worry; the updates in this article a normal production updates.

I also upgraded 3 V2s to without any issue. And my Wyze Pro Buds.



I updated three out of 5 V3 cams yesterday up to one at a time the 4th one out in the pole barn with a kind of weak signal failed, but is working just fine , I often have to take extra steps with that one because of the weak signal

1 Like

I believe that is the key “a solid, reliable, modern router”

The junk that most internet providers so nicely let you borrow is from the lowest bidder. The modem and router they supply are only designed for the bare minimum. When smart devices, cameras, etc are added, the hardware can’t handle it.

We used to have internet outages and slow speeds. On the advice of someone fluent in IT, the Charter crap went back and a Tenda AC23 router and Netgear CM600 cable modem went in. Have had a rock solid network since. Hubitat, Wyze, 3 IPads (only WiFi), and a myriad of other WIFI devices all perform as expected.


I have never used the cable companies crappy equipment.
My advice, if you need to upgrade your modem and especially your router , dig deep in the pockets and don’t skimp get the best you can afford, and for God sakes never put your router in the basement

1 Like

Yes, you can get much better equipment and pay it off fairly quickly when you stop paying monthly rental charges. :slight_smile:


These V3s are on the same floor with the router. I use a TP- link Archer A9 for my smart devices. All cams reports good connections even the V2s. This I find strange. I submitted the logs and support told me to try the manual flash, which I will try tomorrow. The last set wasn’t responding with the manual flash. I hope I have success with this firmware and these set. Wish me luck

Looks like you are having troubles, so yeah, good luck

Correction. The spotlight is staying on, the app says no spotlight is installed.

I am going to wait to update, staying away from home for awhile. Will observe others results before updating to latest firmware.


I update all three of my v3 cams without any issues what so ever. Did all three at the same time. Waited for them all to get to .18, then updated them all to .19. There was one of the three that took MUCH longer than the other two. I just let it do its thing and did not navigate away from the WYZE update page on my Android phone.

Last weekend I disabled “green” mode on my wireless access point. Since doing so, I haven’t had any connectivity issues with my two v2s nor my three v3s (two mounted outdoors).

1 Like

I tried. Still no success. Waiting to hear back from support.

Update on my previous post.
Ever since I installed the V3 camera in the pole barn that I mentioned above I’ve had no problem with it going offline,
I have also been able to update the firmware on this camera with some issues but without bringing it inside until this one,
I had to bring it inside the house to get it to update properly.
Since I updated the firmware on this camera to this firmware version this camera has been offline, not recording any events and live view is also unavailable.
The V2 camera I previously had out there never had these types of issues

1 Like

Check to see if you’re getting a solid red light. Thats been happening for the last 2 firmware come forward. I can’t seem to pinpoint a reason and you can’t resolve it either

Now that I have returned home I updated 2 of the 14 V3’s I have, so far they are working.

Those 2 are ones I have not decided where to setup outside yet, the other 12 outside V3’s I depend on so no update yet, the 2 V3’s I updated are a test to see if I have problems like others are discussing.

The best way to update in my opinion, update 1 or 2 non-essential and see how it goes, when you know all is well then update the rest

1 Like

After updating my Cam 3 cameras to, I now have two Firmware Version entries in Device Info. One is for and when you click on it, it says Everything’s Good. The second firmware entry is blank and does nothing when you click on it. Initially, when trying to update the cameras to firmware, the update appeared to fail but was installed on a second try.

1 Like

Thank you for reporting. It looks like the template area for the v2 cam bridge firmware info was accidentally enabled for v3 cams. Wyze is aware of this issue.

v3 cam Device Info page:

v2 cam Device Info page:

1 Like

2 out of 7 V3 cameras failed the update 4.36.19. I update them as they send out he updates. The iOS app shows the update wheel spinning, then stops. Ive tried resetting back to factory, tried “flashing” the camera with the .BIN file on a micro SD card, I get a purple light, then it turns red and stays red. No matter what steps I try, I cannot use the 2 cameras. I called about one of them (at a remote location) and explained my steps, and was told they would replace the camera, they did. That camera updated and works. When I got to my other location, did another update to the same type V3, same results. Cannot flash, or reset. Wyze seems to know there is an issue, because they just offer a replacement right away. I don’t see how they can continue to keep just replacing cameras that will not update. Are they making that big of a profit on these devices?