Wyze Cam software issues

wyze-cam

#1

Wyze team,

I love my wyze cameras for several reasons including the form factor, hardware, cool positioning legs, ability to hang by magnet, etc. I have multiple of the cameras installed however there are few things that are driving me nuts and pushing me towards replacing the cameras. These are mostly software fixes and as a long time developer, I know some of these shouldn’t be terribly hard to fix.

  1. Inconsistent handling of 30 min offset time zones in video playback. Seriously this is sloppy time offset handling and needs to be fixed(every time based app deals with this). The end result is that the timeline slider and the camera playback use different times. As a result, when the timeline shows recording in green, the video playback has no video to show and when the timeline shows no recording, moving to that spot on timeline plays back video with a 30 min offset. This is super frustrating and makes it nearly impossible to track motion.

  2. Navigating between motion events in the timeline is super hard to do, especially going from one motion event to start of next one. With the above issue(#1), you have no idea where the next motion event is since the timeline highlighting is incorrect.

  3. Having the app open on devices page should auto-refresh the static image on every camera every 3 or 5 seconds. With multiple cameras this is needed rather than clicking into each camera and waiting for connection repeatedly.

  4. Need to Speed up connecting and authenticating with cameras(in fact pre-auth the cameras when app is opened) - currently it’s annoying to wait 2-5 seconds each time you click to view live video, even over fast internet (both at camera and app).

  5. Navigating from one camera live view to next camera should be a left / right swipe rather than going back to devices list then clicking on next camera and waiting for connection, auth. Just make this simple.

Fixing these issues, in just the app (vs the device firmware) would go a long way in improving usability of these otherwise terrific cameras. App usability for core daily usage scenarios(checking live cameras quickly, navigating alerts, navigating motion on timeline) is where dev focus is strongly needed. Please, please fix these soon.

I’ve seen some of these issues reported in other threads, but wanted to collect my thoughts in one place.

 


#2

I have wondered why I get the message “no video to show” on my timeline. I have my SD card set for events only. Makes it much easier for me look at an extended view of an alert. I usually just give up looking on the timeline.

I also like your suggestion on the left / right swipe. I have 20 cameras between two different locations. I am having to open each one individually. Often I just look at the alert, but I have found that sometimes there is nothing in the alert that indicates an motion has occurred. It is those times that I go to my time line to hopefully see what might have caused the alert.

 

 


#3
  1. Not sure I understand. Are you in a timezone that's offset by 30 minutes from the majority of world time zones?
  2. On the timeline, you can use a pinch-out gesture to expand the time scale, making it much easier to zoom in on a specific time once you're in the ballpark.
  3. I've added your suggestion for auto refresh of the static thumbnails to Wyze's feature request tracker.
  4. I've passed this request along as well.
  5. I've added your vote for this feature to the tracker as well.

#4

Thank you RickO for your response - let me clarify further below. Sisty2 I’m also using motion alerts only to save to SD card and have the same issue.

  1. I'm in India where the offset is GMT/UST +5.30 Image from the windows clock below, several other countries have offsets of 30 and even 15 mins.Timezones list
2. I'm familiar with the pinch and zoom for granularity, however the handling of the time in the video playback and the green highlighting on timeline are inconsistent hence always wrong for the issue above. Where there is highlighting, there is no video and vice versa. This is for all my cameras, all the time. Let me try to demonstrate that with pictures below :

Thanks for passing along the feedback for the other issues. Great to see that several other improvements have been coming and I can’t wait for these to be addressed.


#5

@karanvsb… I’m not sure that the 1/2 hour time zone was considered in the development of Wyze Cam since they are not intended to be sold overseas. Therefore, it doesn’t really surprise me that there may be issues associated with that. I would suggest submitting a support ticket describing the issue and see what their response is.


#6

Not in the CONUS, but in Canada the province of Newfoundland has a +30 minute offset from Atlantic Time:

https://www.timeanddate.com/time/zones/adt

https://www.timeanddate.com/time/zones/ndt

 

I agree, time zones and offsets should be trivial to calculate in software. I’m surprised the Wyze app doesn’t support it unless it’s using its own time handling library.


#7

@karanvsb… An update: I have confirmed with Wyze that 30 minute offset time zones are not currently supported. They are aware of the problems this creates on the timeline. However, Wyze Cams are not sold internationally at this time and therefore addressing this issue is a low development priority for now. Sorry that’s not better news.


#8

Thanks Rick for the followup. I hear you, however a time offset handling is a simple (possibly trivial fix) in software today(am an engineer myself) and will really help out all those who are affected.

Alternatively if the app allowed me to set time on the camera manually - that may also help address the issue.

Is there a way to help get this addressed now, vs later. I’m assuming Wyze will go to Canada and be available world wide sometime soon. Its can’t be a hard fix.

Thanks for looking into this!


#9

I think the eventual solution will be to set the timezone in firmware and have the camera ping a time server itself. That development, as I’m sure you realize, is a bit more than trivial. Not that it’s super difficult, but there’s a long, long list of software/firmware mods and improvements in the pipeline ahead of it. Since Wyze doesn’t (at this time) sell or support the cameras outside the US, this just isn’t going to have a very high priority (yet).

I’ve done all I can already by passing this along to Wyze. I am not privy to Wyze’s international expansion plans, but I suspect there’s nothing happening in the very near term. The only other suggestion I can make is to file a support ticket on this to try to give it a bit more visibility.


#10

Thanks Rick for your help.

Have opened a couple support tickets in the last month regarding time handling issue already.

i hope they do fix this.

thanks