Wyze cam outdoor wont turn on after charging

after charging 1st time cam will not turn on

Welcome to the Wyze community @billycassels!
Does the red light come on, then flash when the camera is charging? If not, what cable and power supply are you using to charge it?
Make sure the switch on the back of the camera is set to the “on” position.

1 Like

Yes it does blink then solid after full charge

Mine just did the same thing but after successfully charging it few times before. However I should mention that this time it took far less time for the red light to stop blinking when I was charging it! Also, I noticed that when it was running, the charge percentage went from 41% to zero in few hours before I removed it and charged it. My other three WCO are doing fine. Is there a “reset” procedure somewhere I can try?

My WCO won’t turn on after 100% full charge.

My other two WCOs say OFFLINE but actually they are online and they are just fine.

If the camera still doesn’t turn on, You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

Will do… Thank you …

1 Like

Update: After hours attempting to recharge and reconnect, all the while telling me the camera is out of charge, all of the sudden the charge jumped to 99% and was able to connect to the base, and now is working fine. Still don’t understand how the charge dropped from 41% to zero without sending the customary notification that the charge is now below 20%.

1 Like