Wyze Cam Outdoor won't save password for Travel Mode

I’m trying to set up my Wyze Cam Outdoor for Travel Mode before going on a trip. In order to do this it says I need the Travel Mode Password to be set. I’ve tried repeatedly to enter a password (between 8 and 16 characters long) and it simply does not save it. I started removing special characters and even punctuation, but it still says “Not Set” next to the Travel Mode Password field.

I can’t avoid creating a password either because Travel Mode prompts me for it.

I’ve tried saving the password and then entering it in Travel Mode setup (just in case it’s just an error that it says “not set”) but that doesn’t work either. I tried form two different iPhones.

Trip is Monday - anyone got an idea how to make this work?

Try forcing close of the app and setting the password again. If that doesn’t work, try power cycling the camera and restarting your phone.

Thanks @Brlepage, yes we’ve done that and in fact tried on two different phones without success.

Whalen you connect to the camera, make sure that you use your WiFi not mobile data.
If the issue isn’t solved, you may have to try deleting the WCO and adding it back.

Thanks again, I just figured out the problem. I had the camera in Travel mode (double-pressing the button) before trying to set the password. I put it back in the regular mode, and immediately it took my password (even my long, strong and complex password). Did this with cellular data only as you suggested.

Of course I had to turn WiFi back after entering Travel Mode on the camera in order to connect to it, I can connect to the WiFi signal from the Wyze Cam Outdoor, with it still in Travel Mode, but it keeps saying Connection failed.

I feel like I’m in a Catch-22 situation!

1 Like

Is this happening only in travel mode?
Try turning off your mobile data when in travel mode.