Wyze cam outdoor only recording 7 seconds

My wco only seems to be recording 7 seconds. I have cam plus, and it’s enabled for this cam. I have it set for one minute, but I’ve tried setting it to five minutes and have the same results. I noticed that my videos were getting cut off, and I’ve tested it myself by standing and moving in front of the camera, and I get consistent results. I’ve rebooted the camera, the base, my wifi, and tried multiple setting changes with now luck. The only thing I’ve not done is completely remove the device and reset it up in my app. If I have to go through this step I’m probably taking it down for good and looking elsewhere for cameras. Anyone else seeing this issue?

To he clear, you are saying that if you stand in front of the camera and continue to move around for 45 seconds, it will only record the first 7 seconds of that continuous movement?

Yeah.

You can try removing the cam plus licence from the WCO, go back to the main screen, exit the app, go back into the app and re-add the license. Maybe wait like 30 minutes before you test the camera again and make sure sensitivity is set to 100 to test. Another option is to try the beta firmware.

I am experiencing the exact same issue right now and cannot figure it out. Did you come to any conclusions?