Wyze Bulb: unable to finish pairing, Connection timed out

Thanks to you all :+1: I turned off mobile data , Setting up the bulbs was a breeze, no problems

You guys helped me as well with a lot of your tips. Even so, I could not set up the bulbs from my boys fan light, for whatever reason. So I moved them to a lamp in our bedroom and was able to set them up immediately. Once set up, I moved them back to the fan light with no issues. So I would suggest trying a different lamp if you can’t get them working.

So one the bulb was setup were you able to switch the WiFi setting back or did you have to leave it in 2.4 mode.

Disabling mobile data on my android phone worked for me. Thanks

After I set up my bulbs I switched my phone back to 5 G And it works Perfectly This may depend on how your router is set up though

I set up all bulbs individually in a desk lamp near the router, After they are set up I moved them to the fixtures I wanted

1 Like

Found a work around that worked for me on all of my bulbs.

TLDR: Just press the Retry button.

All - I was having the connection timeout issue as well. I tried to restart the pairing process many times and always ran into the same issue. I am on an iPhone and have Google WiFi.

I’d turn on each bulb three times and it would pulse. I’d enter my wifi password, connect to the bulb WiFi network, switch back to the Wyze app. It would start the connection count down. About 15-20 seconds into the countdown I’d see the connection timeout message, and the bulb would stop pulsing.

After trying this multiple times I tried to just press Retry on the screen showing the connection timed out message. After a couple seconds of the countdown again it would be successful and asked me to name the bulb.

Ran into the same issue on the next bulb, and the same process worked again…pressing the Retry button right after seeing the connection timed out message.

I have an older FiOS router, 2.4GHz only, which was set to “Performance mode (802.11n)” and the bulbs failed to connect to my local network. Changing the router to “Compatibility Mode(802.11b/g/n)” enabled everything to work. Thanks for the tip…

In one of my unsuccessful setup attempts, in addition to turning off cellular (I think this is an Andriod-only fix)I I tried turning off “Auto-Join” for my home network SSID in the iOS Settings before running the setup process again to force my iPhone to stay on the bulb’s wifi AP.
My iPhone’s wifi connection to the bulb was still maintained when I switched back to the Wyze app, yet I still got a timeout as usual, unfortunately.

Turning off cellular data as potentially the only thing you need to do to fix the setup problem appears to be an Android-only fix.

I didn’t read every single message here, so sorry if this has already been mentioned.

All I had to do to get my bulb to connect (Android) was to turn off the Advanced WiFi option called “Avoid Bad WiFi Connections” which causes the phone to use the cellular network if the Wifi connection does not have Internet access.

I did have one failed attempt where the phone jumped off the bulb and onto the regular wifi, but the next try worked fine. What you don’t want it to do is use the cellular network. Turning off cellular data likely accomplishes the same thing.

I don’t see why it would matter whether the phone connects to the 2.4 or 5 GHz variant of the SSID. The point of the pairing procedure is presumably to communicate the SSID and password to the bulb. Google WiFi uses the same password on both frequencies for any given SSID. You’re connecting to the bulb’s temporary SSID only in order to convey the SSID/password of your permanent WiFi to the bulb.

1 Like

I don’t know why either. All I know is that my phone will not let me set up the bulbs but my wife’s can, no problem.

Pixel 2 tried fixes, uninstalled Beta reinstalled public, App now crashing

update I used old Nexus 7 tablet runs only 2 ghz setup went straight through, can access on pixel 2…!!!:footprints:

I also had the pairing problem – tried with two different bulbs. Clearly the issue is communication with a WiFi AP that has no internet service. On my Pixel 2, I was unable to find a setting to disable the automatic switchover from “bad WiFi” to cell data, so I had to switch off cell data.

I strongly recommend that Wyze PROMPTLY update the Android app to suggest that users turn off Cell Data prior to starting the pairing process.

1 Like

I have also had the same issue. Wyze products usually pair quickly and easily. Now I can not update my pan cam. Updated and restarted phone and app. Turned mobile data off. Only on 2G network and NOTHING. Can’t get any of these lights to pair. Kind of want my money back if this can’t be resolved.

1 Like

If you are having trouble with bulb setup, see if any of these suggestions help:

1 Like

Or just fix the app so it works like just about any other IoT setup program. I’ve connected various sorts of devices to my local network and have never had these sorts of issues.

Hopefully the Wyze folks are working on an actual fix instead of some sort band-aid solution.

I too have 4 bulbs still in the box. I’ve been trying for 4 days. I have tired Pixel 3, wife’s iPhone, and my Chromebook. I have turned my router back to “legacy” shutting of N.

I get to the countdown part of adding a new bulb. It flashes and stuff. But then never finishes. And yes cellular data is off.

Dear Wyze, whats up?