Wyze bulb setup with google home

Hi, just got my Bulb order. When attempting to setup my new bulb I had trouble connecting to the bulb wifi network as directed to in one step of the setup. My Samsung phone kept reverting back to my normal wifi network because there was no internet available on the wyze bulb network. I ended up having to use my tablet which allowed me to temporarily connect to the bulb wifi. So now that I have the bulb connected and named in the wyze app, I am unable to connect it in the google home app. I already had my 2 wyze cameras added to the Google home assistant, but it won’s see my bulb. I tried several different ways but was unable to see the bulb. just a note that the wyze connected client within the google home app says 2 devices are connected which I assume are the cameras. Just another concern, after running the bulb for about 40 minutes the base is about 145 degrees …. a lot hotter than expected. I was looking for anyone else running into the google home not seeing the bulb and how they were able to get Google to see the bulbs.

1 Like

I had the same trouble connecting my first bulb as well it took five or six times …the phone kept warning me that the wyze bulb may not have an internet connection… by dismissing that warning I was able to finally complete the setup process… Yesterday, the bulb was working great… but today I’m finding the bulb offline and I’ve had no success in getting it to reconnect… all my other cameras and sensors are online and working fine… Wi-Fi running great… I’m stymied

SOLVED!
I unlinked my Wyze account in Google Home app and re-linked it … my two cameras and my new light showed up😀 all I had to do is re-assign the cameras and assign my newly set up bulb. I plan on grouping several bulbs and installing them in my media room using voice control & experimenting with ifttt .

4 Likes

One additional thing to note here is that I think some phones (mine at least) are swapping over to your cellular connection when they don’t see an “internet” connection via WiFi. That appears to be the case with the initial bulb setup. Mine failed twice before I disabled my cellular connection and then flew through the setup with ease. I had this same problem with a “smart” garage door opener recently that had the same connection method (connect to WiFi -> connect to open WiFi on the IoT device to “share” the original WiFi info).

I’m in this thread because I’m having the same problem with Google “seeing” the new bulb(s). It sees my cameras, but not the new bulbs. Is there a particular timing where Google checks the linked accounts and updates them for new items. Is this a push or a pull?

I guess I could link and unlink, but I’m in the middle of a beta test for another Wyze product and don’t want to mess anything up. :wink:

1 Like

I’m not sure how google works, all I can say for sure is that un-linking & re-linking resulted in everything working. I was even able to group the bulbs & google saw the group as well.

Kinda wish that you wouldn’t have to unlink the Wyze account and then re-link it to Google Home every time you add a Wyze device. (E.g., create Wyze account with 2 cameras, link to GHome. 2 devices shown in GHome. Add a Wyze bulb and add it to Wyze account, still only 2, not 3, devices shown in GHome. Have to unlink Wyze account from GHome and then re-add Wyze account for GHome to recognize the new bulb. Have to repeat steps if any more cameras or bulbs added.) Maybe in a future update they’ll address that.

You shouldn’t have to, when I add a WYZE device it appears in my Google account, I just have to place it in a home and room and then it works. Until I do that it shows up at the bootom as ‘Linked to You, not in a home’

@Jason21271 is correct. You shouldn’t have to do a relink. This is a Google Home app issue. I have found when devices haven’t shown up yet in my Google Home app, I swipe downward to initiate a refresh, and then the devices show up in the bottom of the app. Hope that helps! :slight_smile:

Below is from the Google Support pages

Sync your devices in the Google Home app

  1. Open the Google Home app .
  2. Tap Account Settings or More settings Assistant Home control.
  3. Swipe down with your finger on the screen.
  4. You will see a spinning circle. The sync is complete when the circle disappears.
  5. Check for your device in the Home control list.
1 Like