WYZE bulb color and scheduling

I have schedules that are supposed to turn the bulbs on and off at a certain time. These bulbs will not shut off. I came home today to find they were still running even though I clearly have a schedule for thursdays to turn on at 6:45am and to turn off at 9am.

First no bi-weekly scheduling and now the scheduling that is allowed isn’t even followed.

:face_with_symbols_over_mouth:

I have even deleted my schedules and re-set them back up and still the result is the same.

Would you mind posting your Rules so the community can look into it as well. In addition, are you sure there is no trigger rules setup in the App or Alexa to turn lights on when something happens?

In the App, you can go to Acount>Rules>History. There you can see if the Rules you set were successfully run or if there was any errors.

No there are no rules setup with Alexa. Screenshots forthcoming.

Screenshots. I have two rules setup. One for “trash day” which are for Mondays and Thursdays.

The second one is for “evening” which is every day.

I’ll try to upload the screenshots in order as I had to





take 2 screenshots for the setup since the length of information on the setup screens are too long.

Second set of images for the second rule




In your rules, under the “Add Action” section, simply remove your Turn Off entries. Your selected End Time turns off your bulbs and your redundant turn off action conflicts.

1 Like

It appears the rules history show succeeded. However, doesn’t appear to be processing the turn off most of the time. And when it laps with Mondays and Thursdays, where it is supposed to turn off at 6am (from being on the previous night at 7:30pm) and then turn back on at 6:45am and turn off at 9am (the two trash day setups) it doesn’t appear to do anything.

I think the way this is even supposed to be setup is redundant. Why have the option in both areas under scheduling. You can have an optional time for turn off, but it’s not an option to have a time for turn on. So there should be “no action” to apply for either given the two time fields. With that said, I’ll give that a shot.

Thank you.

And also, if what you’re saying is correct, then why should I also have a turn on action when the time is already set for that too?

I was just going to say that…

should be removed.

1 Like

The Start time sets the action, the optional end time it will turn them off. You you want to make sure they go off, you can remove the Turn off from the list of actions, create another rule for the end time and simply set it to turn the lights off.

Need to read the note at the bottom of your rules. When you use a device that has an on/off feature in a rule, the actions specified run at the start time and the inverse (Off in your case) run at end time.

Every action listed in a rule runs at start time. That means at 6:45am on Mondays and Thursdays, your driveway lights turn on with 100% brightness with your specified color and turn off. All of these actions run at your start time.

Just remove your Turns Off actions from rules, hit Save in the upper right and your rules will work.

1 Like

I read that section, I misinterpreted it. I’ve made the changes and will check to make sure they’re processing correctly. Thank you to you both for the assistance.

1 Like

Thank you to you both for the assistance.

With regards to the suggestion of creating another rule to turn them off, I initially thought about doing that, but then that’s where I came across the part where the “on time” isn’t optional. If that were optional like the “off time”, then I would have went forward with another rule to “turn off”.

Am I misinterpreting that as well?

If you are going to set a time for the event to fire, you will always have to set a start time. The end time is optional because you may need it on and manually turn it off or you have an additional rule to turn it off. You can leave yours the way it is and simply remove the Turn-Off Step and you should be fine.

I personally have a rule to turn lights on at a certain time and the another rule to turn them off at a certain time. With the previous Rules engine, I had issues and this is how I got it resolved. But in the new engine, it seems to be working, but I left mine as is. :slight_smile:

2 Likes

So, the problem still persists. For some reason these bulbs do not want to follow the schedule. I changed my rules entirely based on this discussion thread. I created two rules for Monday and Thursdays.

The first rule has a start time of 6am and the bulbs are set to two actions: a specific brightness and color. There is NO end time set.

The secondary rule has a start time of 9am and the action is simply: turn off. There is NO end time set.

Today is Thursday. The bulbs turned on at 6am and at the specified brightness/color.

At 10:46am the bulbs were still on.

When I first set these rules up, I tested them at a minute apart and they worked. Now, they’ve reverted back to the same issue: not following the rule/action.

Can someone shed some light?

I have attached two photos depicting the rules described above.

Thanks.


Turned on? Your rule actions shows that they should turn off at 9am, not on.

Does your 6:00 a.m. rule have the turn on action hidden from your screenshot? Are all actions shown? I would think you would still need to have the turn on action at this time to actually turn on the bulb.

Do you have any other rules? Any other rules that change the bulk colors to something else? If your bulb colors never change, and the brightness never changes, you don’t need to keep having a rule action that sets the color and brightness. It’ll remember that the next time you turn your bulb on.

What does your rules history say for the 9am rule? You said previously the 9:00 a.m. rule turns the bulbs on, but the screenshot says they should have turned off. If you don’t know where it is the rules history is if you go to account then rules then there should be a history tab. This tells you the status of executed rules if they fail or ran successfully. You can expand each line to show the status of each action.

The statement of turning on at 9am was a typo. When corrected to say 6am, it relates exactly what the entirety of the post described along with the screenshots.

Yes, I have a different color applied for other times throughout the week.

The screenshots have nothing hidden. All actions are shown in the screenshots attached.

I’ll attach the rules history, but again, it was simply a typo.

Here are screenshots from the history tab. You can see that on last Sunday, the lights turned on at 7:30pm.

Then on Monday at 5am, they turned off.

Then on Monday, they turned on again at 6am.

On Monday, they were also set to turn off at 9am, and they did, so correct again.

Lastly, on Monday, they were set to turn on again at 7:30pm and once again, they did so, which is correct.

Monday performed as expected.

Screenshots of history shown below.



Now, let’s skip to Thursday.

Wednesday evening, lights were set to turn on at 7:30pm, and they did.

Then they were set to turn off at 5am on Thursday, and they did.

Next, they were set to turn on at 6am on Thursday, and they did.

Then, you can see it skipped the turn off time that clearly happened for Monday (even though Thursday is part of the same rule as Monday), and it went straight to turning on at 7:30pm.

Screenshots for Wednesday to Thursday attached.


I’m going to create a specific turn off rule for Thursday only. Separate it from Monday. Let’s see how that goes.