Wyze Band Woes

So fun story:
Wyze band 98% battery status last I looked. Decides to go black screen. It has been sitting on a charger for 3 days now and hasn’t come back. So far one of the lightest paper weights on my desk. Complete disaster as I had the Band for a couple days and now it doesn’t work at all. Tried multiple USB chargers, ports on multiple PCs and nothing brings this thing back from the dead. Love the Cams and continue to use them but wow really disappointed with the Wyze band.

I got a black screen soon after the firmware update. Try holding down on the home button thing until the menu pops up. I was able to get it to reboot with that method.

1 Like

Yeah sadly I’ve tried that and no dice. Either the battery is dead or this thing itself is dead. I mean 4 days on charger repeatedly pressing on the button, repeatedly holding the button till my hand gets tired… nothing.

Just randomly came back to life, updated to the latest firmware on the stable app and seems to be good now for a couple days.

Sounds perfect, that’s about how often I exercise anyway.